diff --git a/testing/frr/APKBUILD b/testing/frr/APKBUILD
index 041ec01a2abc7babb5cee56cb277db1bb560eb1c..850008f80e3acdacfdb8a76fd3c9497e34899be6 100644
--- a/testing/frr/APKBUILD
+++ b/testing/frr/APKBUILD
@@ -8,14 +8,18 @@ pkggroups="frr"
 url="https://frrouting.org/"
 arch="x86_64"
 license="GPL-2.0-only and LGPL-2.1-only"
-depends="json-c c-ares iproute2 python2 py-ipaddr bash"
-makedepends="ncurses-dev net-snmp-dev gawk texinfo perl
-    acct autoconf automake bash bison bsd-compat-headers
-    c-ares-dev cryptsetup-libs device-mapper-libs flex
-    json-c-dev kmod lddtree libacl libblkid libburn libedit
-    libisoburn libisofs libltdl libtool libuuid linux-headers lzo m4 mkinitfs
-    mtools pcre perl python2-dev readline-dev
-    squashfs-tools texinfo xorriso py-sphinx"
+depends="iproute2 python2 py2-ipaddr bash"
+makedepends="autoconf automake libtool
+	bsd-compat-headers
+	c-ares-dev
+	flex bison
+	json-c-dev
+	linux-headers
+	py-sphinx
+	python3-dev
+	readline-dev
+	texinfo
+	"
 checkdepends="pytest py-setuptools"
 install="$pkgname.pre-install"
 subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg $pkgname-openrc"
@@ -47,7 +51,6 @@ build() {
 
 check() {
 	cd "$builddir"
-
 	make -j 1 check
 }