diff --git a/community/py3-holidays/APKBUILD b/community/py3-holidays/APKBUILD
index 6aff48e75df89a398562f8e989c8ae921d834629..153590ba9a34c16512f4cb1c71f26d2833921198 100644
--- a/community/py3-holidays/APKBUILD
+++ b/community/py3-holidays/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Bart Ribbers <bribbers@disroot.org>
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=py3-holidays
-pkgver=0.17.2
+pkgver=0.22
 pkgrel=0
 pkgdesc="Generate and work with holidays in Python"
 url="https://github.com/dr-prodigy/python-holidays"
@@ -16,6 +16,7 @@ depends="
 	"
 makedepends="py3-setuptools"
 checkdepends="py3-pytest"
+subpackages="$pkgname-lang"
 source="https://pypi.python.org/packages/source/h/holidays/holidays-$pkgver.tar.gz"
 builddir="$srcdir/holidays-$pkgver"
 # AttributeError: 'TestAllInSameYear' object has no attribute '_feedErrorsToResult'
@@ -33,6 +34,13 @@ package() {
 	python3 setup.py install --skip-build --root="$pkgdir"
 }
 
+lang() {
+	pkgdesc="Languages for package $pkgname"
+	install_if="$pkgname=$pkgver-r$pkgrel lang"
+
+	amove usr/lib/python3*/site-packages/holidays/locale
+}
+
 sha512sums="
-8e38dba73daea2f6b71fd4266149655642506c5892440ae7bedc954e28b9fae520639b004316383b8ac0471424439d8e447870f4c8b992fe415a0db13f8ef9a6  holidays-0.17.2.tar.gz
+c61c9a3d3aab5daf8ee401a164b22016b8e59ae1b9cee593b1042c3bf80c6f98ffa2dec8ebf8225c667dee1714c547d925fd7f27f112699b7a378dca5aeeea20  holidays-0.22.tar.gz
 "