diff --git a/community/R/APKBUILD b/community/R/APKBUILD
index e8e8da03c40cb80cb6b895cfdb1a318cad951d98..c345e7a5b6c5a2662c71e8bb014d17326f2e25f9 100644
--- a/community/R/APKBUILD
+++ b/community/R/APKBUILD
@@ -6,8 +6,7 @@ pkgver=3.4.3
 pkgrel=0
 pkgdesc="Language and environment for statistical computing"
 url="https://www.r-project.org"
-# ppc64le: segfaults in build since 3.4.3
-arch="all !s390x !ppc64le"
+arch="all !s390x"
 license="GPL-2 GPL-3 LGPL-2.1"
 depends="$pkgname-mathlib"
 depends_dev="gcc gfortran icu-dev libjpeg-turbo libpng-dev make openblas-dev
@@ -53,8 +52,8 @@ build() {
 		--with-tcltk \
 		--with-x
 
-	make
-	make -C src/nmath/standalone
+	make -j1
+	make -j1 -C src/nmath/standalone
 }
 
 # TODO: Run provided test suite.