diff --git a/community/linux-edge/APKBUILD b/community/linux-edge/APKBUILD
index e6691792febf646bd0deccdd596ccbebb729e550..902a9ddc3252191797a0c27ac32d4dd154fd558c 100644
--- a/community/linux-edge/APKBUILD
+++ b/community/linux-edge/APKBUILD
@@ -4,7 +4,7 @@ _flavor=edge
 pkgname=linux-${_flavor}
 # NOTE: this kernel is intended for testing
 # please resist urge to upgrade it blindly
-pkgver=6.0.6
+pkgver=6.0.7
 case $pkgver in
 	*.*.*)	_kernver=${pkgver%.*};;
 	*.*) _kernver=$pkgver;;
@@ -35,7 +35,6 @@ esac
 	config-edge.riscv64
 
 	fix-speakup.patch
-	revert-platform-x86-amd-pmc-Read-SMU-version-during-suspend.patch
 	"
 
 builddir="$srcdir/linux-${_kernver}"
@@ -270,11 +269,10 @@ _doc() {
 
 sha512sums="
 bac41a7aeb6e809616cee2f13dcd1c45e829dfd1ccf60aee1dc4c46b1e28532f4485c7d819a32940de84fdfbf89db80a4e919bce8a74b2948c5a01551771b714  linux-6.0.tar.xz
-a19469f06a8461cd091cfc74c070d367c7d34ad2fd0fe1186f94ce7d7521b2702cd0916d6cd5682bae27651f7a530bea5423574a7834f19347f177a0a1f6e809  patch-6.0.6.xz
-4d540c0faf40f51f30376fb98dd2441c120db53b22a45984fa7beaabae76fa783c27fa9f15a6725cd694d599f2aeba36fff545654c36138678e086759ba753ef  config-edge.aarch64
-668d60ca289756ee48c96c86abab6c238224f06631b783874413822a0cbd1f58f9933dd7e7ae2c626d1afaeaabeefe38975862bbc0b660a7375e4bd5b0116e29  config-edge.armv7
-37e801d3e00540cf4814c96157972b8510924f3044d285e3eac768b8344ea37021a86028cdead352e1c64a1521a383adfc9cf45c34f4d0d9cfd283ddb359d8fa  config-edge.x86_64
-d76097e1d8fe96fc786f6e55201b6f2c2624c24cc040e971c0fa842244517dc5d960e911c92c29f6d381c64d62153f815645d7a38bee4556f80db4dace61d1c4  config-edge.riscv64
+a25570a289580cd8ca0365a007948b69236517efb4fe53b0f99697bbb8321174f827c2fff24903301eeaec1068456e2fbf2321ef7884e78347211e2b58f09809  patch-6.0.7.xz
+02bb9616b97a6004063c980c55071e4422583828ed9912b460bfbd9aca434fc1cf6e8be7f4482348c6793c85fc4a5db3eeb740d344c357ab6c2893e54dd08b15  config-edge.aarch64
+7e4f299865e08578ecc6a2eb213dc72dbbe49bf9f83316be043c54885cbc3c6e2eb335dbefc3de62b6ab09969916d8c12b5532b5a02a9c45fc85f1224d4aeab7  config-edge.armv7
+8a1ae93ad2fbd79d85ddb0c2da9cadd1c0d4f8a07542ceb351c2fea677bfd1950536bf3c69145efd34c28cfa3238412840da260fe0e346afbe546612d92eaf05  config-edge.x86_64
+76e2e571cd2336a69c366b5b1ab96ceeb8312d1901b1948f5bb85bc6f2fe030ad991f0465c61d2c88d8fc7135c3390eaae3007ba86284045de728f15ddd7842e  config-edge.riscv64
 502670e35baa59cb18715d10af37b90cd0dc3f3ab1a0b3b8b11f7bdd974c44628ef704ea62d1d4ec6e5a819eb57533627bb05f6bdbb8ac6139e6f99b4c2bec63  fix-speakup.patch
-fa94cca7259c0ff6974974cf6d4362aac73c7adae4a514613248b23c514855987173d2411daf9968ab71da4140da113b994fc2fec1a4327812307983e4c1e036  revert-platform-x86-amd-pmc-Read-SMU-version-during-suspend.patch
 "
diff --git a/community/linux-edge/config-edge.aarch64 b/community/linux-edge/config-edge.aarch64
index f1db409a0db4c65d87a0293443b97e318bbc7db4..c399d65c57013fb5e8e59b50816ad3f203608dec 100644
--- a/community/linux-edge/config-edge.aarch64
+++ b/community/linux-edge/config-edge.aarch64
@@ -1,6 +1,6 @@
 #
 # Automatically generated file; DO NOT EDIT.
-# Linux/arm64 6.0.6 Kernel Configuration
+# Linux/arm64 6.0.7 Kernel Configuration
 #
 CONFIG_CC_VERSION_TEXT="gcc (Alpine 12.1.1_git20220630) 12.1.1 20220630"
 CONFIG_CC_IS_GCC=y
diff --git a/community/linux-edge/config-edge.armv7 b/community/linux-edge/config-edge.armv7
index 4f77f2f4a2aaaccc574733279d5345c182d390fd..84087b96ed41db99b68e63270760766bcd1087ea 100644
--- a/community/linux-edge/config-edge.armv7
+++ b/community/linux-edge/config-edge.armv7
@@ -1,6 +1,6 @@
 #
 # Automatically generated file; DO NOT EDIT.
-# Linux/arm 6.0.6 Kernel Configuration
+# Linux/arm 6.0.7 Kernel Configuration
 #
 CONFIG_CC_VERSION_TEXT="gcc (Alpine 12.1.1_git20220630) 12.1.1 20220630"
 CONFIG_CC_IS_GCC=y
diff --git a/community/linux-edge/config-edge.riscv64 b/community/linux-edge/config-edge.riscv64
index 5558e97721d459ac7de899e6d6f855d99dc2ba2a..246ab6a19a4ba7352e24b94565ca58c484dc10ab 100644
--- a/community/linux-edge/config-edge.riscv64
+++ b/community/linux-edge/config-edge.riscv64
@@ -1,6 +1,6 @@
 #
 # Automatically generated file; DO NOT EDIT.
-# Linux/riscv 6.0.6 Kernel Configuration
+# Linux/riscv 6.0.7 Kernel Configuration
 #
 CONFIG_CC_VERSION_TEXT="gcc (Alpine 12.2.1_git20220924-r2) 12.2.1 20220924"
 CONFIG_CC_IS_GCC=y
@@ -295,8 +295,9 @@ CONFIG_TUNE_GENERIC=y
 CONFIG_RISCV_ALTERNATIVE=y
 CONFIG_RISCV_ISA_C=y
 CONFIG_RISCV_ISA_SVPBMT=y
-CONFIG_CC_HAS_ZICBOM=y
+CONFIG_TOOLCHAIN_HAS_ZICBOM=y
 CONFIG_RISCV_ISA_ZICBOM=y
+CONFIG_TOOLCHAIN_HAS_ZIHINTPAUSE=y
 CONFIG_FPU=y
 # end of Platform type
 
diff --git a/community/linux-edge/config-edge.x86_64 b/community/linux-edge/config-edge.x86_64
index 8fece0863c07986bca0e5d63ef12353cc62fa751..ca708e87addbd01dbd85b7b08685886605f04b5f 100644
--- a/community/linux-edge/config-edge.x86_64
+++ b/community/linux-edge/config-edge.x86_64
@@ -1,6 +1,6 @@
 #
 # Automatically generated file; DO NOT EDIT.
-# Linux/x86_64 6.0.6 Kernel Configuration
+# Linux/x86_64 6.0.7 Kernel Configuration
 #
 CONFIG_CC_VERSION_TEXT="gcc (Alpine 12.2.1_git20220924-r3) 12.2.1 20220924"
 CONFIG_CC_IS_GCC=y
diff --git a/community/linux-edge/revert-platform-x86-amd-pmc-Read-SMU-version-during-suspend.patch b/community/linux-edge/revert-platform-x86-amd-pmc-Read-SMU-version-during-suspend.patch
deleted file mode 100644
index b55e53b52693e31316e8000f0eca25099267be93..0000000000000000000000000000000000000000
--- a/community/linux-edge/revert-platform-x86-amd-pmc-Read-SMU-version-during-suspend.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/drivers/platform/x86/amd/pmc.c b/drivers/platform/x86/amd/pmc.c
-index 96e790e639a2..ce859b300712 100644
---- a/drivers/platform/x86/amd/pmc.c
-+++ b/drivers/platform/x86/amd/pmc.c
-@@ -663,13 +663,6 @@ static int amd_pmc_verify_czn_rtc(struct amd_pmc_dev *pdev, u32 *arg)
- 	struct rtc_time tm;
- 	int rc;
- 
--	/* we haven't yet read SMU version */
--	if (!pdev->major) {
--		rc = amd_pmc_get_smu_version(pdev);
--		if (rc)
--			return rc;
--	}
--
- 	if (pdev->major < 64 || (pdev->major == 64 && pdev->minor < 53))
- 		return 0;
-