diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index 1424a7a535a329b6a5fe63b9b69cd27bf24dacf3..a11bb5958ee28d2282ff00df6051f9ac47ef8491 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -5,9 +5,9 @@
 # Contributor: Ariadne Conill <ariadne@dereferenced.org>
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=rust
-pkgver=1.57.0
+pkgver=1.58.0
 _llvmver=12
-_bootver=1.56.1
+_bootver=1.57.0
 pkgrel=0
 pkgdesc="The Rust Programming Language"
 url="https://www.rust-lang.org/"
@@ -350,7 +350,7 @@ _mv() {
 }
 
 sha512sums="
-7903bcfc7c1db208da5d5991bd5b7f55dbe5917d4814274a8badf0d3b767211e81f8626c355ea93142f236abf116d5921c0b542ef309fbe84ece1ce84e5af30f  rustc-1.57.0-src.tar.xz
+70104f4d3b474dcb9935200ef0503f29cb15f10d38ba8630e1dadbb384924dd9137fced647794699efe83ac88083e4ae5f45712f0e1c8bc0a6f8c23eecdb0aeb  rustc-1.58.0-src.tar.xz
 4accbdf546e9f82f38d56169f65fcfb53839e1df89978b9a434a59a1dcb80b4d57c0272c0ece65530ce09ad0f7a7e880b4b97e2b8dd8f2bccace02a5874e6733  musl-fix-linux_musl_base.patch
 2d401a01d2c2db92624d672018342907a41aa4a3842708c0a2ab694af0396d568aca4835d1075f244d77c0a4c45e67f893fd175fd97cd7f758090eba9972eba6  need-rpath.patch
 bc28e1edae88f48eb0368cd0905280c323d521c7e13b6fc2bb1fb6e57274fa418afdc9cb3342f4928842e309d0573b98e82976159541c88b35694dceaf7a82e4  need-ssp_nonshared.patch
@@ -358,7 +358,7 @@ bc28e1edae88f48eb0368cd0905280c323d521c7e13b6fc2bb1fb6e57274fa418afdc9cb3342f492
 063469591de555f133339c8c9a3cf45bfc059a9b6bd57268068166bc065ef99fa1fb958a1bc42df4097eb59122d49d32e45bc31a44dc030ca3578d99fd39ff9e  alpine-target.patch
 7d59258d4462eba0207739a5c0c8baf1f19d9a396e5547bb4d59d700eb94d50ba6add2e523f3e94e29e993821018594625ea4ac86304fb58f7f8c82622a26ab0  install-template-shebang.patch
 c31fdfe8a9b3411576c75da46645cf0465b9053000a2ab49cf9b2f2733f679d6d33acbf236d67a20e14935d094a685453b7f1840180249f39d610fd0902c3125  check-rustc
-d5d3ccc5c3a73bf1816106ba00805346ea28f2e6337d960e9e9f776ba59d22abd8864382f163d32dd9a278df38c080949dafc70169728f44080ddc04f1e7f125  link-musl-dynamically.patch
+0bdcc06f1765f8f5655ac960ef8214018c31feacfcf407d836ff70e42b47be266e805e98e7e1a689d610d36d89086a7e56a345ac92c903714e65126fe2d83228  link-musl-dynamically.patch
 d368c955b058e7b57d91f53fbebf1030f2d2826b0ffb0a85db5aa54baee7bd44371491cc373101846232f91fd383dd15aa1cd245fb8f439d35813ac4017be419  0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch
 7af23c34096f7a03c5a1b40aa07e00dd6193743c872881018a9baa900f240c6e44918e481ab5ed7787a70ef361e4aeec2a7719bcd695f52988262e23271b44e5  0007-do-not-install-libunwind-source.patch
 4cb2592d30cd1a776375522631aa284dd077eaa39b109921d6ee5906fd0130b048e07d3adef1d7221f5c001d1df5187feb3e3687e0aa5d19279099065a7d4cb7  mips-softfloat.patch
diff --git a/community/rust/link-musl-dynamically.patch b/community/rust/link-musl-dynamically.patch
index b3d7cab69a625b98a3f901425ce433939d8c3dcd..55d02a32421c1d7954b41ebff2521cdd36bedc31 100644
--- a/community/rust/link-musl-dynamically.patch
+++ b/community/rust/link-musl-dynamically.patch
@@ -1,14 +1,14 @@
---- rustc-1.38.0-src/vendor/libc/src/unix/mod.rs
-+++ rustc-1.38.0-src/vendor/libc/src/unix/mod.rs
-@@ -297,11 +297,11 @@ cfg_if! {
-         // cargo build, don't pull in anything extra as the libstd dep
-         // already pulls in all libs.
+--- rustc-1.58.0-src.orig/vendor/libc/src/unix/mod.rs
++++ rustc-1.58.0-src/vendor/libc/src/unix/mod.rs
+@@ -329,11 +329,11 @@
+         #[link(name = "c", cfg(not(target_feature = "crt-static")))]
+         extern {}
      } else if #[cfg(target_env = "musl")] {
-+        #[link(name = "c")]
-+        extern {}
++	#[link(name = "c")]
++	extern {}
          #[cfg_attr(feature = "rustc-dep-of-std",
--                   link(name = "c", kind = "static",
-+                   link(name = "gcc", kind = "static-nobundle",
+-                   link(name = "c", kind = "static", modifiers = "-bundle",
++                   link(name = "gcc", kind = "static", modifiers = "-bundle",
                          cfg(target_feature = "crt-static")))]
 -        #[cfg_attr(feature = "rustc-dep-of-std",
 -                   link(name = "c", cfg(not(target_feature = "crt-static"))))]