From 4cedf677fe09d71ad8480b66b3a13c5047053cfe Mon Sep 17 00:00:00 2001
From: Leo <thinkabit.ukim@gmail.com>
Date: Tue, 2 Nov 2021 15:16:52 -0300
Subject: [PATCH] testing/*: remove stale patches

---
 ...TH-Simplify-FluidSynth-version-check.patch |  58 ---------
 ...-Fix-compilation-with-Fluidsynth-2.2.patch | 111 ------------------
 .../allow-llvm-11-1-0.patch                   |  11 --
 3 files changed, 180 deletions(-)
 delete mode 100644 testing/scummvm/0001-FLUIDSYNTH-Simplify-FluidSynth-version-check.patch
 delete mode 100644 testing/scummvm/0002-FLUIDSYNTH-Fix-compilation-with-Fluidsynth-2.2.patch
 delete mode 100644 testing/spirv-llvm-translator/allow-llvm-11-1-0.patch

diff --git a/testing/scummvm/0001-FLUIDSYNTH-Simplify-FluidSynth-version-check.patch b/testing/scummvm/0001-FLUIDSYNTH-Simplify-FluidSynth-version-check.patch
deleted file mode 100644
index 6ad41190cf58..000000000000
--- a/testing/scummvm/0001-FLUIDSYNTH-Simplify-FluidSynth-version-check.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Backported from 631b13b5f4990b667e19d9fbdc467f0c873b6c15 Mon Sep 17 00:00:00 2001
-From: Le Philousophe <lephilousophe@users.noreply.github.com>
-Date: Mon, 5 Apr 2021 12:22:51 +0200
-Subject: FLUIDSYNTH: Simplify FluidSynth version check
-
---- scummvm-2.2.0-orig/audio/softsynth/fluidsynth.cpp
-+++ scummvm-2.2.0/audio/softsynth/fluidsynth.cpp
-@@ -46,6 +46,14 @@
- #include "backends/platform/ios7/ios7_common.h"
- #endif
- 
-+// We assume here Fluidsynth minor will never be above 255 and
-+// that micro versions won't break API compatibility
-+#if defined(FLUIDSYNTH_VERSION_MAJOR) && defined(FLUIDSYNTH_VERSION_MINOR)
-+#define FS_API_VERSION ((FLUIDSYNTH_VERSION_MAJOR << 8) | FLUIDSYNTH_VERSION_MINOR)
-+#else
-+#define FS_API_VERSION 0
-+#endif
-+
- class MidiDriver_FluidSynth : public MidiDriver_Emulated {
- private:
- 	MidiChannel_MPU401 _midiChannels[16];
-@@ -75,7 +83,7 @@
- 
- 	void setEngineSoundFont(Common::SeekableReadStream *soundFontData) override;
- 	bool acceptsSoundFontData() override {
--#if defined(FLUIDSYNTH_VERSION_MAJOR) && FLUIDSYNTH_VERSION_MAJOR > 1
-+#if FS_API_VERSION >= 0x0200
- 		return true;
- #else
- 		return false;
-@@ -134,7 +142,7 @@
- 
- // Soundfont memory loader callback functions.
- 
--#if defined(FLUIDSYNTH_VERSION_MAJOR) && FLUIDSYNTH_VERSION_MAJOR > 1
-+#if FS_API_VERSION >= 0x0200
- static void *SoundFontMemLoader_open(const char *filename) {
- 	void *p;
- 	if (filename[0] != '&') {
-@@ -166,7 +174,7 @@
- 	if (_isOpen)
- 		return MERR_ALREADY_OPEN;
- 
--#if defined(FLUIDSYNTH_VERSION_MAJOR) && FLUIDSYNTH_VERSION_MAJOR > 1
-+#if FS_API_VERSION >= 0x0200
- 	// When provided with in-memory SoundFont data, only use the configured
- 	// SoundFont instead if it's explicitly configured on the current game.
- 	bool isUsingInMemorySoundFontData = _engineSoundFontData && !ConfMan.getActiveDomain()->contains("soundfont");
-@@ -246,7 +254,7 @@
- 	const char *soundfont = !isUsingInMemorySoundFontData ?
- 			ConfMan.get("soundfont").c_str() : Common::String::format("&%p", (void *)_engineSoundFontData).c_str();
- 
--#if defined(FLUIDSYNTH_VERSION_MAJOR) && FLUIDSYNTH_VERSION_MAJOR > 1
-+#if FS_API_VERSION >= 0x0200
- 	if (isUsingInMemorySoundFontData) {
- 		fluid_sfloader_t *soundFontMemoryLoader = new_fluid_defsfloader(_settings);
- 		fluid_sfloader_set_callbacks(soundFontMemoryLoader,
diff --git a/testing/scummvm/0002-FLUIDSYNTH-Fix-compilation-with-Fluidsynth-2.2.patch b/testing/scummvm/0002-FLUIDSYNTH-Fix-compilation-with-Fluidsynth-2.2.patch
deleted file mode 100644
index 3c96e2c52020..000000000000
--- a/testing/scummvm/0002-FLUIDSYNTH-Fix-compilation-with-Fluidsynth-2.2.patch
+++ /dev/null
@@ -1,111 +0,0 @@
-From d0d38b0199dae9a1dbfecc53db54dd0a070694b4 Mon Sep 17 00:00:00 2001
-From: Le Philousophe <lephilousophe@users.noreply.github.com>
-Date: Mon, 5 Apr 2021 12:23:26 +0200
-Subject: FLUIDSYNTH: Fix compilation with Fluidsynth 2.2
-
-We replace deprecated functions as well
----
- audio/softsynth/fluidsynth.cpp | 43 ++++++++++++++++++++++++++++++++++
- 1 file changed, 43 insertions(+)
-
-diff --git a/audio/softsynth/fluidsynth.cpp b/audio/softsynth/fluidsynth.cpp
-index e770fb6854..f01dd8c736 100644
---- a/audio/softsynth/fluidsynth.cpp
-+++ b/audio/softsynth/fluidsynth.cpp
-@@ -180,11 +180,19 @@ static void *SoundFontMemLoader_open(const char *filename) {
- 	return p;
- }
- 
-+#if FS_API_VERSION >= 0x0202
-+static int SoundFontMemLoader_read(void *buf, fluid_long_long_t count, void *handle) {
-+#else
- static int SoundFontMemLoader_read(void *buf, int count, void *handle) {
-+#endif
- 	return ((Common::SeekableReadStream *) handle)->read(buf, count) == (uint32)count ? FLUID_OK : FLUID_FAILED;
- }
- 
-+#if FS_API_VERSION >= 0x0202
-+static int SoundFontMemLoader_seek(void *handle, fluid_long_long_t offset, int origin) {
-+#else
- static int SoundFontMemLoader_seek(void *handle, long offset, int origin) {
-+#endif
- 	return ((Common::SeekableReadStream *) handle)->seek(offset, origin) ? FLUID_OK : FLUID_FAILED;
- }
- 
-@@ -193,7 +201,11 @@ static int SoundFontMemLoader_close(void *handle) {
- 	return FLUID_OK;
- }
- 
-+#if FS_API_VERSION >= 0x0202
-+static fluid_long_long_t SoundFontMemLoader_tell(void *handle) {
-+#else
- static long SoundFontMemLoader_tell(void *handle) {
-+#endif
- 	return ((Common::SeekableReadStream *) handle)->pos();
- }
- #endif
-@@ -237,7 +249,11 @@ int MidiDriver_FluidSynth::open() {
- 	_synth = new_fluid_synth(_settings);
- 
- 	if (ConfMan.getBool("fluidsynth_chorus_activate")) {
-+#if FS_API_VERSION >= 0x0202
-+		fluid_synth_chorus_on(_synth, -1, 1);
-+#else
- 		fluid_synth_set_chorus_on(_synth, 1);
-+#endif
- 
- 		int chorusNr = ConfMan.getInt("fluidsynth_chorus_nr");
- 		double chorusLevel = (double)ConfMan.getInt("fluidsynth_chorus_level") / 100.0;
-@@ -252,22 +268,49 @@ int MidiDriver_FluidSynth::open() {
- 			chorusType = FLUID_CHORUS_MOD_TRIANGLE;
- 		}
- 
-+#if FS_API_VERSION >= 0x0202
-+		fluid_synth_set_chorus_group_nr(_synth, -1, chorusNr);
-+		fluid_synth_set_chorus_group_level(_synth, -1, chorusLevel);
-+		fluid_synth_set_chorus_group_speed(_synth, -1, chorusSpeed);
-+		fluid_synth_set_chorus_group_depth(_synth, -1, chorusDepthMs);
-+		fluid_synth_set_chorus_group_type(_synth, -1, chorusType);
-+#else
- 		fluid_synth_set_chorus(_synth, chorusNr, chorusLevel, chorusSpeed, chorusDepthMs, chorusType);
-+#endif
- 	} else {
-+#if FS_API_VERSION >= 0x0202
-+		fluid_synth_chorus_on(_synth, -1, 0);
-+#else
- 		fluid_synth_set_chorus_on(_synth, 0);
-+#endif
- 	}
- 
- 	if (ConfMan.getBool("fluidsynth_reverb_activate")) {
-+#if FS_API_VERSION >= 0x0202
-+		fluid_synth_reverb_on(_synth, -1, 1);
-+#else
- 		fluid_synth_set_reverb_on(_synth, 1);
-+#endif
- 
- 		double reverbRoomSize = (double)ConfMan.getInt("fluidsynth_reverb_roomsize") / 100.0;
- 		double reverbDamping = (double)ConfMan.getInt("fluidsynth_reverb_damping") / 100.0;
- 		int reverbWidth = ConfMan.getInt("fluidsynth_reverb_width");
- 		double reverbLevel = (double)ConfMan.getInt("fluidsynth_reverb_level") / 100.0;
- 
-+#if FS_API_VERSION >= 0x0202
-+		fluid_synth_set_reverb_group_roomsize(_synth, -1, reverbRoomSize);
-+		fluid_synth_set_reverb_group_damp(_synth, -1, reverbDamping);
-+		fluid_synth_set_reverb_group_width(_synth, -1, reverbWidth);
-+		fluid_synth_set_reverb_group_level(_synth, -1, reverbLevel);
-+#else
- 		fluid_synth_set_reverb(_synth, reverbRoomSize, reverbDamping, reverbWidth, reverbLevel);
-+#endif
- 	} else {
-+#if FS_API_VERSION >= 0x0202
-+		fluid_synth_reverb_on(_synth, -1, 0);
-+#else
- 		fluid_synth_set_reverb_on(_synth, 0);
-+#endif
- 	}
- 
- 	Common::String interpolation = ConfMan.get("fluidsynth_misc_interpolation");
--- 
-2.32.0
-
diff --git a/testing/spirv-llvm-translator/allow-llvm-11-1-0.patch b/testing/spirv-llvm-translator/allow-llvm-11-1-0.patch
deleted file mode 100644
index 6c99473d359c..000000000000
--- a/testing/spirv-llvm-translator/allow-llvm-11-1-0.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt	2021-03-12 18:06:40.486001382 +0100
-+++ b/CMakeLists.txt	2021-03-12 18:06:44.742971472 +0100
-@@ -1,6 +1,6 @@
- cmake_minimum_required(VERSION 3.3)
- 
--set (BASE_LLVM_VERSION 11.0.0)
-+set (BASE_LLVM_VERSION 11.1.0)
- set(LLVM_SPIRV_VERSION ${BASE_LLVM_VERSION}.0)
- 
- option(LLVM_SPIRV_INCLUDE_TESTS
-
-- 
GitLab