diff --git a/community/py3-pytest-xdist/APKBUILD b/community/py3-pytest-xdist/APKBUILD
index 9a2dd80fb302be314e482d3e989064aefdfe0f5b..c23a7a28f16b61124cb7fc4356305a513f3d029c 100644
--- a/community/py3-pytest-xdist/APKBUILD
+++ b/community/py3-pytest-xdist/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Dmitry Romanenko <dmitry@romanenko.in>
 # Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
 pkgname=py3-pytest-xdist
-pkgver=1.31.0
+pkgver=1.32.0
 pkgrel=0
 pkgdesc="pytest xdist plugin for distributed testing and loop-on-failing modes"
 url="https://github.com/pytest-dev/pytest-xdist"
@@ -37,5 +37,5 @@ package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
 
-sha512sums="b7960d20295232b251c8ddcc5a3b9d6e7b761d577ba11c2647b4b4b410ee5c05998cf57fa57208561eb3ea7c4914db1fd446173794589d8c8e8e79ff8e0ad3aa  pytest-xdist-1.31.0.tar.gz
-4777113de61a6377a8c45f6a3321fabef3b407a2efdfe70baacd6ba0df0266742efdeb1008532fe2f42c831ea2b908b820fb3a17808567e265d67b1970f876ad  skip-failing-test.patch"
+sha512sums="f159b4653efb4afeff4124df484670d3c672e1014712f948390b25efc53096f8237258c83a5f1a9e688c52b4a756291cb731d37fdfa800707f556550a19cb0e8  pytest-xdist-1.32.0.tar.gz
+da339ce326ccd6bc46024af269bf36b19e2cd384e71edc73fc85b031b763125f2f1b3ef3c3d8f44e56f0198e1838291ca8b503bd8ce081a69e5b0f11ab06bf3f  skip-failing-test.patch"
diff --git a/community/py3-pytest-xdist/skip-failing-test.patch b/community/py3-pytest-xdist/skip-failing-test.patch
index 07421084d71b5efd1ff7210c5cf368474a3988ae..3342e0e4b00684e31ccf91795da92267f8a1fec9 100644
--- a/community/py3-pytest-xdist/skip-failing-test.patch
+++ b/community/py3-pytest-xdist/skip-failing-test.patch
@@ -1,14 +1,17 @@
-Upstream: no
-Reason: test is failing and holding the 3.12 builders up
-diff --git a/testing/acceptance_test.py b/testing/acceptance_test.py
-index d93f08e..435c043 100644
+Upstream: Yes
+Reason: Python 3.8 test failure
+
+URL: https://github.com/pytest-dev/pytest-xdist/pull/527
 --- a/testing/acceptance_test.py
 +++ b/testing/acceptance_test.py
-@@ -115,6 +115,7 @@ class TestDistribution:
+@@ -115,9 +115,7 @@ class TestDistribution:
          assert result.ret == 2
          result.stdout.fnmatch_lines(["*Interrupted: stopping*1*", "*1 failed*"])
  
-+    @pytest.mark.skip(reason="failing")
+-    @pytest.mark.xfail(
+-        reason="#527: Python 3.8 failure in pytest where testdir.tmpdir returns an unexpected value"
+-    )
++    @pytest.mark.skip(reason="failure")
      def test_basetemp_in_subprocesses(self, testdir):
          p1 = testdir.makepyfile(
              """