From 4c63c358a52411e007f749582d354b03d07beab8 Mon Sep 17 00:00:00 2001
From: Danct12 <danct12@disroot.org>
Date: Fri, 23 Aug 2019 00:37:12 +0700
Subject: [PATCH] testing/fceux: new aport

Signed-off-by: Danct12 <danct12@disroot.org>
---
 testing/fceux/APKBUILD            |  38 +++++++++++
 testing/fceux/scons-python3.patch | 108 ++++++++++++++++++++++++++++++
 2 files changed, 146 insertions(+)
 create mode 100644 testing/fceux/APKBUILD
 create mode 100644 testing/fceux/scons-python3.patch

diff --git a/testing/fceux/APKBUILD b/testing/fceux/APKBUILD
new file mode 100644
index 000000000000..93b3e03cd177
--- /dev/null
+++ b/testing/fceux/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Danct12 <danct12@disroot.org>
+# Maintainer: Danct12 <danct12@disroot.org>
+pkgname=fceux
+pkgver=2.2.3
+pkgrel=0
+pkgdesc="Fast and ultra-compatible NES/Famicom emulator"
+url="http://www.fceux.com"
+arch="all"
+license="GPL-2.0-only"
+depends_dev="sdl-dev gd-dev gtk+2.0-dev mesa-dev glu-dev"
+makedepends="$depends_dev scons"
+subpackages="$pkgname-doc"
+source="https://downloads.sourceforge.net/project/fceultra/Source%20Code/$pkgver%20src/$pkgname-$pkgver.src.tar.gz
+	scons-python3.patch"
+options="!check" # no testsuite
+
+build() {
+	scons -C "$pkgname-$pkgver"
+}
+
+package() {
+	scons install -i --prefix="$pkgdir/usr"
+
+	install -d "$pkgdir/usr/share/doc/$pkgname"
+	cp -r documentation/* "$pkgdir/usr/share/doc/$pkgname/"
+	install -Dm644 changelog.txt "$pkgdir/usr/share/doc/$pkgname/"
+
+	# desktop shortcut
+	install -Dm644 "$pkgname.desktop" \
+		"$pkgdir/usr/share/applications/$pkgname.desktop"
+	install -Dm644 "$pkgname.png" \
+		"$pkgdir/usr/share/pixmaps/$pkgname.png"
+
+	rm -f "$pkgdir/usr/share/$pkgname/"*.dll
+}
+
+sha512sums="6deb83e9e773694f4040f5f325b0b5b4f45d58bb3481db67b4659c940d90c4c87e3ffeac712b72ddb3f5d089cd9fc7b55b497db61f708c23a7c43c17eda55c7b  fceux-2.2.3.src.tar.gz
+2c2cf6d7eac03a4cf7f66118e0f8af9562eb5497c2e3159952eced1edee5f38c983ede704536eade645f5c028635b8ff0ceca8769dcf0d50b3159a1666660ae0  scons-python3.patch"
diff --git a/testing/fceux/scons-python3.patch b/testing/fceux/scons-python3.patch
new file mode 100644
index 000000000000..d3be48de222c
--- /dev/null
+++ b/testing/fceux/scons-python3.patch
@@ -0,0 +1,108 @@
+--- fceux-2.2.3/SConstruct.orig	2019-07-26 18:04:29.368573309 +0000
++++ fceux-2.2.3/SConstruct	2019-07-26 18:04:31.975265342 +0000
+@@ -46,30 +46,30 @@
+ # Default compiler flags:
+ env.Append(CCFLAGS = ['-Wall', '-Wno-write-strings', '-Wno-sign-compare'])
+ 
+-if os.environ.has_key('PLATFORM'):
++if os.environ.get('PLATFORM'):
+   env.Replace(PLATFORM = os.environ['PLATFORM'])
+-if os.environ.has_key('CC'):
++if os.environ.get('CC'):
+   env.Replace(CC = os.environ['CC'])
+-if os.environ.has_key('CXX'):
++if os.environ.get('CXX'):
+   env.Replace(CXX = os.environ['CXX'])
+-if os.environ.has_key('WINDRES'):
++if os.environ.get('WINDRES'):
+   env.Replace(WINDRES = os.environ['WINDRES'])
+-if os.environ.has_key('CFLAGS'):
++if os.environ.get('CFLAGS'):
+   env.Append(CCFLAGS = os.environ['CFLAGS'].split())
+-if os.environ.has_key('CXXFLAGS'):
++if os.environ.get('CXXFLAGS'):
+   env.Append(CXXFLAGS = os.environ['CXXFLAGS'].split())
+-if os.environ.has_key('CPPFLAGS'):
++if os.environ.get('CPPFLAGS'):
+   env.Append(CPPFLAGS = os.environ['CPPFLAGS'].split())
+-if os.environ.has_key('LDFLAGS'):
++if os.environ.get('LDFLAGS'):
+   env.Append(LINKFLAGS = os.environ['LDFLAGS'].split())
+-if os.environ.has_key('PKG_CONFIG_PATH'):
++if os.environ.get('PKG_CONFIG_PATH'):
+   env['ENV']['PKG_CONFIG_PATH'] = os.environ['PKG_CONFIG_PATH']
+-if not os.environ.has_key('PKG_CONFIG_PATH') and env['PLATFORM'] == 'darwin':
++if not os.environ.get('PKG_CONFIG_PATH') and env['PLATFORM'] == 'darwin':
+   env['ENV']['PKG_CONFIG_PATH'] = "/usr/local/lib/pkgconfig:/opt/X11/lib/pkgconfig"
+-if os.environ.has_key('PKG_CONFIG_LIBDIR'):
++if os.environ.get('PKG_CONFIG_LIBDIR'):
+   env['ENV']['PKG_CONFIG_LIBDIR'] = os.environ['PKG_CONFIG_LIBDIR']
+ 
+-print "platform: ", env['PLATFORM']
++print ("platform: ", env['PLATFORM'])
+ 
+ # compile with clang
+ if env['CLANG']:
+@@ -103,18 +103,18 @@
+     assert conf.CheckLibWithHeader('z', 'zlib.h', 'c', 'inflate;', 1), "please install: zlib"
+   if env['SDL2']:
+     if not conf.CheckLib('SDL2'):
+-      print 'Did not find libSDL2 or SDL2.lib, exiting!'
++      print ('Did not find libSDL2 or SDL2.lib, exiting!')
+       Exit(1)
+     env.Append(CPPDEFINES=["_SDL2"])
+     env.ParseConfig('pkg-config sdl2 --cflags --libs')
+   else:
+     if not conf.CheckLib('SDL'):
+-      print 'Did not find libSDL or SDL.lib, exiting!'
++      print ('Did not find libSDL or SDL.lib, exiting!')
+       Exit(1)
+     env.ParseConfig('sdl-config --cflags --libs')
+   if env['GTK']:
+     if not conf.CheckLib('gtk-x11-2.0'):
+-      print 'Could not find libgtk-2.0, exiting!'
++      print ('Could not find libgtk-2.0, exiting!')
+       Exit(1)
+     # Add compiler and linker flags from pkg-config
+     config_string = 'pkg-config --cflags --libs gtk+-2.0'
+@@ -153,7 +153,7 @@
+         env.Append(CCFLAGS = ["-I/usr/include/lua"])
+         lua_available = True
+       if lua_available == False:
+-        print 'Could not find liblua, exiting!'
++        print ('Could not find liblua, exiting!')
+         Exit(1)
+     else:
+       env.Append(CCFLAGS = ["-Isrc/lua/src"])
+@@ -167,7 +167,7 @@
+     gd = conf.CheckLib('gd', autoadd=1)
+     if gd == 0:
+       env['LOGO'] = 0
+-      print 'Did not find libgd, you won\'t be able to create a logo screen for your avis.'
++      print ('Did not find libgd, you won\'t be able to create a logo screen for your avis.')
+    
+   if env['OPENGL'] and conf.CheckLibWithHeader('GL', 'GL/gl.h', 'c', autoadd=1):
+     conf.env.Append(CCFLAGS = "-DOPENGL")
+@@ -181,8 +181,8 @@
+ if env['FRAMESKIP']:
+   env.Append(CPPDEFINES = ['FRAMESKIP'])
+ 
+-print "base CPPDEFINES:",env['CPPDEFINES']
+-print "base CCFLAGS:",env['CCFLAGS']
++print ("base CPPDEFINES:",env['CPPDEFINES'])
++print ("base CCFLAGS:",env['CCFLAGS'])
+ 
+ if env['DEBUG']:
+   env.Append(CPPDEFINES=["_DEBUG"], CCFLAGS = ['-g', '-O0'])
+--- fceux-2.2.3/src/SConscript.orig    2019-07-26 18:08:11.297535443 +0000
++++ fceux-2.2.3/src/SConscript 2019-07-26 18:08:33.857781956 +0000
+@@ -33,7 +33,7 @@
+   platform_files = SConscript('drivers/sdl/SConscript')
+ file_list.append(platform_files)
+ 
+-print env['LINKFLAGS']
++print (env['LINKFLAGS'])
+ 
+ if env['PLATFORM'] == 'win32':
+   fceux = env.Program('fceux.exe', file_list)
+
-- 
GitLab