From 4be372e7d950fb1e608eef83dbfe4cfee330f7fb Mon Sep 17 00:00:00 2001
From: Sertonix <sertonix@posteo.net>
Date: Wed, 7 Aug 2024 23:19:50 +0200
Subject: [PATCH] community/libresource: fix build with GCC 14

---
 community/libresource/APKBUILD                |  4 ++-
 .../libresource/implicit-declaration.patch    | 36 +++++++++++++++++++
 2 files changed, 39 insertions(+), 1 deletion(-)
 create mode 100644 community/libresource/implicit-declaration.patch

diff --git a/community/libresource/APKBUILD b/community/libresource/APKBUILD
index 8fecb3f1b037..3fb81e18fc5a 100644
--- a/community/libresource/APKBUILD
+++ b/community/libresource/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=libresource
 pkgver=0.25.1
-pkgrel=1
+pkgrel=2
 _commit_dbusgmain="d42176ae4763e5288ef37ea314fe58387faf2005"
 pkgdesc="Nemo's libresource"
 url="https://github.com/sailfishos/libresource"
@@ -21,6 +21,7 @@ makedepends="$depends_dev
 subpackages="$pkgname-static $pkgname-dev"
 source="https://github.com/sailfishos/libresource/archive/$pkgver/libresource-$pkgver.tar.gz
 	https://github.com/sailfishos-mirror/dbus-glib/archive/$_commit_dbusgmain/dbus-glib-$_commit_dbusgmain.tar.gz
+	implicit-declaration.patch
 	"
 options="!check" # No suitable tests
 
@@ -48,4 +49,5 @@ package() {
 sha512sums="
 c60d6badec533cd569b0ad7b5cddb0a5fb9853e2fb9c23a679bba66777c2ced6a7a00f0a308542aacb23297f4210aca177ca8c61f3b9812a509a04c1d68a5f26  libresource-0.25.1.tar.gz
 665cd6395ee0ea14086ba30188c62a72697b3f63484681e18fc7f54109c9aca162f2e33aa2fa4d45287c6c0b590e81ca310c143dac0232cd5887692cdaf51256  dbus-glib-d42176ae4763e5288ef37ea314fe58387faf2005.tar.gz
+e12da83deb587393d68a8843d50f8d9eada98804442458c5f4319289e68d115e03eae1d61eb8067921dbf6628de79ef4edc91a834f1ca63007db84bf08680eeb  implicit-declaration.patch
 "
diff --git a/community/libresource/implicit-declaration.patch b/community/libresource/implicit-declaration.patch
new file mode 100644
index 000000000000..85d98e77d391
--- /dev/null
+++ b/community/libresource/implicit-declaration.patch
@@ -0,0 +1,36 @@
+diff --git a/examples/fmradio.c b/examples/fmradio.c
+index 1a5515f..49bd0d1 100644
+--- a/examples/fmradio.c
++++ b/examples/fmradio.c
+@@ -26,6 +26,7 @@ USA.
+ #include <glib.h>
+ 
+ #include <resource.h>
++#include <res-msg.h>
+ 
+ static GMainLoop       *main_loop;
+ 
+diff --git a/src/res-proto.c b/src/res-proto.c
+index b21a9f3..10a8874 100644
+--- a/src/res-proto.c
++++ b/src/res-proto.c
+@@ -27,6 +27,7 @@ USA.
+ 
+ #include <res-proto.h>
+ #include "res-conn-private.h"
++#include "res-set-private.h"
+ #include "dbus-msg.h"
+ #include "dbus-proto.h"
+ #include "internal-msg.h"
+diff --git a/tests/memory-leak-test.c b/tests/memory-leak-test.c
+index 0d47044..44e5116 100644
+--- a/tests/memory-leak-test.c
++++ b/tests/memory-leak-test.c
+@@ -5,6 +5,7 @@
+ #include <glib.h>
+ 
+ #include <resource.h>
++#include <res-msg.h>
+ 
+ static GMainLoop       *main_loop;
+ 
-- 
GitLab