Commit 4b666867 authored by Timo Teräs's avatar Timo Teräs
Browse files

main/eudev: provide udev

.. and delete the transitional dummy 'udev' package
parent fd14deba
......@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=eudev
pkgver=3.2.1
pkgrel=1
pkgrel=2
pkgdesc="OpenRC compatible fork of systemd-udev"
url="https://wiki.gentoo.org/wiki/Project:Eudev"
arch="all"
......@@ -10,6 +10,7 @@ license="GPLv2"
depends="udev-init-scripts"
depends_dev=""
replaces="udev"
provides="udev=176"
makedepends="$depends_dev gperf glib-dev linux-headers kmod-dev
gobject-introspection-dev util-linux-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-netifnames::noarch"
......
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=udev
pkgver=175
pkgrel=10
pkgdesc="Compatility package. Use udev instead"
url="http://www.kernel.org/pub/linux/utils/kernel/hotplug/"
arch="noarch"
license="GPL2"
subpackages=""
depends="eudev"
makedepends=""
install=""
source=""
prepare() {
return 0
}
build() {
mkdir -p "$pkgdir"
}
package() {
mkdir -p "$pkgdir"/usr/share/doc/udev
cat >"$pkgdir"/usr/share/doc/udev/README.alpine <<EOF
udev is deprecated and replaced by eudev. To replace it you need to:
apk add eudev
apk del udev
EOF
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment