diff --git a/community/syncthing/APKBUILD b/community/syncthing/APKBUILD
index 00d756f857f4c9db39286c57bc260a68a250844d..a059ac7694384076653a3dc2b27442e0308ad572 100644
--- a/community/syncthing/APKBUILD
+++ b/community/syncthing/APKBUILD
@@ -4,7 +4,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=syncthing
 pkgver=1.25.0
-pkgrel=1
+pkgrel=2
 pkgdesc="Open Source Continuous File Synchronization"
 url="https://syncthing.net/"
 arch="all"
@@ -84,5 +84,5 @@ utils() {
 sha512sums="
 fd9e1b7c76f327b2eb746c1660313e4e012c0a32bffa813ac6524bea9e7123795aa970a4bbb7bb97ab2362b55e7b47b081eabbf9c9371172468b44df654c688e  syncthing-1.25.0.tar.gz
 81bcb6b2e0956624b596201d1de24a3b6fcb10d08761f2c426081350b611295a7f4d47775d175f2ee5dbbb289b98bc022389fc9992f0d31bcdbfde855ceafaf8  only-test-with-race-when-provided.patch
-7fe49210180827c28f3ee9a1a95da3884dbef34de9bdc643f4455c9a056adba81f16c1c6ac059e83bee360aea091ace98b8a6f4c4b26a32c450f61f15206d3f5  syncthing.initd
+b001d1550f5877dd3a0e6506adc4cc451d08230269842064b3f6ad2e6919aca71edd8e46e3516395cd76f00505641f095df0e0bde60accb642708fc781d6347a  syncthing.initd
 "
diff --git a/community/syncthing/syncthing.initd b/community/syncthing/syncthing.initd
index f64821ef041ac3d921c401fa51f2291180be8121..98840224d852dfc5c27ff40109c28b6789522fea 100644
--- a/community/syncthing/syncthing.initd
+++ b/community/syncthing/syncthing.initd
@@ -6,16 +6,11 @@ command_args="${SYNCTHING_ARGS:--no-browser}"
 command_user="${SYNCTHING_USER:-syncthing}"
 pidfile=/run/${RC_SVCNAME}.pid
 command_background=yes
-start_stop_daemon_args="--stdout /var/log/$RC_SVCNAME/${RC_SVCNAME}.log --stderr /var/log/$RC_SVCNAME/${RC_SVCNAME}.log"
+output_logger="logger -t '${RC_SVCNAME}' -p daemon.info"
+error_logger="logger -t '${RC_SVCNAME}' -p daemon.error"
 
 depend() {
         use logger dns
         need net
         after firewall
 }
-
-start_pre() {
-        checkpath --directory --owner $command_user --mode 0775 \
-                /var/log/$RC_SVCNAME
-}
-