Commit 47071799 authored by Natanael Copa's avatar Natanael Copa
Browse files

main/irssi: security upgrade to 1.1.3 (CVE-2019-13045)

fixes #10657
parent 8493bffc
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=irssi
pkgver=1.1.2
pkgver=1.1.3
pkgrel=0
pkgdesc="Modular textUI IRC client with IPv6 support"
url="https://irssi.org/"
......@@ -14,6 +14,8 @@ source="https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-
builddir="$srcdir"/$pkgname-$pkgver
# secfixes:
# 1.1.3-r0:
# - CVE-2019-13045
# 1.1.2-r0:
# - CVE-2019-5882
# 1.0.3-r0:
......@@ -89,5 +91,5 @@ proxy() {
mv "$pkgdir"/usr/lib/irssi/modules/libirc_proxy.* "$subpkgdir"/usr/lib/irssi/modules/
}
sha512sums="706f811c810b976888101a29bab6ff6b9aa6116678994b3710d6b266bfbc0ae2be1d4fd889aedfbf0a13a2e3da3f1affcce0018346ecc582865eaccd8cc79f84 irssi-1.1.2.tar.xz
sha512sums="ea4117d7b8ba92e96004e129e050aef8700c3bb55b836d10bc7b96c19c9638d2fa86582c6dee300afa6c3573fed72bb5ca1b970e73c5782fb1517bd64c72286e irssi-1.1.3.tar.xz
6b5d987a9aeb189f3926272b37c631d04403832b495004779e8c23e9925a19349c7303927bab65b964ecb631fe7ac2394cf1c8e42ab69e300e30a121a95215ad libressl-2.7.patch"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment