diff --git a/community/peanutbutter/APKBUILD b/community/peanutbutter/APKBUILD
index f5e45dbc558654986aef092b079c3c3292a63cdd..4284464e763ba76748b2979bbca8d5b89b5c1fdf 100644
--- a/community/peanutbutter/APKBUILD
+++ b/community/peanutbutter/APKBUILD
@@ -1,16 +1,15 @@
 # Contributor: Anjandev Momi <anjan@momi.ca>
 # Maintainer: Anjandev Momi <anjan@momi.ca>
 pkgname=peanutbutter
-pkgver=0.3
+pkgver=0.4
 pkgrel=0
 pkgdesc="A lock screen for linux mobile - specially designed for Sxmo (sway edition)"
 url="https://git.sr.ht/~anjan/peanutbutter"
 # s390x: build fails on nix dependency
 arch="all !s390x"
 license="AGPL-3.0-only"
-makedepends="cargo cargo-auditable"
-source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~anjan/peanutbutter/archive/$pkgver.tar.gz
-	cargo-update.patch"
+makedepends="cargo cargo-auditable glib-dev pango-dev"
+source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~anjan/peanutbutter/archive/$pkgver.tar.gz"
 options="!check"
 
 prepare() {
@@ -29,6 +28,5 @@ package() {
 }
 
 sha512sums="
-1bff0df188a370e55048ed97bc0a4441b30ce31c67165d1c965ccd2e7b59f2d0dbd04f0ccee408129c02c3f33c38b839bf94e41f627b93585625242b6dc2a51c  peanutbutter-0.3.tar.gz
-486b48ea176887c3af8bac0575f7bd1f6a5d3f84c0a836b143e0132f359ddfb2f53ae4a06b3255699fef8eb2e1879ecc4c44d1e2d7848acc907d89b3f1b1fde1  cargo-update.patch
+a1cf1a34de7e564694037333aec67d8af527b65443726f538a3655ced73f6e031936a79197ce20f5bf180e98f703c532d9fc0bf1843e5fb639cec426744ba28b  peanutbutter-0.4.tar.gz
 "
diff --git a/community/peanutbutter/cargo-update.patch b/community/peanutbutter/cargo-update.patch
deleted file mode 100644
index 1cde45197bfab80d775c43fbc7b5fae8d14530d5..0000000000000000000000000000000000000000
--- a/community/peanutbutter/cargo-update.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/Cargo.lock b/Cargo.lock
-index 6a00ea8..b5ef655 100644
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -65,9 +65,9 @@ checksum = "25cbce373ec4653f1a01a31e8a5e5ec0c622dc27ff9c4e6606eefef5cbbed4a5"
- 
- [[package]]
- name = "libc"
--version = "0.2.151"
-+version = "0.2.155"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "302d7ab3130588088d277783b1e2d2e10c9e9e4a16dd9050e6ec93fb3e7048f4"
-+checksum = "97b3888a4aecf77e811145cadf6eef5901f4782c53886191b2f693f24761847c"
- 
- [[package]]
- name = "libloading"