diff --git a/community/enscript/APKBUILD b/community/enscript/APKBUILD
index 5bad655793d4720c1407e6b9e37996570769f9a6..3b056288c126c34d7ed657ce6c4148e9cf1a8cfc 100644
--- a/community/enscript/APKBUILD
+++ b/community/enscript/APKBUILD
@@ -1,13 +1,15 @@
 # Maintainer: André Klitzing <aklitzing@gmail.com>
 pkgname=enscript
 pkgver=1.6.6
-pkgrel=5
+pkgrel=6
 pkgdesc="GNU Enscript converts ASCII files to PostScript, HTML, or RTF"
 url="https://www.gnu.org/software/enscript/"
 arch="all"
 license="GPL-3.0-only"
 subpackages="$pkgname-doc"
-source="https://ftp.gnu.org/gnu/enscript/enscript-$pkgver.tar.gz"
+source="https://ftp.gnu.org/gnu/enscript/enscript-$pkgver.tar.gz
+	gcc14-implicit-function-declaration.patch
+	"
 
 prepare() {
 	default_prepare
@@ -33,4 +35,7 @@ package() {
 	install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
 }
 
-sha512sums="bf1c2b9ea7723518a1ef312145ddcd6ffdef0c6e8b5795ea84cb55d76fccc02f441d0c2dc6897e970368186e6a829ab74a090716624e0f7a8f575653fa495ebc  enscript-1.6.6.tar.gz"
+sha512sums="
+bf1c2b9ea7723518a1ef312145ddcd6ffdef0c6e8b5795ea84cb55d76fccc02f441d0c2dc6897e970368186e6a829ab74a090716624e0f7a8f575653fa495ebc  enscript-1.6.6.tar.gz
+8534bd60a6f0a2b066fa52ad734c84ff6b9abae859c88550be4a9e93400f25d4520a5b39c0e0995d21d1bb661716806e6d8c2dd04d1391a97b012c7ad1cb58ac  gcc14-implicit-function-declaration.patch
+"
diff --git a/community/enscript/gcc14-implicit-function-declaration.patch b/community/enscript/gcc14-implicit-function-declaration.patch
new file mode 100644
index 0000000000000000000000000000000000000000..8e718b1f17640835e6eeaeb77afb126c0e608d2c
--- /dev/null
+++ b/community/enscript/gcc14-implicit-function-declaration.patch
@@ -0,0 +1,10 @@
+--- enscript-1.6.6-origin/compat/getopt.c
++++ enscript-1.6.6/compat/getopt.c
+@@ -111,6 +111,7 @@
+    they can distinguish the relative order of options and other arguments.  */
+ 
+ #include "getopt.h"
++#include <string.h>
+ 
+ /* For communication from `getopt' to the caller.
+    When `getopt' finds an option that takes an argument,