diff --git a/testing/ifuse/APKBUILD b/testing/ifuse/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..26f49c57d08e60be7a00684f7dbe60812a30f611
--- /dev/null
+++ b/testing/ifuse/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Kasper K <kasperkantz@outlook.com>
+# Maintainer: Kasper K <kasperkantz@outlook.com>
+pkgname=ifuse
+pkgver=1.1.4
+pkgrel=0
+pkgdesc="Fuse filesystem to access the contents of iOS devices"
+url="https://libimobiledevice.org"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="libudev-zero-dev libimobiledevice-dev fuse-dev"
+subpackages="$pkgname-doc"
+source="https://github.com/libimobiledevice/ifuse/releases/download/$pkgver/ifuse-$pkgver.tar.bz2"
+
+build() {
+	./configure \
+		--host=$CHOST \
+		--build=$CBUILD \
+		--prefix=/usr \
+		--disable-static
+	make
+}
+
+check() {
+	make check
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+}
+
+sha512sums="671fabb0828fb6dd5ddba80ef418005305f4ee4676ab1078513a83582e84616f47c8973c25e1fdd8897b08a01a135080898a55d3ad8b31e89c0bb72ee865cdff  ifuse-1.1.4.tar.bz2"