From 45f8a2c7b44b710e54e149f9bf01b138d875aef5 Mon Sep 17 00:00:00 2001
From: Luca Weiss <luca@z3ntu.xyz>
Date: Sun, 7 Jun 2020 13:51:39 +0200
Subject: [PATCH] testing/yubioath-desktop: new aport

---
 testing/yubioath-desktop/APKBUILD | 35 +++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 testing/yubioath-desktop/APKBUILD

diff --git a/testing/yubioath-desktop/APKBUILD b/testing/yubioath-desktop/APKBUILD
new file mode 100644
index 000000000000..7bf595ebae79
--- /dev/null
+++ b/testing/yubioath-desktop/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+pkgname=yubioath-desktop
+pkgver=5.0.4
+pkgrel=0
+pkgdesc="Yubico Authenticator for Desktop"
+url="https://github.com/Yubico/yubioath-desktop"
+arch="all !armhf" # missing qt5-qtquickcontrols2
+license="BSD-2-Clause"
+depends="py3-pyotherside py3-ykman ccid"
+makedepends="qt5-qtquickcontrols2-dev"
+source="https://github.com/Yubico/yubioath-desktop/archive/yubioath-desktop-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+options="!check" # No tests
+
+build() {
+	qmake-qt5 . \
+		PREFIX=/usr \
+		QMAKE_CFLAGS_RELEASE="$CFLAGS" \
+		QMAKE_CXXFLAGS_RELEASE="$CXXFLAGS"
+
+	make
+}
+
+package() {
+	make INSTALL_ROOT="$pkgdir" install
+
+	install -Dm644 resources/icons/com.yubico.yubioath.svg \
+		"$pkgdir"/usr/share/pixmaps/com.yubico.yubioath.svg
+	install -Dm755 resources/com.yubico.yubioath.desktop \
+		"$pkgdir"/usr/share/applications/com.yubico.yubioath.desktop
+	install -Dm755 resources/com.yubico.yubioath.appdata.xml \
+		"$pkgdir"/usr/share/metainfo/com.yubico.yubioath.appdata.xml
+}
+
+sha512sums="a10c7f4fb137683183ed5aaca0e996193686857edc2a6a2b86e7bc4257971a747b48aa19cfd72162ea9557d375d080bae0ed26bdfa33c07ed60f8b67572f10a3  yubioath-desktop-5.0.4.tar.gz"
-- 
GitLab