diff --git a/testing/ngspice/APKBUILD b/testing/ngspice/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..a6174ea5c835307d0ce57c585f6c623dfe426147
--- /dev/null
+++ b/testing/ngspice/APKBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=ngspice
+pkgver=30
+pkgrel=0
+pkgdesc="open source spice simulator for electric and electronic circuits"
+url="http://ngspice.sourceforge.net/"
+arch="all"
+license="BSD-3-Clause"
+makedepends="libxaw-dev libedit-dev readline-dev"
+depends="python3"
+subpackages="$pkgname-doc $pkgname-dev"
+source="
+	https://downloads.sourceforge.net/project/$pkgname/ng-spice-rework/$pkgver/$pkgname-$pkgver.tar.gz
+	"
+
+build() {
+	./configure \
+		--prefix=/usr \
+		--mandir=/usr/share/man \
+		--infodir=/usr/share/info \
+		--with-readline=yes \
+		--enable-xspice \
+		--enable-cider \
+		--enable-openmp \
+		--with-ngshared
+
+	make
+
+	# build the binary ngspice, which is only build without --with-ngshared
+
+	./configure \
+		--prefix=/usr \
+		--mandir=/usr/share/man \
+		--infodir=/usr/share/info \
+		--with-readline=yes \
+		--enable-xspice \
+		--enable-cider \
+		--enable-openmp
+
+	make
+}
+
+check() {
+	make check
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+	install -Dm755 src/.libs/libngspice.so.0.0.0 "$pkgdir/usr/lib/libngspice.so.0.0.0"
+	ln -s "libngspice.so.0.0.0" "$pkgdir/usr/lib/libngspice.so.0"
+	ln -s "libngspice.so.0.0.0" "$pkgdir/usr/lib/libngspice.so"
+}
+
+sha512sums="baa67527a05586b6da19e96203889fe013eb19a9e60b159ab9e3828dd5bb865f44bd683e622b256c3c434d77fe7adb5fe1badab75bdeaa9f24faafe7aaaae2e2  ngspice-30.tar.gz"