diff --git a/main/perl-type-tiny/APKBUILD b/main/perl-type-tiny/APKBUILD
index 777e58b810ea62c097dfe73dc902433bbe4683ad..faced821a527af09632ccfd578f8d7362a803379 100644
--- a/main/perl-type-tiny/APKBUILD
+++ b/main/perl-type-tiny/APKBUILD
@@ -1,11 +1,11 @@
-# Automatically generated by apkbuild-cpan, template 3
+# Automatically generated by apkbuild-cpan, template 4
 # Contributor: Francesco Colista <fcolista@alpinelinux.org>
 # Maintainer: Francesco Colista <fcolista@alpinelinux.org>
 pkgname=perl-type-tiny
+pkgver=2.006000
+pkgrel=0
 #_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
 _pkgreal=Type-Tiny
-pkgver=2.004000
-pkgrel=1
 pkgdesc="tiny, yet Moo(se)-compatible type constraint"
 url="https://metacpan.org/release/Type-Tiny/"
 arch="noarch"
@@ -18,7 +18,10 @@ builddir="$srcdir/$_pkgreal-$pkgver"
 
 build() {
 	export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
-	PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+	PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+		INSTALLDIRS=vendor \
+		NO_PACKLIST=1 \
+		NO_PERLLOCAL=1
 	make
 }
 
@@ -29,9 +32,15 @@ check() {
 
 package() {
 	make DESTDIR="$pkgdir" install
-	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+doc() {
+	local file; find "$pkgdir" -name "*.pod" | while read -r file; do
+		amove "${file#"$pkgdir"}"
+	done
+	default_doc
 }
 
 sha512sums="
-a28a0fdfe48c8ce7f7313bfa6645094337dfb12d76401d9947a649763379a912f480ff418f0023d1e0c5851ffa347823669192a9eb8081341db7525d84c82220  Type-Tiny-2.004000.tar.gz
+24c3fea4834eb093b2aceff82e951bed73adf821d77c0f5445085021b8dc661cc3264198d265817349e582fc0e640303534a1d23ae1fcf669135ed7ab3ee937d  Type-Tiny-2.006000.tar.gz
 "