diff --git a/community/editorconfig/APKBUILD b/community/editorconfig/APKBUILD
index 67fd7ce7e82995cdf34463c870aec066204f9153..65245a132f47bdfd88f9d94ce581a1d612cd5e46 100644
--- a/community/editorconfig/APKBUILD
+++ b/community/editorconfig/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=$pkgname-core-c
 pkgver=0.12.3
 _testname=editorconfig-core-test
 _testver=0.12
-pkgrel=0
+pkgrel=1
 pkgdesc="EditorConfig core library written in C (for use by plugins supporting EditorConfig parsing)"
 url="https://github.com/editorconfig/editorconfig-core-c"
 arch="all"
@@ -13,7 +13,7 @@ license="BSD-2-Clause"
 makedepends="cmake pcre2-dev"
 subpackages="lib$pkgname:libs $pkgname-static $pkgname-dev"
 source="$pkgname-$pkgver.tar.gz::https://github.com/editorconfig/$_pkgname/archive/v$pkgver.tar.gz
-	https://github.com/editorconfig/$_testname/archive/v${_testver}.tar.gz
+	https://github.com/editorconfig/$_testname/archive/v$_testver.tar.gz
 	disable-failing-test.patch
 	"
 builddir="$srcdir/$_pkgname-$pkgver"
@@ -21,13 +21,13 @@ builddir="$srcdir/$_pkgname-$pkgver"
 prepare() {
 	# Tests are taken from a github release tarball so place them in the tree
 	rmdir tests
-	mv ../${_testname}-${_testver} tests
+	mv ../$_testname-$_testver tests
 	default_prepare
 }
 
 build() {
 	cmake . \
-		-DCMAKE_BUILD_TYPE=MinSizeRel \
+		-DCMAKE_BUILD_TYPE=None \
 		-DCMAKE_C_FLAGS_MINSIZEREL="$CFLAGS" \
 		-DCMAKE_INSTALL_PREFIX=/usr \
 		-DCMAKE_INSTALL_LIBDIR=lib \