From 41a63b1a9683fcb092f73decca0a947020787e81 Mon Sep 17 00:00:00 2001
From: Dennis Krupenik <dennis@krupenik.com>
Date: Sat, 20 Jun 2020 17:02:47 +0300
Subject: [PATCH] testing/intel-compute-runtime: new aport
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Intel® Graphics Compute Runtime for oneAPI Level Zero and OpenCL™ Driver
https://github.com/intel/compute-runtime
---
 testing/intel-compute-runtime/APKBUILD        | 43 ++++++++++++++++
 .../intel-compute-runtime/link-execinfo.patch | 50 +++++++++++++++++++
 .../intel-compute-runtime/pthread-yield.patch | 22 ++++++++
 .../remove-rtld-deepbind.patch                | 19 +++++++
 .../intel-compute-runtime/remove-select.patch | 14 ++++++
 5 files changed, 148 insertions(+)
 create mode 100644 testing/intel-compute-runtime/APKBUILD
 create mode 100644 testing/intel-compute-runtime/link-execinfo.patch
 create mode 100644 testing/intel-compute-runtime/pthread-yield.patch
 create mode 100644 testing/intel-compute-runtime/remove-rtld-deepbind.patch
 create mode 100644 testing/intel-compute-runtime/remove-select.patch

diff --git a/testing/intel-compute-runtime/APKBUILD b/testing/intel-compute-runtime/APKBUILD
new file mode 100644
index 000000000000..78e132faa77d
--- /dev/null
+++ b/testing/intel-compute-runtime/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Dennis Krupenik <dennis@krupenik.com>
+# Maintainer: Dennis Krupenik <dennis@krupenik.com>
+pkgname=intel-compute-runtime
+pkgver=20.34.17727
+pkgrel=0
+pkgdesc="Intel® Graphics Compute Runtime for oneAPI Level Zero and OpenCL™ Driver"
+url="https://github.com/intel/compute-runtime"
+arch="x86_64"
+license="MIT"
+depends_dev="intel-gmmlib-dev intel-graphics-compiler-dev libexecinfo-dev libva-dev"
+makedepends="$depends_dev cmake"
+subpackages="$pkgname-dev"
+source="https://github.com/intel/compute-runtime/archive/$pkgver/compute-runtime-$pkgver.tar.gz
+	link-execinfo.patch
+	pthread-yield.patch
+	remove-rtld-deepbind.patch
+	remove-select.patch"
+builddir="$srcdir/compute-runtime-$pkgver"
+options="!check" # runs unit tests in preinstall
+
+build() {
+	if [ "$CBUILD" != "$CHOST" ]; then
+		CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+	fi
+	cmake -B build \
+		-DCMAKE_BUILD_TYPE=None \
+		-DCMAKE_INSTALL_PREFIX=/usr \
+		-DCMAKE_INSTALL_LIBDIR=lib \
+		-DBUILD_SHARED_LIBS=True \
+		-DSKIP_UNIT_TESTS=1 \
+		$CMAKE_CROSSOPTS .
+	nice make -C build -j"$(nproc)"
+}
+
+package() {
+	make -C build DESTDIR="$pkgdir" install
+}
+
+sha512sums="0afd611e135d46c7168fe28cc7ab5a18e543a7b4de782734a46c99d8adae4f723def1d207a8d62b409d453beaf3cecf701a99b6ae51eecd4c332a60814697232  compute-runtime-20.34.17727.tar.gz
+5cf4bb4114ffc9940e20f3d3f21edb5b1e6f9157b38c4232cb16ff7fb52e36eedb26b008ed5801c257233375315a950e4e6e47756be01ca9787a1b6f42fbe369  link-execinfo.patch
+855284aad45809046266e0def176f16f28dcd08154d39ffd2e34c92127f52da0f24a5679ec1d5005369f878a9947e69c21fd34cda31b636d04d055956b3cf06b  pthread-yield.patch
+5b63d5a480fa72353cf6229d77391163631cdb00e1ce444d75d3681128468726df9f74eb3b44eebd47d62fb2779a61d12d983ebe38902d063a7e54ea3347a52a  remove-rtld-deepbind.patch
+8ee0f776f06858cedaed0194618030eb7d0e27e27b7488daf975e3f6eb6df378461b93a300ecd68366ded2ec28d7c53ee35711e2c9cbe2c8634423bb03e9cf57  remove-select.patch"
diff --git a/testing/intel-compute-runtime/link-execinfo.patch b/testing/intel-compute-runtime/link-execinfo.patch
new file mode 100644
index 000000000000..b2ee2bc27d67
--- /dev/null
+++ b/testing/intel-compute-runtime/link-execinfo.patch
@@ -0,0 +1,50 @@
+add execinfo library
+---
+--- a/opencl/test/unit_test/offline_compiler/CMakeLists.txt
++++ b/opencl/test/unit_test/offline_compiler/CMakeLists.txt
+@@ -87,7 +87,7 @@
+ )
+ target_compile_definitions(ocloc_tests PUBLIC MOCKABLE_VIRTUAL=virtual $<TARGET_PROPERTY:ocloc_lib,INTERFACE_COMPILE_DEFINITIONS>)
+ 
+-target_link_libraries(ocloc_tests gmock-gtest)
++target_link_libraries(ocloc_tests gmock-gtest execinfo)
+ 
+ if(WIN32)
+     target_link_libraries(ocloc_tests dbghelp)
+
+--- a/opencl/test/unit_test/offline_compiler/segfault_test/CMakeLists.txt
++++ b/opencl/test/unit_test/offline_compiler/segfault_test/CMakeLists.txt
+@@ -38,7 +38,7 @@
+   target_link_libraries(ocloc_segfault_test dbghelp)
+ endif()
+ if(UNIX)
+-  target_link_libraries(ocloc_segfault_test dl pthread)
++  target_link_libraries(ocloc_segfault_test dl pthread execinfo)
+ endif()
+ 
+ set(CLOC_SEGFAULT_TEST_INCLUDES
+
+--- a/shared/offline_compiler/source/CMakeLists.txt
++++ b/shared/offline_compiler/source/CMakeLists.txt
+@@ -139,7 +139,7 @@
+ endif()
+ 
+ if(UNIX)
+-  target_link_libraries(${OCLOC_NAME}_lib dl pthread)
++  target_link_libraries(${OCLOC_NAME}_lib dl pthread execinfo)
+ endif()
+ 
+ set(CLOC_LIB_SRCS_LIB ${CLOC_LIB_SRCS_LIB} PARENT_SCOPE)
+
+--- a/opencl/source/CMakeLists.txt
++++ b/opencl/source/CMakeLists.txt
+@@ -81,7 +81,7 @@
+   )
+   target_compile_definitions(${NEO_STATIC_LIB_NAME} PRIVATE OGL=1)
+ else()
+-  set(IGDRCL_EXTRA_LIBS dl pthread)
++  set(IGDRCL_EXTRA_LIBS dl pthread execinfo igc)
+   target_include_directories(${NEO_STATIC_LIB_NAME} PUBLIC
+     ${NEO_SHARED_DIRECTORY}/os_interface/linux
+     ${NEO_SOURCE_DIR}/opencl/source/os_interface/linux
+
diff --git a/testing/intel-compute-runtime/pthread-yield.patch b/testing/intel-compute-runtime/pthread-yield.patch
new file mode 100644
index 000000000000..8ca6a482e105
--- /dev/null
+++ b/testing/intel-compute-runtime/pthread-yield.patch
@@ -0,0 +1,22 @@
+pthread_yield -> sched_yield
+---
+--- a/opencl/test/unit_test/os_interface/linux/drm_gem_close_worker_tests.cpp
++++ b/opencl/test/unit_test/os_interface/linux/drm_gem_close_worker_tests.cpp
+@@ -121,7 +121,7 @@
+ 
+     //wait for worker to complete or deadCnt drops
+     while (!worker->isEmpty() && (deadCnt-- > 0))
+-        pthread_yield(); //yield to another threads
++        sched_yield(); //yield to another threads
+ 
+     worker->close(false);
+ 
+@@ -142,7 +142,7 @@
+ 
+     //wait for worker to complete or deadCnt drops
+     while (!worker->isEmpty() && (deadCnt-- > 0))
+-        pthread_yield(); //yield to another threads
++        sched_yield(); //yield to another threads
+ 
+     //and check if GEM was closed
+     EXPECT_EQ(1, this->drmMock->gem_close_cnt.load());
diff --git a/testing/intel-compute-runtime/remove-rtld-deepbind.patch b/testing/intel-compute-runtime/remove-rtld-deepbind.patch
new file mode 100644
index 000000000000..d2e1fbbd180f
--- /dev/null
+++ b/testing/intel-compute-runtime/remove-rtld-deepbind.patch
@@ -0,0 +1,19 @@
+RTLD_DEEPBIND is a glibc thing
+---
+--- a/shared/source/os_interface/linux/os_library_linux.cpp
++++ b/shared/source/os_interface/linux/os_library_linux.cpp
+@@ -29,13 +29,7 @@
+     if (name.empty()) {
+         this->handle = dlopen(0, RTLD_LAZY);
+     } else {
+-#ifdef SANITIZER_BUILD
+-        constexpr auto dlopenFlag = RTLD_LAZY;
+-#else
+-        constexpr auto dlopenFlag = RTLD_LAZY | RTLD_DEEPBIND;
+-        /* Background: https://github.com/intel/compute-runtime/issues/122 */
+-#endif
+-        this->handle = dlopen(name.c_str(), dlopenFlag);
++        this->handle = dlopen(name.c_str(), RTLD_LAZY | RTLD_GLOBAL);
+     }
+ }
+ 
diff --git a/testing/intel-compute-runtime/remove-select.patch b/testing/intel-compute-runtime/remove-select.patch
new file mode 100644
index 000000000000..fddb761bd41c
--- /dev/null
+++ b/testing/intel-compute-runtime/remove-select.patch
@@ -0,0 +1,14 @@
+do not redefine `select`
+---
+--- a/opencl/source/builtin_kernels_simulation/opencl_c.h
++++ b/opencl/source/builtin_kernels_simulation/opencl_c.h
+@@ -220,8 +220,6 @@
+     (                               \
+         (type)var)
+ 
+-#define select(a, b, c) (c ? b : a)
+-
+ uint get_local_id(int dim);
+ uint get_global_id(int dim);
+ uint get_local_size(int dim);
+
-- 
GitLab