From 3fe27c9f306d0816d474a48b9c3bae91969dd03d Mon Sep 17 00:00:00 2001
From: Antoni Aloy Torrens <aaloytorrens@gmail.com>
Date: Tue, 21 Jun 2022 01:10:21 +0200
Subject: [PATCH] community/obconf-qt: move from testing

---
 {testing => community}/obconf-qt/APKBUILD | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)
 rename {testing => community}/obconf-qt/APKBUILD (83%)

diff --git a/testing/obconf-qt/APKBUILD b/community/obconf-qt/APKBUILD
similarity index 83%
rename from testing/obconf-qt/APKBUILD
rename to community/obconf-qt/APKBUILD
index 80ca6a5ac930..456563943f7d 100644
--- a/testing/obconf-qt/APKBUILD
+++ b/community/obconf-qt/APKBUILD
@@ -9,17 +9,18 @@ url="https://github.com/lxqt/obconf-qt"
 arch="all !s390x !armhf !riscv64"
 license="LGPL-2.0-or-later"
 makedepends="
-	cmake lxqt-build-tools liblxqt-dev
+	cmake samurai lxqt-build-tools liblxqt-dev
 	qt5-qttools-dev openbox-dev
 	"
 options="!check" # No testsuite
+subpackages="$pkgname-lang"
 source="https://github.com/lxqt/obconf-qt/releases/download/$pkgver/obconf-qt-$pkgver.tar.xz"
 
 build() {
 	if [ "$CBUILD" != "$CHOST" ]; then
 		CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
 	fi
-	cmake -B build \
+	cmake -B build -G Ninja \
 		-DCMAKE_BUILD_TYPE=Release \
 		-DCMAKE_INSTALL_PREFIX=/usr \
 		-DCMAKE_INSTALL_LIBDIR=lib \
@@ -31,6 +32,12 @@ build() {
 package() {
 	DESTDIR="$pkgdir" cmake --build build --target install
 }
+
+lang() {
+	install_if="lang $pkgname=$pkgver-r$pkgrel"
+	amove usr/share/$pkgname/translations
+}
+
 sha512sums="
 bd91a5669f07471966d296b91d78e2a40e2e3640405de2179513457088eb7d6cb063dbfaff623db6f404985734e986b52c1e3155a050f374b7afa58f7d720c0d  obconf-qt-0.16.2.tar.xz
 "
-- 
GitLab