diff --git a/community/py3-aiohttp-socks/APKBUILD b/community/py3-aiohttp-socks/APKBUILD
index 9bee1fc2662925d22e83497bd7378f7463544fd4..4355ba222a8d473f9fadc4c34e56da64b6428623 100644
--- a/community/py3-aiohttp-socks/APKBUILD
+++ b/community/py3-aiohttp-socks/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Michał Adamski <michal@ert.pl>
 pkgname=py3-aiohttp-socks
 pkgver=0.5.5
-pkgrel=3
+pkgrel=4
 pkgdesc="Proxy connector for aiohttp"
 url="https://github.com/romis2012/aiohttp-socks"
 arch="noarch"
@@ -16,10 +16,14 @@ build() {
 }
 
 check() {
-	python3 setup.py check
+	# no tests in pypi tarball + they need testing/3proxy to run
+	PYTHONPATH=build/lib python3 -c "import aiohttp_socks"
 }
 
 package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
-sha512sums="18eb7cb6f8553596e5b973f0bffda71ce67f0b4298ad0006fff5353161ac656a0d87eb138c363683b411a42e2585f308625827bf896bbe53bb5cee2e8901b7a3  aiohttp_socks-0.5.5.tar.gz"
+
+sha512sums="
+18eb7cb6f8553596e5b973f0bffda71ce67f0b4298ad0006fff5353161ac656a0d87eb138c363683b411a42e2585f308625827bf896bbe53bb5cee2e8901b7a3  aiohttp_socks-0.5.5.tar.gz
+"