From 3f34665176234662c429514d20744a33e30a4276 Mon Sep 17 00:00:00 2001
From: Noel Kuntze <noel.kuntze@thermi.consulting>
Date: Wed, 22 May 2024 22:47:39 +0200
Subject: [PATCH] testing/py3-aioitertools: new aport

Implementation of itertools, builtins, and more for AsyncIO and mixed-type iterables
---
 testing/py3-aioitertools/APKBUILD | 33 +++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
 create mode 100644 testing/py3-aioitertools/APKBUILD

diff --git a/testing/py3-aioitertools/APKBUILD b/testing/py3-aioitertools/APKBUILD
new file mode 100644
index 000000000000..bed92b12dca5
--- /dev/null
+++ b/testing/py3-aioitertools/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Noel Kuntze <noel.kuntze@contauro.com>
+pkgname=py3-aioitertools
+pkgdesc="Implementation of itertools, builtins, and more for AsyncIO and mixed-type iterables"
+pkgver=0.11.0
+pkgrel=0
+arch="noarch"
+url="https://github.com/omnilib/aioitertools"
+license="MIT"
+depends="python3"
+makedepends="py3-gpep517 py3-setuptools py3-wheel py3-flit-core"
+subpackages="$pkgname-pyc"
+
+source="$pkgname-$pkgver.tar.gz::https://github.com/omnilib/aioitertools/archive/refs/tags/v$pkgver.tar.gz"
+
+builddir="$srcdir"/aioitertools-$pkgver
+
+build() {
+	gpep517 build-wheel \
+		--wheel-dir dist \
+		--output-fd 3 3>&1 >&2
+}
+
+check() {
+	python -m unittest -v aioitertools.tests
+}
+
+package() {
+	python3 -m installer -d "$pkgdir" dist/*.whl
+}
+
+sha512sums="
+0ddc884004c297cd08872b38bf3788fdf65846935e9c576638fae477ab920bb1e5f7197e3f9e668e55634f4df464348518acc55c9581b9210915af4cead98545  py3-aioitertools-0.11.0.tar.gz
+"
-- 
GitLab