diff --git a/testing/py3-aioitertools/APKBUILD b/testing/py3-aioitertools/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..bed92b12dca5e4f23b6225a5c5e78c75d06f4e25
--- /dev/null
+++ b/testing/py3-aioitertools/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Noel Kuntze <noel.kuntze@contauro.com>
+pkgname=py3-aioitertools
+pkgdesc="Implementation of itertools, builtins, and more for AsyncIO and mixed-type iterables"
+pkgver=0.11.0
+pkgrel=0
+arch="noarch"
+url="https://github.com/omnilib/aioitertools"
+license="MIT"
+depends="python3"
+makedepends="py3-gpep517 py3-setuptools py3-wheel py3-flit-core"
+subpackages="$pkgname-pyc"
+
+source="$pkgname-$pkgver.tar.gz::https://github.com/omnilib/aioitertools/archive/refs/tags/v$pkgver.tar.gz"
+
+builddir="$srcdir"/aioitertools-$pkgver
+
+build() {
+	gpep517 build-wheel \
+		--wheel-dir dist \
+		--output-fd 3 3>&1 >&2
+}
+
+check() {
+	python -m unittest -v aioitertools.tests
+}
+
+package() {
+	python3 -m installer -d "$pkgdir" dist/*.whl
+}
+
+sha512sums="
+0ddc884004c297cd08872b38bf3788fdf65846935e9c576638fae477ab920bb1e5f7197e3f9e668e55634f4df464348518acc55c9581b9210915af4cead98545  py3-aioitertools-0.11.0.tar.gz
+"