diff --git a/testing/py3-nosexcover/APKBUILD b/community/py3-nosexcover/APKBUILD
similarity index 81%
rename from testing/py3-nosexcover/APKBUILD
rename to community/py3-nosexcover/APKBUILD
index fb59e8182f6fd381ec7a20a6a44fa81c815be3d6..bad64c28bf2e9150b7fd6499325f54fa437d175f 100644
--- a/testing/py3-nosexcover/APKBUILD
+++ b/community/py3-nosexcover/APKBUILD
@@ -5,13 +5,13 @@ _pkgname=nose-xcover
 pkgver=1.0.11
 pkgrel=3
 pkgdesc="Extends nose.plugins.cover to add Cobertura-style XML reports"
-url="https://github.com/cmheisel/nose-xcover/"
+url="https://github.com/cmheisel/nose-xcover"
 arch="noarch"
 license="MIT"
 depends="py3-nose py3-coverage"
 makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/cmheisel/$_pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/"$_pkgname-$pkgver
+source="$pkgname-$pkgver.tar.gz::https://github.com/cmheisel/nose-xcover/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
 
 replaces="py-nosexcover" # Backwards compatibility
 provides="py-nosexcover=$pkgver-r$pkgrel" # Backwards compatibility
@@ -27,4 +27,5 @@ check() {
 package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
+
 sha512sums="e606e89b75d51c728d1487200f4a38afe1af93defabe6bd847b80d597374e7bb10abc2e5c8e6778bbd4f17ba8b8d7a601864a8277cd14437ee94a9e04996cf22  py3-nosexcover-1.0.11.tar.gz"