From 3dde7e2494c5557c7acf79e75de421625f51422a Mon Sep 17 00:00:00 2001
From: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
Date: Fri, 14 Oct 2022 08:57:31 +0200
Subject: [PATCH] testing/py3-mistletoe: new aport

markdown parser in pure Python, designed to be fast, spec-compliant and fully customizable
https://github.com/miyuchina/mistletoe
---
 testing/py3-mistletoe/APKBUILD | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 testing/py3-mistletoe/APKBUILD

diff --git a/testing/py3-mistletoe/APKBUILD b/testing/py3-mistletoe/APKBUILD
new file mode 100644
index 000000000000..d3b70c6575cb
--- /dev/null
+++ b/testing/py3-mistletoe/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py3-mistletoe
+_pkgname="${pkgname#py3-}"
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="markdown parser in pure Python, designed to be fast, spec-compliant and fully customizable"
+url="https://github.com/miyuchina/mistletoe"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-requests py3-yaml"
+source="$pkgname-$pkgver.tar.gz::https://github.com/miyuchina/mistletoe/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	pytest
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="
+b0e9c96b27255fb8527f359d8bfb2612a1302efcd3250867caa7e2dbf91eeeab4dabb20071d64e0914e52afdc8c30a181c042c2263aa9f1c5dc4421f5d862ae7  py3-mistletoe-0.9.0.tar.gz
+"
-- 
GitLab