From 3caaeff22e11aecaa5fc6b72551643471e143277 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Fri, 30 Jun 2023 22:42:14 +0000
Subject: [PATCH] community/basisu: enable sse2 on x86

---
 community/basisu/APKBUILD | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/community/basisu/APKBUILD b/community/basisu/APKBUILD
index 1ade0280fcd1..406b6a4b1afb 100644
--- a/community/basisu/APKBUILD
+++ b/community/basisu/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
 pkgname=basisu
 pkgver=1.16.4
-pkgrel=0
+pkgrel=1
 pkgdesc="Basis Universal GPU Texture Codec"
 url="https://github.com/BinomialLLC/basis_universal"
 arch="all"
@@ -20,10 +20,10 @@ source="basisu-$pkgver.tar.gz::https://github.com/BinomialLLC/basis_universal/ar
 builddir="$srcdir"/basis_universal-$pkgver
 
 build() {
-	_sse=OFF
-	if [ "$CARCH" = "x86_64" ]; then
-		_sse=ON
-	fi
+	case "$CARCH" in
+	x86*) local sse=ON ;;
+	*) local sse=OFF ;;
+	esac
 
 	if [ "$CBUILD" != "$CHOST" ]; then
 		CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
@@ -33,7 +33,7 @@ build() {
 		-DCMAKE_INSTALL_LIBDIR=lib \
 		-DBUILD_SHARED_LIBS=ON \
 		-DCMAKE_BUILD_TYPE=MinSizeRel \
-		-DSSE=$_sse \
+		-DSSE=$sse \
 		$CMAKE_CROSSOPTS
 	cmake --build build
 }
-- 
GitLab