Commit 3c097ca2 authored by Andy Postnikov's avatar Andy Postnikov
Browse files

community/nodejs-current: security upgrade to 16.6.0

fixes CVE-2021-22930
parent 8f98979c
Pipeline #88912 canceled with stages
in 24 seconds
......@@ -2,6 +2,8 @@
# Maintainer: Jose-Luis Rivas <ghostbar@riseup.net>
#
# secfixes:
# 16.6.0-r0:
# - CVE-2021-22930
# 15.10.0-r0:
# - CVE-2021-22883
# - CVE-2021-22884
......@@ -39,7 +41,7 @@
#
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
pkgver=16.3.0
pkgver=16.6.0
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
......@@ -120,9 +122,9 @@ package() {
}
sha512sums="
1b80b28d02fe32d4ecc41fa4f7246bf0d687c3bdca6dd4f5dd747c045653b433ca1026ee1600c47dd8d9576331484ac6e7fbc6bc3daa6f7b62e7bec345812f24 node-v16.3.0.tar.gz
367bb45780e9eb2673e70a8720b2d2ba6504057b7940263d712494ddc73b5375e157984eb891818eec91f13bcf2c58623d666ce3d1b161907cf7e189a83196ad node-v16.6.0.tar.gz
940cc90aaa77a531cde13e31918a9978f9478936c3851038bcdf2869e64de03ce84dec5a46519469a90a8ba2853226825452d23d9347752abdbe04e944c083eb dont-run-gyp-files-for-bundled-deps.patch
65df7eeadbdfc015185260c0e24f3206714e4d2aacceef742d078a4f8bae386b2867e0f7f3b8c2eac47180cb10a8e14b71a36a23bb74ed6a95eecbaf76897e0c link-with-libatomic-on-mips32.patch
e6f2907bdf2082097841f44ac9380d5b1bc65eca39be7153da081266940c6a10d2932e16a2e15bdcf12fec61c45549d009d1a07e5e1633603172968b5f6fdb77 elf.patch
6b06f819a026999e3a01bee09401004376e8c1fe19541a6f508557e73fbbb5b9d433cf8130a99230c7d04513715dff898f6004809e1ce7d0c01287312e468a5a unbundle-uv.patch
d8f1092a92f7a168755020b3e40fe72b743f9150de6d18f7664074dadaef866ecb4fa8252fa891fd7cf34b3dc183455af8d5570d7b3f1883464c2b6e3a9f2789 unbundle-uv.patch
"
--- a/deps/uvwasi/uvwasi.gyp
+++ b/deps/uvwasi/uvwasi.gyp
@@ -17,7 +17,6 @@
'src/wasi_rights.c',
@@ -30,7 +30,6 @@
}],
[ 'node_shared_libuv=="false"', {
'dependencies': [
- '../uv/uv.gyp:libuv',
],
}],
],
'dependencies': [
- '../uv/uv.gyp:libuv',
],
'direct_dependent_settings': {
'include_dirs': ['include']
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment