diff --git a/main/cmake/APKBUILD b/main/cmake/APKBUILD
index 2bbfe4c8bcba70ae8a6243cdfd6b1ae2ac125977..d33c65628ac3318c346a8c16c02125b13bca38b6 100644
--- a/main/cmake/APKBUILD
+++ b/main/cmake/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Valery Kartel <valery.kartel@gmail.com>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=cmake
-pkgver=3.27.8
+pkgver=3.28.0
 pkgrel=0
 pkgdesc="Cross-platform, open-source make system"
 url="https://www.cmake.org/"
@@ -33,9 +33,7 @@ case $pkgver in
 *.*.*.*) _v=v${pkgver%.*.*};;
 *.*.*) _v=v${pkgver%.*};;
 esac
-source="https://www.cmake.org/files/$_v/cmake-$pkgver.tar.gz
-	pkgconfig-whitespace.patch
-	"
+source="https://www.cmake.org/files/$_v/cmake-$pkgver.tar.gz"
 options="!check"
 
 build() {
@@ -94,6 +92,5 @@ vim() {
 }
 
 sha512sums="
-ca7782caee11d487a21abcd1c00fce03f3172c718c70605568d277d5a8cad95a18f2bf32a52637935afb0db1102f0da92d5a412a7166e3f19be2767d6f316f3d  cmake-3.27.8.tar.gz
-675c27a8ef1445381fdb20da354621f232964484e9806ba17f67b5840f2e132baf51db3007f8aa580bd68ef48ef76c0a10e155bb68890b3cbb821ffab660cd34  pkgconfig-whitespace.patch
+54f0fa5754693ab0a58314301da6957fbee410cf3c5906eaf5a5eabe9d371d8eda84eba42832c29d0a223d954b580c955811f62be38b33b817cab7199f884b60  cmake-3.28.0.tar.gz
 "
diff --git a/main/cmake/pkgconfig-whitespace.patch b/main/cmake/pkgconfig-whitespace.patch
deleted file mode 100644
index f382b6ca4e4280c7e0dd418d3bf027336d4879e1..0000000000000000000000000000000000000000
--- a/main/cmake/pkgconfig-whitespace.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Patch-Source: https://gitlab.kitware.com/cmake/cmake/-/commit/9beb4dd8a752e3c9ea0e19152b85f68b0f96d7c6
-From d47771bbb96a8435401950fb504b06003ec0babb Mon Sep 17 00:00:00 2001
-From: Paul Zander <negril.nx@gmail.com>
-Date: Sat, 9 Sep 2023 13:45:19 +0200
-Subject: [PATCH] FindPkgConfig: ignore whitespace separators in version check
-
-The regex used to split up the version if it contains an operator fails
-if the string contains whitespaces. Resulting in an extra whitespace
-after the package name and before the package version leading to
-breakage in pkgconf and thus webkit-gtk.
-
-See:
-https://github.com/pkgconf/pkgconf/issues/317
-https://bugs.webkit.org/show_bug.cgi?id=261125
-https://bugs.gentoo.org/913644
----
- Modules/FindPkgConfig.cmake | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
-index 4d29f4505c..6e8b78441a 100644
---- a/Modules/FindPkgConfig.cmake
-+++ b/Modules/FindPkgConfig.cmake
-@@ -563,8 +563,8 @@ macro(_pkg_check_modules_internal _is_required _is_silent _no_cmake_path _no_cma
-     foreach (_pkg_check_modules_pkg ${_pkg_check_modules_list})
-       set(_pkg_check_modules_exist_query)
- 
--      # check whether version is given
--      if (_pkg_check_modules_pkg MATCHES "(.*[^><])(=|[><]=?)(.*)")
-+      # check whether version is given while ignoring whitespace
-+      if (_pkg_check_modules_pkg MATCHES "(.*[^>< \t])[ \t]*(=|[><]=?)[ \t]*(.*)")
-         set(_pkg_check_modules_pkg_name "${CMAKE_MATCH_1}")
-         set(_pkg_check_modules_pkg_op "${CMAKE_MATCH_2}")
-         set(_pkg_check_modules_pkg_ver "${CMAKE_MATCH_3}")
--- 
-GitLab
-