diff --git a/testing/hplip/APKBUILD b/testing/hplip/APKBUILD
index 3c20e2bc0e589a8e1f0577bb00d7399c789c0617..9826e9a63057f10ee15e02c83e17cbc636e4ce04 100644
--- a/testing/hplip/APKBUILD
+++ b/testing/hplip/APKBUILD
@@ -16,6 +16,11 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
 	fix-includes.patch"
 builddir="$srcdir"/$pkgname-$pkgver
 
+prepare() {
+	default_prepare
+	update_config_guess
+}
+
 build() {
 	cd "$builddir"
 	./configure --prefix=/usr \