From 3a1dbb3948aaeb805f4d222a4891d0f4bebd950d Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Thu, 5 Jan 2017 11:40:08 +0000
Subject: [PATCH] testing/openscenegraph: fix build with arm and aarch64

---
 testing/openscenegraph/APKBUILD | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/testing/openscenegraph/APKBUILD b/testing/openscenegraph/APKBUILD
index 3dc903e2ffcd..bc1341db7f38 100644
--- a/testing/openscenegraph/APKBUILD
+++ b/testing/openscenegraph/APKBUILD
@@ -4,7 +4,7 @@ pkgver=3.4.0
 pkgrel=1
 pkgdesc="High performance 3D graphics toolkit"
 url="https://openscenegraph.org"
-arch="x86 x86_64"
+arch="all"
 license="Custom"
 depends=
 depends_dev=
@@ -20,7 +20,10 @@ builddir="$srcdir"/OpenSceneGraph-$pkgver
 prepare() {
 	cd "$builddir"
 	default_prepare || return 1
-	cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release || return 1
+	cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+		-DCMAKE_BUILD_TYPE=Release \
+		-DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-narrowing" \
+		|| return 1
 }
 
 build() {
-- 
GitLab