diff --git a/testing/telegram-desktop/APKBUILD b/testing/telegram-desktop/APKBUILD
index 74c857b62106427faca7c554ed476c872740526e..8cdf7424ff064ace65ad15982d40e9c8afc51573 100644
--- a/testing/telegram-desktop/APKBUILD
+++ b/testing/telegram-desktop/APKBUILD
@@ -2,9 +2,8 @@
 # Contributor: Leo <thinkabit.ukim@gmail.com>
 # TODO(Leo): remove pulseaudio dep
 pkgname=telegram-desktop
-pkgver=1.9.3
-pkgrel=2
-_breakpad_commit=dbd454dbe47e584571388fc3533193416bdce67f
+pkgver=1.9.4
+pkgrel=0
 pkgdesc="Telegram Desktop messaging app"
 options="!check" # Requires Catch2 to be packaged.
 url="https://desktop.telegram.org/"
@@ -13,6 +12,7 @@ license="GPL-3.0-or-later WITH OpenSSL"
 depends="qt5-qtimageformats libappindicator"
 makedepends="
 	cmake
+	ninja
 	zlib-dev
 	opus-dev
 	libva-dev
@@ -37,71 +37,26 @@ makedepends="
 	xxhash-dev
 	enchant2-dev
 	range-v3-dev
-	python
+	python3
 	"
 source="
 	https://github.com/telegramdesktop/tdesktop/releases/download/v$pkgver/tdesktop-$pkgver-full.tar.gz
-	breakpad-$_breakpad_commit.tar.gz::https://github.com/google/breakpad/archive/$_breakpad_commit.tar.gz
 	xdg.patch
-	lz4.cmake
-	zlib.cmake
-	opus.cmake
-	openal.cmake
-	openssl.cmake
-	ffmpeg.cmake
-	qt.cmake
-	range-v3.cmake
-	breakpad.cmake
 	musl-basename.patch
-	updater.patch
-	default-shared.patch
-	check-sizeof-void-p.patch
-	werror-lto.patch
-	qt_functions.patch
 	ppc.patch
 	qt-plugin-path.patch
-	guard-msse2.patch
-	variables-after-project.patch
-	qt_functions.cpp
 	"
 builddir="$srcdir/tdesktop-$pkgver-full"
 
-prepare() {
-	# we have these system-wide
-	rm -rf Telegram/ThirdParty/minizip Telegram/ThirdParty/lz4
-
-	mv "$srcdir"/breakpad-$_breakpad_commit "$builddir"/Telegram/ThirdParty/breakpad
-
-	# Copy our file over
-	cp -L "$srcdir"/qt_functions.cpp "$builddir"/Telegram/SourceFiles
-
-	# Install our cmake files
-	mv "$srcdir"/lz4.cmake "$builddir"/cmake/external/lz4/CMakeLists.txt
-	mv "$srcdir"/zlib.cmake "$builddir"/cmake/external/zlib/CMakeLists.txt
-	mv "$srcdir"/opus.cmake "$builddir"/cmake/external/opus/CMakeLists.txt
-	mv "$srcdir"/openal.cmake "$builddir"/cmake/external/openal/CMakeLists.txt
-	mv "$srcdir"/openssl.cmake "$builddir"/cmake/external/openssl/CMakeLists.txt
-	mv "$srcdir"/ffmpeg.cmake "$builddir"/cmake/external/ffmpeg/CMakeLists.txt
-	mv "$srcdir"/qt.cmake "$builddir"/cmake/external/qt/CMakeLists.txt
-	mv "$srcdir"/range-v3.cmake "$builddir"/cmake/external/ranges/CMakeLists.txt
-	mv "$srcdir"/breakpad.cmake "$builddir"/cmake/external/crash_reports/breakpad/CMakeLists.txt
-
-	default_prepare
-
-	mkdir "$builddir"/build
-}
-
 build() {
 	if [ "$CBUILD" != "$CHOST" ]; then
 		CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
 	fi
-	cd build
-
-	cmake \
+	cmake -B build -G Ninja \
 		-DCMAKE_INSTALL_PREFIX=/usr \
 		-DBUILD_SHARED_LIBS=True \
 		-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-		-DDESKTOP_APP_DISABLE_CRASH_REPORTS=True \
+		-DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON \
 		-DDESKTOP_APP_DISABLE_SPELLCHECK=OFF \
 		-DDESKTOP_APP_LOTTIE_USE_CACHE=ON \
 		-DDESKTOP_APP_USE_GLIBC_WRAPS=OFF \
@@ -109,8 +64,10 @@ build() {
 		-DTDESKTOP_API_ID=17349 \
 		-DTDESKTOP_API_HASH=344583e45741c457fe1862106095a5eb \
 		-DTDESKTOP_DISABLE_GTK_INTEGRATION=ON \
-		${CMAKE_CROSSOPTS} ..
-	make
+		-DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF \
+		-DTDESKTOP_USE_PACKAGED_TGVOIP=OFF \
+		${CMAKE_CROSSOPTS} .
+	ninja -C build
 }
 
 package() {
@@ -134,26 +91,8 @@ package() {
 	done
 }
 
-sha512sums="af8e5d2c74d0b990958edd75a01f40b70bc21c0f69074acfb943f44fdb1f1e84465b461765a1a584513e54ab30045817b42b6839ad16cb4c1043fda89ea600f7  tdesktop-1.9.3-full.tar.gz
-af8c9e8cf151b6aaa94a11b1f3f4d73c117fa25d7ba3b603c25170278bb0a99a9da10facc3b140fa0e3c2c0747a1f5bdcfb1120dfd48913a0d84f78701abb9fc  breakpad-dbd454dbe47e584571388fc3533193416bdce67f.tar.gz
+sha512sums="0967f60dd978a5fc5ec2501a22e8865afd4ddeaacfd1b0acfb133cd511767ff1c6f03a099aef3de03b0f837c8eccac1caea14c395ee54c8d3ab5b35de7551745  tdesktop-1.9.4-full.tar.gz
 8de8c0508177da5fcac4f2dcee4d8baef4b99f74f1dca296567bc3689a6bd17a47c1c945df504abc8811b82a687010d0709503c7c32e47d2ebb1cf0e374c80c5  xdg.patch
-15e7328bdfb1ddae0357d30ded5448fb785f3ef0e148f47df8e66d5716999afb73bbc1caed21c5babd283db40017d1939066ae4d7d5989053cd41088ee7d5c91  lz4.cmake
-f53c7194e62e22e0e197599ceffb37f1d742da83402257503c8f529e00187ed59d241d7880aa410ddbeac0540dc1ec6809700cf2c94c0c41db73809c712b1624  zlib.cmake
-0149ed6db6d92ed933f83ca385d2a06d4d6a960a2768134b3967a5e0a9bd58af83ac93fe45b3033e3da6767f90fea26037f6db17ba219dbe09f8942ba4903a84  opus.cmake
-48a6f5de0a03357d5f13a065c06b279021e8ebb872ea96d59f5ccb2bc8efd5e1f2d2850dddc22cdc0da0ac53cf0eb407ca0f53eebba8f68cf51224bb624c1b23  openal.cmake
-f3c13e996b8456a79a418380c9e78c8d871f53c9da6dbe030ebb25817f232c7b511255a6c618aabc6afe6aba3b636b1058986d8fede9d06ad354bf6c1e46bb9f  openssl.cmake
-c0afecd5d75d385e4e3d3d3e1273b12afebaaec38375a72edb17cb4c17666b3c45301cb0f06806a264798909ffd15517b7ed4d698cb00aa5c2d10bd6bd6ad12a  ffmpeg.cmake
-c15a8da42d5248ee48fd3663913c010476cedd0fde86c6b133770c41ee6cdab33637732ac24bcc34d9b3a9e2a202147eed08fbfa7bffcf0ca4a2681f519a52bb  qt.cmake
-f99017a119efb1b534cece9580d2b6cf4d88c0c3285eac8ac826008eec25a4fe43c846a9e1523f5af2aec57c13cf6abc549cdd8242ce266e43c3e61928e61d2a  range-v3.cmake
-bcb1ed7ecc7ca5c0282337fad9c341d7468537d0f1ae2dc296d63c34508c9768cd7120a135fea27a752a9e8c9e6eaa223fa661f488c7f8a565d9cc2b2eab7be4  breakpad.cmake
 6062602d02e20917c06f17d12bb21bd4a94b23c2a6744a8a05c2c93d41747ba413e110edd344ecd130c28ebaf997ae46b347d239e69f5856ead42318bd5b01cd  musl-basename.patch
-3182d2da588fd50c771047550e0d4805cce404836ecc6a4f9ccc95b21c6915391ab3f4d75cd745737836d6c483eac84974659b97e9514384efd032ef33044125  updater.patch
-4fb0f0a8c0a57436a10a79d7d1a45c1045d3ac30b9437e65025a4867400b52e52b38c61d447b1392bdf2bd6b241ed25a2c73851c67e08b9198a922c22a316345  default-shared.patch
-d76f218f65aa33f425da0b2174bb177384aa9dded21869f33bcd97c3f4fdd06977552a46b64d15124b78dece8e192d5193b53cf5c240f44b65407d036f96618b  check-sizeof-void-p.patch
-447c2f29d5527b934c70c39b7f6bdd15760e53dcb08ee516dd72a5bba6f2884958be31c86ed917109661a59e65a7b42b656ca8a81430e0b5e7ca5507f4ccd053  werror-lto.patch
-835f5735d6fc52ad0a3b99f21a0a06cb310f21981a6036f4c9b76312eb947af7fa065ef7f530bcd63ee9271d293778cc8ddf098764c2878a8500aa04ee05c2b1  qt_functions.patch
 9a3e491e2b2a9ea3f15da3766a2d743bafead7ae1e6a6ca3e6e9c7352dc268221311acd73664e5452622e2bc91cc88a2a7d3b4ebe6634b4da74c54b3bde0bb7f  ppc.patch
-183767e9a291dd605797cdc46382d8cb6a73a342348a40df7d52864ea27b3aa8709808cd51c46f5e611c247229ed336cb569bed1185c4c97b03171b56bbe5653  qt-plugin-path.patch
-6ec05a4b2d4cdee79eb4a985060c94174f5bd47ca99c8de30ebf8244e2f6bd97fcc56a132fd4e557f1e91f79ced796d149be950dd0b975227865a864542fdbee  guard-msse2.patch
-952570fe403727554b977e923d54b7a61aeaefc411a24d338196c28ad226b025c9005fdfab9f7c191ad2e43105a6aa42dbb059bf0984e7573a423bde6c041a7c  variables-after-project.patch
-edb5e7b1492c4913d2669610c7666a90fd94a615b7e3fc0c84e82bfd56fc61515b0e8ce14b35232a2f60f69db02769b8a05a4d11ccffec771d767cb600c92340  qt_functions.cpp"
+183767e9a291dd605797cdc46382d8cb6a73a342348a40df7d52864ea27b3aa8709808cd51c46f5e611c247229ed336cb569bed1185c4c97b03171b56bbe5653  qt-plugin-path.patch"
diff --git a/testing/telegram-desktop/breakpad.cmake b/testing/telegram-desktop/breakpad.cmake
deleted file mode 100644
index 007943d1a338d27e3eb9bb261add4e55ff093868..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/breakpad.cmake
+++ /dev/null
@@ -1,7 +0,0 @@
-add_library(external_breakpad INTERFACE IMPORTED GLOBAL)
-add_library(desktop-app::external_breakpad ALIAS external_breakpad)
-
-target_include_directories(external_breakpad SYSTEM
-INTERFACE
-    ${third_party_loc}/breakpad/src
-)
diff --git a/testing/telegram-desktop/check-sizeof-void-p.patch b/testing/telegram-desktop/check-sizeof-void-p.patch
deleted file mode 100644
index 9b14d4baf3f801e22b39519b879e6e4a5bbaf4bb..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/check-sizeof-void-p.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/cmake/variables.cmake b/cmake/variables.cmake
-index b3d7ff4..feb3dac 100644
---- a/cmake/variables.cmake
-+++ b/cmake/variables.cmake
-@@ -59,10 +59,9 @@ elseif (APPLE)
-     set(DESKTOP_APP_USE_GLIBC_WRAPS OFF)
- else()
-     set(LINUX 1)
--    execute_process(COMMAND uname -m OUTPUT_VARIABLE machine_uname)
--    if (NOT ${machine_uname} MATCHES "x86_64" AND NOT ${machine_uname} MATCHES "aarch64")
--        set(build_linux32 1)
--    endif()
-+	if(CMAKE_SIZEOF_VOID_P EQUAL 4)
-+		set(build_linux32 1)
-+	endif()
-     if (DESKTOP_APP_SPECIAL_TARGET STREQUAL "linux")
-         if (build_linux32)
-             report_bad_special_target()
diff --git a/testing/telegram-desktop/default-shared.patch b/testing/telegram-desktop/default-shared.patch
deleted file mode 100644
index 9507fae041bba60c1af37c1617b2d42ff3686676..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/default-shared.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/cmake/init_target.cmake b/cmake/init_target.cmake
-index c7a1244..2824a60 100644
---- a/cmake/init_target.cmake
-+++ b/cmake/init_target.cmake
-@@ -27,7 +27,7 @@ function(init_target target_name) # init_target(my_target folder_name)
-     endif()
-     target_link_libraries(${target_name} PUBLIC desktop-app::common_options)
-     set_target_properties(${target_name} PROPERTIES
--        LINK_SEARCH_START_STATIC 1
-+        LINK_SEARCH_START_STATIC 0
-         XCODE_ATTRIBUTE_CLANG_ENABLE_OBJC_WEAK YES
-         XCODE_ATTRIBUTE_GCC_INLINES_ARE_PRIVATE_EXTERN YES
-         XCODE_ATTRIBUTE_GCC_SYMBOLS_PRIVATE_EXTERN YES
diff --git a/testing/telegram-desktop/ffmpeg.cmake b/testing/telegram-desktop/ffmpeg.cmake
deleted file mode 100644
index 3f97fcb698e0ac587b5e744b1e6a838eb2ac7418..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/ffmpeg.cmake
+++ /dev/null
@@ -1,14 +0,0 @@
-# This file is part of Desktop App Toolkit,
-# a set of libraries for developing nice desktop applications.
-#
-# For license and copyright information please follow this link:
-# https://github.com/desktop-app/legal/blob/master/LEGAL
-
-add_library(external_ffmpeg INTERFACE IMPORTED GLOBAL)
-add_library(desktop-app::external_ffmpeg ALIAS external_ffmpeg)
-
-find_package(PkgConfig REQUIRED)
-pkg_check_modules(FFMPEG REQUIRED libavcodec libavformat libavutil libswresample libswscale)
-
-target_include_directories(external_ffmpeg SYSTEM INTERFACE ${FFMPEG_INCLUDE_DIR})
-target_link_libraries(external_ffmpeg INTERFACE ${FFMPEG_LIBRARIES})
diff --git a/testing/telegram-desktop/guard-msse2.patch b/testing/telegram-desktop/guard-msse2.patch
deleted file mode 100644
index 68a2d20949f2e1178346e50c8dd09c3d3a63f792..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/guard-msse2.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Telegram/cmake/lib_tgvoip.cmake b/Telegram/cmake/lib_tgvoip.cmake
-index 38fa632..2801fbe 100644
---- a/Telegram/cmake/lib_tgvoip.cmake
-+++ b/Telegram/cmake/lib_tgvoip.cmake
-@@ -756,7 +756,7 @@ else()
-         -Wno-error=sequence-point
-         -Wno-error=unused-result
-     )
--    if (build_linux32)
-+    if (build_linux32 AND CMAKE_SYSTEM_PROCESSOR MATCHES "i686.*|i386.*|x86.*")
-         target_compile_options(lib_tgvoip PRIVATE -msse2)
-     endif()
-     target_compile_definitions(lib_tgvoip
diff --git a/testing/telegram-desktop/lz4.cmake b/testing/telegram-desktop/lz4.cmake
deleted file mode 100644
index 28f36dcc0fb02c69fa0369a0715f67e25b663018..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/lz4.cmake
+++ /dev/null
@@ -1,7 +0,0 @@
-add_library(external_lz4 INTERFACE IMPORTED GLOBAL)
-add_library(desktop-app::external_lz4 ALIAS external_lz4)
-
-find_package(PkgConfig REQUIRED)
-pkg_check_modules(LZ4 REQUIRED liblz4)
-
-target_link_libraries(external_lz4 INTERFACE ${LZ4_LIBRARIES})
diff --git a/testing/telegram-desktop/openal.cmake b/testing/telegram-desktop/openal.cmake
deleted file mode 100644
index c598e1d5ca7cc40971b181b73638c896766e002b..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/openal.cmake
+++ /dev/null
@@ -1,7 +0,0 @@
-add_library(external_openal INTERFACE IMPORTED GLOBAL)
-add_library(desktop-app::external_openal ALIAS external_openal)
-
-find_package(OpenAL REQUIRED)
-
-target_include_directories(external_openal SYSTEM INTERFACE ${OPENAL_INCLUDE_DIR})
-target_link_libraries(external_openal INTERFACE ${OPENAL_LIBRARY})
diff --git a/testing/telegram-desktop/openssl.cmake b/testing/telegram-desktop/openssl.cmake
deleted file mode 100644
index 44235645c9ae0bfff25ad802de09d98eab2497eb..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/openssl.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
-add_library(external_openssl INTERFACE IMPORTED GLOBAL)
-add_library(desktop-app::external_openssl ALIAS external_openssl)
-
-find_package(OpenSSL REQUIRED)
-
-target_include_directories(external_openssl SYSTEM INTERFACE ${OpenSSL_INCLUDE_DIR})
-target_link_libraries(external_openssl
-INTERFACE
-	OpenSSL::Crypto
-	OpenSSL::SSL
-)
diff --git a/testing/telegram-desktop/opus.cmake b/testing/telegram-desktop/opus.cmake
deleted file mode 100644
index 50442399701b64cc046b05f730f4599d8c3409fa..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/opus.cmake
+++ /dev/null
@@ -1,8 +0,0 @@
-add_library(external_opus INTERFACE IMPORTED GLOBAL)
-add_library(desktop-app::external_opus ALIAS external_opus)
-
-find_package(PkgConfig REQUIRED)
-pkg_check_modules(OPUS REQUIRED opus)
-
-target_include_directories(external_opus SYSTEM INTERFACE ${OPUS_INCLUDE_DIRS})
-target_link_libraries(external_opus INTERFACE ${OPUS_LIBRARIES})
diff --git a/testing/telegram-desktop/qt.cmake b/testing/telegram-desktop/qt.cmake
deleted file mode 100644
index f569b2573de5618cc7a9fa870bbb3d16d6fd26d2..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/qt.cmake
+++ /dev/null
@@ -1,43 +0,0 @@
-add_library(external_qt INTERFACE IMPORTED GLOBAL)
-add_library(desktop-app::external_qt ALIAS external_qt)
-
-find_package(Qt5 REQUIRED COMPONENTS Core DBus Gui Widgets Network)
-get_target_property(QTCORE_INCLUDE_DIRS Qt5::Core INTERFACE_INCLUDE_DIRECTORIES)
-list(GET QTCORE_INCLUDE_DIRS 0 QT_INCLUDE_DIR)
-
-foreach(__qt_module IN ITEMS QtCore QtGui)
-	list(APPEND QT_PRIVATE_INCLUDE_DIRS
-		${QT_INCLUDE_DIR}/${__qt_module}/${Qt5_VERSION}
-		${QT_INCLUDE_DIR}/${__qt_module}/${Qt5_VERSION}/${__qt_module}
-	)
-endforeach()
-message(STATUS "Using Qt private include directories: ${QT_PRIVATE_INCLUDE_DIRS}")
-
-if (LINUX)
-	if (NOT build_linux32)
-		target_compile_definitions(external_qt INTERFACE Q_OS_LINUX64)
-	else()
-		target_compile_definitions(external_qt INTERFACE Q_OS_LINUX32)
-	endif()
-endif()
-
-target_compile_definitions(external_qt
-INTERFACE
-	_REENTRANT
-	QT_PLUGIN
-	QT_WIDGETS_LIB
-	QT_NETWORK_LIB
-	QT_GUI_LIB
-	QT_CORE_LIB
-)
-
-target_include_directories(external_qt SYSTEM
-INTERFACE
-	${QT_PRIVATE_INCLUDE_DIRS}
-)
-target_link_libraries(external_qt
-INTERFACE
-	Qt5::DBus
-	Qt5::Network
-	Qt5::Widgets
-)
diff --git a/testing/telegram-desktop/qt_functions.cpp b/testing/telegram-desktop/qt_functions.cpp
deleted file mode 100644
index a7c697f2561eae0e796fce7e3956fc689c233419..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/qt_functions.cpp
+++ /dev/null
@@ -1,97 +0,0 @@
-/****************************************************************************
-**
-** Copyright (C) 2015 The Qt Company Ltd.
-** Contact: http://www.qt.io/licensing/
-**
-** This file contains some parts of the Qt Toolkit.
-**
-** $QT_BEGIN_LICENSE:LGPL21$
-** Commercial License Usage
-** Licensees holding valid commercial Qt licenses may use this file in
-** accordance with the commercial license agreement provided with the
-** Software or, alternatively, in accordance with the terms contained in
-** a written agreement between you and The Qt Company. For licensing terms
-** and conditions see http://www.qt.io/terms-conditions. For further
-** information use the contact form at http://www.qt.io/contact-us.
-**
-** GNU Lesser General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU Lesser
-** General Public License version 2.1 or version 3 as published by the Free
-** Software Foundation and appearing in the file LICENSE.LGPLv21 and
-** LICENSE.LGPLv3 included in the packaging of this file. Please review the
-** following information to ensure the GNU Lesser General Public License
-** requirements will be met: https://www.gnu.org/licenses/lgpl.html and
-** http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
-**
-** As a special exception, The Qt Company gives you certain additional
-** rights. These rights are described in The Qt Company LGPL Exception
-** version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
-**
-** $QT_END_LICENSE$
-**
-****************************************************************************/
-
-#include <private/qfixed_p.h>
-#include <private/qfontengine_p.h>
-
-/* TODO: find a dynamic library with these symbols. */
-
-/* Debian maintainer: this function is taken from qfiledialog.cpp */
-/*
-    Makes a list of filters from ;;-separated text.
-    Used by the mac and windows implementations
-*/
-QStringList qt_make_filter_list(const QString &filter)
-{
-    QString f(filter);
-
-    if (f.isEmpty())
-        return QStringList();
-
-    QString sep(QLatin1String(";;"));
-    int i = f.indexOf(sep, 0);
-    if (i == -1) {
-        if (f.indexOf(QLatin1Char('\n'), 0) != -1) {
-            sep = QLatin1Char('\n');
-            i = f.indexOf(sep, 0);
-        }
-    }
-
-    return f.split(sep);
-}
-
-/* Debian maintainer: this constructor is taken from qtextengine.cpp for TextPainter::drawLine */
-QTextItemInt::QTextItemInt(const QGlyphLayout &g, QFont *font, const QChar *chars_, int numChars, QFontEngine *fe, const QTextCharFormat &format)
-    : flags(0), justified(false), underlineStyle(QTextCharFormat::NoUnderline), charFormat(format),
-      num_chars(numChars), chars(chars_), logClusters(0), f(font),  glyphs(g), fontEngine(fe)
-{
-}
-
-/* Debian maintainer: this method is also taken from qtextengine.cpp */
-// Fix up flags and underlineStyle with given info
-void QTextItemInt::initWithScriptItem(const QScriptItem &si)
-{
-    // explicitly initialize flags so that initFontAttributes can be called
-    // multiple times on the same TextItem
-    flags = 0;
-    if (si.analysis.bidiLevel %2)
-        flags |= QTextItem::RightToLeft;
-    ascent = si.ascent;
-    descent = si.descent;
-
-    if (charFormat.hasProperty(QTextFormat::TextUnderlineStyle)) {
-        underlineStyle = charFormat.underlineStyle();
-    } else if (charFormat.boolProperty(QTextFormat::FontUnderline)
-               || f->d->underline) {
-        underlineStyle = QTextCharFormat::SingleUnderline;
-    }
-
-    // compat
-    if (underlineStyle == QTextCharFormat::SingleUnderline)
-        flags |= QTextItem::Underline;
-
-    if (f->d->overline || charFormat.fontOverline())
-        flags |= QTextItem::Overline;
-    if (f->d->strikeOut || charFormat.fontStrikeOut())
-        flags |= QTextItem::StrikeOut;
-}
diff --git a/testing/telegram-desktop/qt_functions.patch b/testing/telegram-desktop/qt_functions.patch
deleted file mode 100644
index 1fecbe9757390d8150c2390ab6b78aed5710397b..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/qt_functions.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Telegram/CMakeLists.txt b/Telegram/CMakeLists.txt
-index d8c623a..f3ca079 100644
---- a/Telegram/CMakeLists.txt
-+++ b/Telegram/CMakeLists.txt
-@@ -936,7 +936,7 @@ PRIVATE
-     mainwindow.h
-     observer_peer.cpp
-     observer_peer.h
--    qt_static_plugins.cpp
-+	qt_functions.cpp
-     settings.cpp
-     settings.h
- )
diff --git a/testing/telegram-desktop/range-v3.cmake b/testing/telegram-desktop/range-v3.cmake
deleted file mode 100644
index f622f5edb17617225b93264b20957470072a89ba..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/range-v3.cmake
+++ /dev/null
@@ -1,9 +0,0 @@
-add_library(external_ranges INTERFACE IMPORTED GLOBAL)
-add_library(desktop-app::external_ranges ALIAS external_ranges)
-
-find_package(range-v3 REQUIRED)
-
-target_include_directories(external_ranges SYSTEM
-INTERFACE
-	${RANGE_V3_INCLUDE_DIRS}
-)
diff --git a/testing/telegram-desktop/updater.patch b/testing/telegram-desktop/updater.patch
deleted file mode 100644
index 4209a0b62f20bba57a43f8b1c5dfa2ac27aa3b18..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/updater.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/Telegram/CMakeLists.txt b/Telegram/CMakeLists.txt
-index d8c623a..bd7cea0 100644
---- a/Telegram/CMakeLists.txt
-+++ b/Telegram/CMakeLists.txt
-@@ -1117,43 +1117,3 @@ else()
- endif()
- 
- set_target_properties(Telegram PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${output_folder})
--
--if (NOT build_macstore AND NOT build_winstore)
--    add_executable(Updater WIN32)
--    init_target(Updater)
--
--    add_dependencies(Telegram Updater)
--
--    nice_target_sources(Updater ${src_loc}
--    PRIVATE
--        _other/updater_win.cpp
--        _other/updater_linux.cpp
--        _other/updater_osx.m
--        _other/updater.h
--    )
--
--    set_target_properties(Updater PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${output_folder})
--
--    if (DESKTOP_APP_SPECIAL_TARGET)
--        add_executable(Packer WIN32)
--        init_target(Packer)
--
--        add_dependencies(Telegram Packer)
--
--        nice_target_sources(Packer ${src_loc}
--        PRIVATE
--            _other/packer.cpp
--            _other/packer.h
--        )
--
--        target_link_libraries(Packer
--        PRIVATE
--            desktop-app::external_qt
--            desktop-app::external_zlib
--            desktop-app::external_auto_updates
--            desktop-app::external_openssl
--        )
--
--        set_target_properties(Packer PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${output_folder})
--    endif()
--endif()
diff --git a/testing/telegram-desktop/variables-after-project.patch b/testing/telegram-desktop/variables-after-project.patch
deleted file mode 100644
index 274b03875d1bde9cdd2548b1e7d887855a9acc9c..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/variables-after-project.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ff9adc6..be6fa47 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -10,7 +10,6 @@ cmake_policy(SET CMP0091 NEW)
- 
- set_property(GLOBAL PROPERTY USE_FOLDERS ON)
- 
--include(cmake/variables.cmake)
- include(cmake/version.cmake)
- desktop_app_parse_version(Telegram/build/version)
- 
-@@ -22,6 +21,9 @@ project(Telegram
- )
- set_property(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} PROPERTY VS_STARTUP_PROJECT Telegram)
- 
-+# This has to be included after the call to 'project' otherwise cmake won't work with it
-+include(cmake/variables.cmake)
-+
- include(cmake/nice_target_sources.cmake)
- include(cmake/target_link_static_libraries.cmake)
- include(cmake/target_link_frameworks.cmake)
diff --git a/testing/telegram-desktop/werror-lto.patch b/testing/telegram-desktop/werror-lto.patch
deleted file mode 100644
index d2cc6c7210cfca1268a4000de1c28dd23729e6d2..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/werror-lto.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/cmake/options_linux.cmake b/cmake/options_linux.cmake
-index a6a13c9..cf6125c 100644
---- a/cmake/options_linux.cmake
-+++ b/cmake/options_linux.cmake
-@@ -9,7 +9,6 @@ INTERFACE
-     $<IF:$<CONFIG:Debug>,,-Ofast -fno-strict-aliasing>
-     -pipe
-     -Wall
--    -Werror
-     -W
-     -fPIC
-     -Wno-unused-variable
-@@ -33,8 +32,4 @@ INTERFACE
- if (build_linux32)
-     target_compile_options(common_options INTERFACE -g0)
-     target_link_options(common_options INTERFACE -g0)
--else()
--    target_compile_options(common_options INTERFACE $<IF:$<CONFIG:Debug>,,-g -flto>)
--    target_link_options(common_options INTERFACE $<IF:$<CONFIG:Debug>,,-g -flto -fuse-linker-plugin>)
- endif()
--
diff --git a/testing/telegram-desktop/zlib.cmake b/testing/telegram-desktop/zlib.cmake
deleted file mode 100644
index 8684c71cabc3bd627616bb37e4923fc05fa3cf36..0000000000000000000000000000000000000000
--- a/testing/telegram-desktop/zlib.cmake
+++ /dev/null
@@ -1,9 +0,0 @@
-add_library(external_zlib INTERFACE IMPORTED GLOBAL)
-add_library(desktop-app::external_zlib ALIAS external_zlib)
-
-find_package(PkgConfig REQUIRED)
-find_package(ZLIB REQUIRED)
-pkg_check_modules(MINIZIP REQUIRED minizip)
-
-target_include_directories(external_zlib SYSTEM INTERFACE ${ZLIB_INCLUDE_DIR} ${MINIZIP_INCLUDE_DIRS})
-target_link_libraries (external_zlib INTERFACE ${ZLIB_LIBRARY_RELEASE} ${MINIZIP_LIBRARIES})