From 38fc40aa335f2d58e9af009e9c017c1fa07bd938 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Sun, 21 Aug 2022 08:44:33 +0000
Subject: [PATCH] main/gcr: upgrade to 3.41.1

---
 main/gcr/APKBUILD                            | 13 ++---
 main/gcr/dont-run-gpg-tests.patch            | 12 ----
 main/gcr/fix-build-without-systemd.patch     | 28 ---------
 main/gcr/fix-meson-invalid-kw-argument.patch | 61 --------------------
 4 files changed, 4 insertions(+), 110 deletions(-)
 delete mode 100644 main/gcr/dont-run-gpg-tests.patch
 delete mode 100644 main/gcr/fix-build-without-systemd.patch
 delete mode 100644 main/gcr/fix-meson-invalid-kw-argument.patch

diff --git a/main/gcr/APKBUILD b/main/gcr/APKBUILD
index c87290e8b3e0..b2b5123529f7 100644
--- a/main/gcr/APKBUILD
+++ b/main/gcr/APKBUILD
@@ -2,7 +2,7 @@
 # Contributor: Natanael Copa <ncopa@alpinelinux.org>
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=gcr
-pkgver=3.41.0
+pkgver=3.41.1
 pkgrel=0
 pkgdesc="library for bits of crypto UI and parsing"
 url="https://wiki.gnome.org/Projects/CryptoGlue"
@@ -23,20 +23,18 @@ makedepends="
 checkdepends="xvfb-run dbus-x11"
 subpackages="
 	$pkgname-dev
-	$pkgname-doc
 	$pkgname-lang
 	$pkgname-base
 	"
 source="https://download.gnome.org/sources/gcr/${pkgver%.*}/gcr-$pkgver.tar.xz
-	fix-build-without-systemd.patch
-	fix-meson-invalid-kw-argument.patch
-	dont-run-gpg-tests.patch
 	fix-64-bit-time_t-32-bit.patch
 	"
 options="!check"  # testsuite requires community/xvfb-run
 
 build() {
 	abuild-meson \
+		-Db_lto=true \
+		-Dgtk_doc=false \
 		-Dgpg_path=/usr/bin/gpg2 \
 		-Dsystemd=disabled \
 		output
@@ -60,9 +58,6 @@ base() {
 }
 
 sha512sums="
-455acc40ed77feeb35f9845b00229f468b322b7eda0b1b5abb0153f0a6ba29f3d0364df22225143f4caf130254a1258b3c7f934370e5142f2f64e1c3084b6f6e  gcr-3.41.0.tar.xz
-29827b87272c152d98a131ab328b8711223b1d13f5057476cfdee295a46d8a4f49daf3081d67b3a59cb48700329baf2ea49b0742b4b619afb2e6d01ce785f186  fix-build-without-systemd.patch
-939e49b23747989a532cc41be6cd6d504e88f69852897f15419f3109a1b799edd7dabe9e1e98d2582dd78de6530109c101b7e0b754fc8d3a07f098dca0c6ce0d  fix-meson-invalid-kw-argument.patch
-e4fc2248497e7103980e9baf9444505649ee93c657c7a82c042ae62d7c54b2764ad7bc9780467ceda5e53a23fa11dc4957898929c7d7f995d9d0d205d18d5eb7  dont-run-gpg-tests.patch
+dd70d41636ede863d05824b26823a8f572902f7a9b6f09b0c70586ef0d4c046864e6956130b9231850a515a9fbfcd56faf20354c1cf8f697f005827c048a2325  gcr-3.41.1.tar.xz
 579b229d6f310ed035974a92a65804deae7b047cf6109e259844ecdc75df32653a2c9f9dcddba9092da335f44d07d5d82056ae0cf5775057bdb9be5b52e29bcc  fix-64-bit-time_t-32-bit.patch
 "
diff --git a/main/gcr/dont-run-gpg-tests.patch b/main/gcr/dont-run-gpg-tests.patch
deleted file mode 100644
index acab92442a36..000000000000
--- a/main/gcr/dont-run-gpg-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/gcr/meson.build b/gcr/meson.build
-index 254a933..8c17e7c 100644
---- a/gcr/meson.build
-+++ b/gcr/meson.build
-@@ -271,7 +271,6 @@ gcr_test_names = [
-   'record',
-   'memory-icon',
-   'gnupg-key',
--  'gnupg-collection',
-   'gnupg-process',
-   'system-prompt',
-   'ssh-askpass',
diff --git a/main/gcr/fix-build-without-systemd.patch b/main/gcr/fix-build-without-systemd.patch
deleted file mode 100644
index 16baa0636645..000000000000
--- a/main/gcr/fix-build-without-systemd.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 96e76ee482dad2a0d71f9a5a5a6558d272d538ca Mon Sep 17 00:00:00 2001
-From: Antoine Jacoutot <ajacoutot@gnome.org>
-Date: Sun, 24 Oct 2021 10:26:03 +0200
-Patch-Source: https://gitlab.gnome.org/GNOME/gcr/-/commit/96e76ee482dad2a0d71f9a5a5a6558d272d538ca
-Subject: [PATCH] Unbreak build without systemd.
-
-This fixes the check for WITH_SYSTEMD and prevents a fatal error:
-'systemd/sd-daemon.h' file not found when building with systemd disabled.
----
- gcr/gcr-ssh-agent-service.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/gcr/gcr-ssh-agent-service.c b/gcr/gcr-ssh-agent-service.c
-index 3b5a4ca..b7e8928 100644
---- a/gcr/gcr-ssh-agent-service.c
-+++ b/gcr/gcr-ssh-agent-service.c
-@@ -39,7 +39,7 @@
- #include <glib/gstdio.h>
- #include <gcr/gcr-base.h>
- 
--#ifdef WITH_SYSTEMD
-+#if WITH_SYSTEMD
- #include <systemd/sd-daemon.h>
- #endif
- 
--- 
-GitLab
-
diff --git a/main/gcr/fix-meson-invalid-kw-argument.patch b/main/gcr/fix-meson-invalid-kw-argument.patch
deleted file mode 100644
index 9c097deeba66..000000000000
--- a/main/gcr/fix-meson-invalid-kw-argument.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-Patch-Source: https://gitlab.gnome.org/GNOME/gcr/-/merge_requests/81
-
-From b3ca1d02bb0148ca787ac4aead164d7c8ce2c4d8 Mon Sep 17 00:00:00 2001
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Wed, 12 Jan 2022 00:24:20 +0100
-Subject: [PATCH] meson: Fix unknown kw argument in gnome.generate_gir
-
-This argument has been removed in Meson 0.61.0:
-
-    gck/meson.build:130:2: ERROR: gnome.generate_gir got unknown keyword arguments "packages"
-
-https://github.com/mesonbuild/meson/commit/f8fc5cb860465718fe7c79a1bf1fe00659f138de:
-
-> The packages argument to gnome.generate_gir was allowed, but never did anything, so stop passing it.
-
-Fixes #89
----
- gck/meson.build | 1 -
- gcr/meson.build | 1 -
- ui/meson.build  | 1 -
- 3 files changed, 3 deletions(-)
-
-diff --git a/gck/meson.build b/gck/meson.build
-index 756b486..a21a1e9 100644
---- a/gck/meson.build
-+++ b/gck/meson.build
-@@ -131,7 +131,6 @@ if get_option('introspection')
-     sources: gck_gir_sources,
-     namespace: 'Gck',
-     nsversion: '@0@'.format(gck_major_version),
--    packages: gck_deps,
-     export_packages: 'gck-@0@'.format(gck_major_version),
-     includes: [ 'GObject-2.0', 'Gio-2.0' ],
-     header: 'gck/gck.h',
-diff --git a/gcr/meson.build b/gcr/meson.build
-index 2233a44..c83641b 100644
---- a/gcr/meson.build
-+++ b/gcr/meson.build
-@@ -190,7 +190,6 @@ if get_option('introspection')
-     sources: [ gcr_base_public_sources, gcr_base_headers ],
-     namespace: 'Gcr',
-     nsversion: '@0@'.format(gcr_major_version),
--    packages: gcr_base_deps,
-     export_packages: 'gcr-base-@0@'.format(gcr_major_version),
-     includes: [
-       'GObject-2.0',
-diff --git a/ui/meson.build b/ui/meson.build
-index e656ea2..32ee057 100644
---- a/ui/meson.build
-+++ b/ui/meson.build
-@@ -152,7 +152,6 @@ if get_option('introspection')
-     export_packages: 'gcr-ui-@0@'.format(gcr_major_version),
-     identifier_prefix: 'Gcr',
-     symbol_prefix: 'gcr',
--    packages: gcr_ui_deps,
-     includes: [
-       'GObject-2.0',
-       'Gio-2.0',
--- 
-GitLab
-
-- 
GitLab