Commit 385c2821 authored by Ted Trask's avatar Ted Trask

main/lua-posix: Change depends to include Lua 5.1 and 5.2 versions

parent 0df72bd5
......@@ -5,16 +5,17 @@ _luaversions="5.1 5.2"
pkgname=lua-posix
_name=luaposix
pkgver=32
pkgrel=1
pkgrel=2
pkgdesc="POSIX library for Lua $_luaver"
url="https://github.com/luaposix/luaposix"
arch="all"
license="MIT"
depends="lua5.1-posix"
depends=""
makedepends="perl ncurses-dev automake autoconf lua5.1-bitlib"
subpackages="$pkgname-doc"
for _i in $_luaversions; do
depends="$depends lua$_i-posix"
makedepends="$makedepends lua$_i-dev"
subpackages="$subpackages lua$_i-posix:_posix_${_i/./_}
lua$_i-curses:_curses_${_i/./_}"
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment