From 3764d7538da6d48530b0921887e636a06bccf30a Mon Sep 17 00:00:00 2001
From: omni <omni+alpine@hack.org>
Date: Sun, 24 Nov 2024 21:49:11 +0000
Subject: [PATCH] community/py3-networkx: upgrade to 3.4.2

- enable all tests, except on riscv64
- hand maintainership to WSinatra
---
 community/py3-networkx/APKBUILD | 29 +++++++++++++++++------------
 1 file changed, 17 insertions(+), 12 deletions(-)

diff --git a/community/py3-networkx/APKBUILD b/community/py3-networkx/APKBUILD
index 4d39ed42a612..5d5601bc6c59 100644
--- a/community/py3-networkx/APKBUILD
+++ b/community/py3-networkx/APKBUILD
@@ -1,8 +1,9 @@
 # Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer:
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
+maintainer="Will Sinatra <wpsinatra@gmail.com>"
 pkgname=py3-networkx
-pkgver=3.2.1
-pkgrel=1
+pkgver=3.4.2
+pkgrel=0
 pkgdesc="Software for complex networks"
 url="https://networkx.org/"
 arch="noarch"
@@ -42,14 +43,18 @@ check() {
 	python3 -m venv --clear --without-pip --system-site-packages .testenv
 	.testenv/bin/python3 -m installer .dist/*.whl
 
-	# Broken with graphviz
-	# travellingsalesman:
-	# https://github.com/networkx/networkx/issues/5913
-	.testenv/bin/python3 -m pytest -n auto \
-		--ignore networkx/drawing/tests/test_agraph.py \
-		--ignore networkx/algorithms/approximation/tests/test_traveling_salesman.py \
-		--ignore networkx/linalg/tests/test_algebraic_connectivity.py \
-		-k "not test_connected_raise"
+	case "$CARCH" in
+	riscv64)
+		.testenv/bin/python3 -m pytest \
+			--ignore networkx/algorithms/bipartite/tests/test_spectral_bipartivity.py \
+			--ignore networkx/algorithms/centrality/tests/test_subgraph.py \
+			--ignore networkx/algorithms/tests/test_communicability.py
+		# these tests deadlock or take a very long time to complete
+		;;
+	*)
+		.testenv/bin/python3 -m pytest
+		;;
+	esac
 }
 
 package() {
@@ -63,5 +68,5 @@ package() {
 }
 
 sha512sums="
-579c54a4a016617f5260df01b821c3906c4f289e80ae7bd618c0ebb9e05ebe806e71f1f660e3012531d04572ac4e6670aa73117ed26da8248fbb8ef7228b5803  networkx-3.2.1.tar.gz
+910e1400ad18711761c715896c3238b9c7d8914c571ab4db3aaf18a772b5fef90e5378ca435fbfce55b5821f1ddd3863a3cd65030086e80a971df91d9203c637  networkx-3.4.2.tar.gz
 "
-- 
GitLab