diff --git a/testing/godot/APKBUILD b/testing/godot/APKBUILD
index 42fff4411633705c4bdecc42bd00f93bdb467753..b14d5c1759aafefcbe17254c3461c90413c72acc 100644
--- a/testing/godot/APKBUILD
+++ b/testing/godot/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Díaz Urbaneja Diego <sodomon2@gmail.com>
 # Maintainer: Díaz Urbaneja Diego <sodomon2@gmail.com>
 pkgname=godot
-pkgver=4.2.2
+pkgver=4.3
 pkgrel=0
 pkgdesc="Multi-platform 2D and 3D game engine"
 url="https://godotengine.org"
@@ -18,6 +18,7 @@ makedepends="
 	graphite2-dev
 	harfbuzz-dev
 	icu-dev
+	libdecor-dev
 	libgudev-dev
 	libogg-dev
 	libpng-dev
@@ -28,6 +29,7 @@ makedepends="
 	libxcursor-dev
 	libxi-dev
 	libxinerama-dev
+	libxkbcommon-dev
 	libxrandr-dev
 	mbedtls2-dev
 	mesa-dev
@@ -37,6 +39,7 @@ makedepends="
 	pulseaudio-dev
 	python3-dev
 	scons
+	wayland-dev
 	wslay-dev
 	zlib-dev
 	zstd-dev
@@ -44,9 +47,9 @@ makedepends="
 depends="ca-certificates-bundle"
 subpackages="$pkgname-doc $pkgname-templates"
 source="https://github.com/godotengine/godot/releases/download/$pkgver-stable/godot-$pkgver-stable.tar.xz
-	no-execinfo.patch
 	miniupnpc.patch
 	glslang.patch
+	wayland-include.patch
 	"
 options="!check" # No tests
 builddir="$srcdir"/godot-"$pkgver"-stable
@@ -81,7 +84,7 @@ _sconsflags="
 
 case "$CARCH" in
 aarch64|x86_64)
-	makedepends="$makedepends embree3-dev"
+	makedepends="$makedepends embree-dev"
 	_sconsflags="$_sconsflags builtin_embree=false"
 	;;
 esac
@@ -117,9 +120,9 @@ build() {
 			target=$target \
 			arch=$arch \
 			$_sconsflags \
-			CFLAGS="$CFLAGS -O2" \
-			CXXFLAGS="$CXXFLAGS -O2" \
-			LINKFLAGS="$LDFLAGS"
+			cflags="$CFLAGS -O2" \
+			cxxflags="$CXXFLAGS -O2" \
+			linkflags="$LDFLAGS"
 	done
 }
 
@@ -143,8 +146,8 @@ templates() {
 }
 
 sha512sums="
-4a623063be5488957e1ede7e45b6865f6cd61bc954ac311587b9e97bed848a4083c4a7225d0a81bca285d854d33be9b07d7d0c21465c9f25b90e92b08090429c  godot-4.2.2-stable.tar.xz
-7563942223564d5235d96a27c840ce0c9d7ceb9690ce1ed02f43c0c4e7b28e85f8311a18b79aeab545bdb83822604f05f98b561d2d00dd3a1b9cea60f528a7d8  no-execinfo.patch
-a9d227f9fadf0f70bfb58b31232596b3865ced1c7d5989b7a14bf60d19e83d6b1c382199100d3a1b79afa45f2f24035632adfb075596a76e6a24c0b4ba8bdf59  miniupnpc.patch
-fff7ae51eb1b37c21d8b9cdb895cc4751d3678e1db17a8793229d8edaf2b483a07d9692a150429f0f96a8b3437a3833bfe283561b6967a81d7c2252cca99bb08  glslang.patch
+6e1eaba5c3447527ce60d623f7f81cbd90633a5a1ad4c6dd469055a43c8fb9b4807fcd3bae25331294596c2418eb6c0c9db0871c3e1405ddcc7d84e29c39a45b  godot-4.3-stable.tar.xz
+3802ea6977f0e4c969ae0592af7c35a9f7150fe42840c4345d9cc9bdb94a1de032f7cdec232a4497cef92481a5695bdedaae235c77be05da6e9b6bcf4f6e32ba  miniupnpc.patch
+0878e5f269fa16884d8b84e217c96817245dc6748a3fe60ae576dfd3006123f59ff25fac793898a30a8a6ff70b2accbde474671d998d7b05584951512743f7a0  glslang.patch
+ab3dfda69c78ac132d5be4474ff46eca397fe687e4232ec123c50489ef7eace8d5586f6671e4fb65feb24f82b1b9ff6eb26a84eba9141e4f1dc9d43212bc593b  wayland-include.patch
 "
diff --git a/testing/godot/glslang.patch b/testing/godot/glslang.patch
index 4d2372d73769d1e68340a6cb9c134b1b4e410245..c3a5db3281515273d51c8be024bdf240afaac9b5 100644
--- a/testing/godot/glslang.patch
+++ b/testing/godot/glslang.patch
@@ -1,18 +1,7 @@
 Fix compilation with builtin_glslang=false
 
 Ref https://github.com/godotengine/godot/pull/93478
-Ref https://github.com/godotengine/godot/pull/93471
 
---- a/modules/glslang/register_types.cpp
-+++ b/modules/glslang/register_types.cpp
-@@ -33,7 +33,6 @@
- #include "core/config/engine.h"
- #include "servers/rendering/rendering_device.h"
- 
--#include <glslang/Include/Types.h>
- #include <glslang/Public/ResourceLimits.h>
- #include <glslang/Public/ShaderLang.h>
- #include <glslang/SPIRV/GlslangToSpv.h>
 --- a/platform/linuxbsd/detect.py
 +++ b/platform/linuxbsd/detect.py
 @@ -480,7 +480,7 @@ def configure(env: "SConsEnvironment"):
diff --git a/testing/godot/miniupnpc.patch b/testing/godot/miniupnpc.patch
index 4070f211bf1e7dec5827fab47a3452afb9bc0fe7..7a08348f3cad621224a7f831d554c4deff978e1b 100644
--- a/testing/godot/miniupnpc.patch
+++ b/testing/godot/miniupnpc.patch
@@ -6,8 +6,8 @@ API changed in miniupnpc 2.2.8
  	}
  
  	char addr[16];
--	int i = UPNP_GetValidIGD(devlist, urls, &data, (char *)&addr, 16);
-+	int i = UPNP_GetValidIGD(devlist, urls, &data, (char *)&addr, 16, nullptr, 0);
+-	int i = UPNP_GetValidIGD(devlist, &urls, &data, (char *)&addr, 16);
++	int i = UPNP_GetValidIGD(devlist, &urls, &data, (char *)&addr, 16, nullptr, 0);
  
  	if (i != 1) {
  		FreeUPNPUrls(urls);
diff --git a/testing/godot/no-execinfo.patch b/testing/godot/no-execinfo.patch
deleted file mode 100644
index 202bc9c02aae38fddc4165684fe6b1a95561e4a0..0000000000000000000000000000000000000000
--- a/testing/godot/no-execinfo.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/platform/linuxbsd/crash_handler_linuxbsd.cpp b/platform/linuxbsd/crash_handler_linuxbsd.cpp
-index 3a24546..ae7430f 100644
---- a/platform/linuxbsd/crash_handler_linuxbsd.cpp
-+++ b/platform/linuxbsd/crash_handler_linuxbsd.cpp
-@@ -37,7 +37,6 @@
- #include "main/main.h"
- 
- #ifdef DEBUG_ENABLED
--#define CRASH_HANDLER_ENABLED 1
- #endif
- 
- #ifdef CRASH_HANDLER_ENABLED
-diff --git a/platform/linuxbsd/detect.py b/platform/linuxbsd/detect.py
-index 3f713d2..e27e1eb 100644
---- a/platform/linuxbsd/detect.py
-+++ b/platform/linuxbsd/detect.py
-@@ -429,8 +429,8 @@ def configure(env: "Environment"):
-     if not env["execinfo"] and platform.libc_ver()[0] != "glibc":
-         # The default crash handler depends on glibc, so if the host uses
-         # a different libc (BSD libc, musl), fall back to libexecinfo.
--        print("Note: Using `execinfo=yes` for the crash handler as required on platforms where glibc is missing.")
--        env["execinfo"] = True
-+        # print("Note: Using `execinfo=yes` for the crash handler as required on platforms where glibc is missing.")
-+        env["execinfo"] = False
- 
-     if env["execinfo"]:
-         env.Append(LIBS=["execinfo"])
diff --git a/testing/godot/wayland-include.patch b/testing/godot/wayland-include.patch
new file mode 100644
index 0000000000000000000000000000000000000000..39e9dc37ba6214a25891fc661c974283fe903177
--- /dev/null
+++ b/testing/godot/wayland-include.patch
@@ -0,0 +1,27 @@
+From 6ce71f0fb0a091cffb6adb4af8ab3f716ad8930b Mon Sep 17 00:00:00 2001
+From: Joel Winarske <joel.winarske@gmail.com>
+Date: Fri, 23 Aug 2024 14:16:37 -0700
+Subject: [PATCH] Use wayland-egl-core.h instead of wayland-egl.h
+
+-avoid use of transitive wayland include
+
+-resolves https://github.com/godotengine/godot/issues/95830
+
+Signed-off-by: Joel Winarske <joel.winarske@gmail.com>
+---
+ platform/linuxbsd/wayland/wayland_thread.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/platform/linuxbsd/wayland/wayland_thread.h b/platform/linuxbsd/wayland/wayland_thread.h
+index 6fd7a6096669..84e9bdc2dc08 100644
+--- a/platform/linuxbsd/wayland/wayland_thread.h
++++ b/platform/linuxbsd/wayland/wayland_thread.h
+@@ -44,7 +44,7 @@
+ #include <wayland-client-core.h>
+ #include <wayland-cursor.h>
+ #ifdef GLES3_ENABLED
+-#include <wayland-egl.h>
++#include <wayland-egl-core.h>
+ #endif
+ #include <xkbcommon/xkbcommon.h>
+ #endif // SOWRAP_ENABLED