Commit 368eb6d2 authored by alice's avatar alice 🗡
Browse files

community/py3-jsonschema: upgrade to 4.6.0

actually hard-required by ansible-lint
parent a46be239
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-jsonschema
pkgver=4.5.1
pkgrel=1
pkgver=4.6.0
pkgrel=0
pkgdesc="An implementation of JSON Schema validation for Python"
url="https://github.com/Julian/jsonschema"
arch="noarch"
license="MIT"
depends="python3 py3-pyrsistent py3-attrs py3-six"
makedepends="py3-build py3-installer py3-setuptools_scm py3-wheel"
makedepends="py3-build py3-installer py3-hatchling py3-hatch-vcs py3-setuptools_scm py3-wheel"
checkdepends="py3-twisted py3-pytest py3-tox"
source="https://files.pythonhosted.org/packages/source/j/jsonschema/jsonschema-$pkgver.tar.gz"
builddir="$srcdir/jsonschema-$pkgver"
......@@ -21,8 +21,7 @@ build() {
}
check() {
PYTHONPATH="$PWD/build/lib" py.test-3 -v \
--deselect jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
tox -e py310-noextra-tests --sitepackages
}
package() {
......@@ -38,5 +37,5 @@ package() {
}
sha512sums="
3866a649ece45c1c69d3d5e9810cfdb094f1af82fcc08a186f9babd7516ad311c4bffa52f61f013bc84e7ab1be06605c5fab738c1c920ff8ce85a73429d9efde jsonschema-4.5.1.tar.gz
82d9e0c7de867c4a53b67b9dc79a38a76e384f5d41c66b52c57d407e03eb97faf8ebf41370ef08b30966f13eca210f94916b6a40347a2a75088e33017ccc2f5f jsonschema-4.6.0.tar.gz
"
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment