diff --git a/community/gitlab-runner/APKBUILD b/community/gitlab-runner/APKBUILD
index 4cf5dbf86e7967accca9343be68fd300c34ef569..9c7c214fd41a4151a5e232caed331ffab8ca28e8 100644
--- a/community/gitlab-runner/APKBUILD
+++ b/community/gitlab-runner/APKBUILD
@@ -23,6 +23,7 @@ source="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v$pkgver/gitlab-ru
 	allow-disable-colors-in-log.patch
 	$pkgname.initd
 	$pkgname.confd
+	$pkgname.logrotate
 	"
 builddir="$srcdir/$pkgname-v$pkgver"
 
@@ -51,6 +52,7 @@ package() {
 
 	install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
 	install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+	install -Dm644 "$srcdir"/$pkgname.logrotate "$pkgdir"/etc/logrotate.d/$pkgname
 
 	install -d -m750 -o "$pkgusers" -g "$pkggroups" "$pkgdir"/etc/$pkgname
 	install -d -m700 -o "$pkgusers" -g "$pkggroups" "$pkgdir"/var/lib/$pkgname
@@ -67,4 +69,5 @@ sha512sums="
 f98a84c10aaebd7cb3c487ae02df17d00f6938aba5e175061220ee1a3cd583a4a4a9abb263cb50556a7170e069c41e623eb94f4696f192429b557bd6827383f6  allow-disable-colors-in-log.patch
 e5a85bb65972c11fd775d7011cc5f0f055a2f29127c006b6434c4764052e6333ae659b03de79ed91784bdcda4e091de34cd0551963bb00dae37fe11acc938b24  gitlab-runner.initd
 a80a1811099f353c4511d1ff9a2f674ce8f9254d460304aa2d66bcc258da2a979033316260663a4745be807d8891895572e5220eabc702230b69e92de4f78205  gitlab-runner.confd
+2ddd42622b72135a95ac1c09061b61e73c4f89d4f0a86d1a3c902760d4a5f2c749a04f2d81568c973c83b1aae60ada71360a6bf74a31f8e5d9b10b90af4cdcfe  gitlab-runner.logrotate
 "
diff --git a/community/gitlab-runner/gitlab-runner.logrotate b/community/gitlab-runner/gitlab-runner.logrotate
new file mode 100644
index 0000000000000000000000000000000000000000..f6bacf4c1249d7ebc72d4d173ffce54e0b580187
--- /dev/null
+++ b/community/gitlab-runner/gitlab-runner.logrotate
@@ -0,0 +1,5 @@
+/var/log/gitlab-runner.log {
+	copytruncate
+	missingok
+	notifempty
+}