diff --git a/testing/rsstail/APKBUILD b/testing/rsstail/APKBUILD
index 7dd56ddcf83db97b4b3af2434bf7a2365ed6994e..02b03cf0dc50b67e994d2419afced2cf09e9b38d 100644
--- a/testing/rsstail/APKBUILD
+++ b/testing/rsstail/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Francesco Colista <fcolista@alpinelinux.org>
 # Maintainer: Francesco Colista <fcolista@alpinelinux.org>
 pkgname=rsstail
-pkgver=2.1
-pkgrel=1
+pkgver=2.2
+pkgrel=0
 pkgdesc="tail for rss feeds"
 url="https://www.vanheusden.com/rsstail/"
 arch="all"
@@ -11,28 +11,22 @@ makedepends="libmrss-dev curl-dev"
 checkdepends="cppcheck"
 subpackages="$pkgname-doc"
 source="$pkgname-$pkgver.tgz::https://github.com/folkertvanheusden/$pkgname/archive/refs/tags/v$pkgver.tar.gz
-	fix-build.patch
 	makefile-suppor-install-destdir-path.patch"
-builddir="$srcdir/$pkgname-$pkgver"
 
 build() {
-	cd "$builddir"
 	return 0
 }
 
 check() {
-	cd "$builddir"
 	make check
 }
 
 package() {
-	cd "$builddir"
 	mkdir -p "$pkgdir"/usr/bin
 	make DESTDIR=$pkgdir install
 }
 
 sha512sums="
-f44b029c7f4ecde1b59db9b84d50e8651871303d057ce92db52a98d16c08d4498d8f946f71a0305d98956aabe114a0c9f2bf2a7a359efd1d13577ec273b905f9  rsstail-2.1.tgz
-66e2cd6952da68a617c4971df494c5a65258ac7851e82bfe83d3cba2ab7c0b7e7e37c7984dff3988808f8301eaa651e0d1795f0041ba3a4bd84e21ed09dcee49  fix-build.patch
+cc80c2cf03d5bb52f4e531e47c10ea29a49f6b4418fb37f29c21889826e4c1d3594063f2b8ddadf9d2c7af103e29a29c0166fc2f138a144235f9064e9601b03d  rsstail-2.2.tgz
 aa935fe0d41ebde9d1da8acc7987c3b8c71a3c67600ef95afb2c36349709bfbcf9ad1eafb2c59532935cd82f7e9556721062d6571216fa5420b7a9912f32a582  makefile-suppor-install-destdir-path.patch
 "
diff --git a/testing/rsstail/fix-build.patch b/testing/rsstail/fix-build.patch
deleted file mode 100644
index d74bc99c4de09b6c7fbf63120ff7228422590cc4..0000000000000000000000000000000000000000
--- a/testing/rsstail/fix-build.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From c87a4476240d4a2c3e4a9060464aaf9b266357e9 Mon Sep 17 00:00:00 2001
-From: Wenlong Zhang <zhangwenlong@loongson.cn>
-Date: Mon, 1 Jul 2024 12:42:41 +0000
-Subject: [PATCH 1/2] fix build
-
----
- Makefile | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 4a7f6d0..a5a6b81 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,8 +1,7 @@
- VERSION=2.1
- 
--DEBUG=-g
--LDFLAGS=-liconv_hook -lmrss $(DEBUG)
--CFLAGS=-O3 -Wall --std=gnu11 -DVERSION=\"$(VERSION)\" $(DEBUG)
-+override LDFLAGS+=-lmrss
-+override CFLAGS+=-Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
- 
- OBJS=r2t.o
- 
--- 
-2.45.2
-