From 345e721a455a07b2e22a97e19ee28b4d4a74c072 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Wed, 17 May 2023 04:11:23 +0000
Subject: [PATCH] */*: replace $url in source= with the url

the two are distinct, url isn't a variable. it could be changed to
update to e.g. a documentation site, source url is separate
---
 community/dzen/APKBUILD                     | 8 +++++---
 community/emptty/APKBUILD                   | 2 +-
 community/foot/APKBUILD                     | 2 +-
 community/fortune/APKBUILD                  | 2 +-
 community/go-bindata/APKBUILD               | 2 +-
 community/html-xml-utils/APKBUILD           | 2 +-
 community/libtpms/APKBUILD                  | 2 +-
 community/neofetch/APKBUILD                 | 2 +-
 community/prometheus-json-exporter/APKBUILD | 2 +-
 community/pwsafe/APKBUILD                   | 2 +-
 community/py3-dirty-equals/APKBUILD         | 2 +-
 community/py3-svgwrite/APKBUILD             | 2 +-
 community/swtpm/APKBUILD                    | 2 +-
 community/sxiv/APKBUILD                     | 2 +-
 community/xbanish/APKBUILD                  | 2 +-
 community/xprintidle/APKBUILD               | 2 +-
 community/xwallpaper/APKBUILD               | 2 +-
 main/awall/APKBUILD                         | 2 +-
 main/axel/APKBUILD                          | 2 +-
 main/ddate/APKBUILD                         | 2 +-
 main/dmvpn/APKBUILD                         | 2 +-
 main/hiredis/APKBUILD                       | 2 +-
 main/lua-asn1/APKBUILD                      | 2 +-
 main/lua-schema/APKBUILD                    | 2 +-
 main/tiny-cloud/APKBUILD                    | 2 +-
 testing/afetch/APKBUILD                     | 2 +-
 testing/cgo/APKBUILD                        | 2 +-
 testing/devmem2/APKBUILD                    | 2 +-
 testing/disfetch/APKBUILD                   | 2 +-
 testing/font-merriweather/APKBUILD          | 2 +-
 testing/innernet/APKBUILD                   | 2 +-
 testing/lua-inet/APKBUILD                   | 2 +-
 testing/mkg3a/APKBUILD                      | 2 +-
 testing/pfetch/APKBUILD                     | 2 +-
 testing/pipe-viewer/APKBUILD                | 2 +-
 testing/py3-enzyme/APKBUILD                 | 2 +-
 testing/py3-pysrt/APKBUILD                  | 2 +-
 testing/subliminal/APKBUILD                 | 2 +-
 testing/tmux-resurrect/APKBUILD             | 2 +-
 testing/topgit/APKBUILD                     | 2 +-
 testing/tremc/APKBUILD                      | 2 +-
 testing/wabt/APKBUILD                       | 2 +-
 testing/xcape/APKBUILD                      | 2 +-
 testing/xkb-switch/APKBUILD                 | 2 +-
 testing/youtube-viewer/APKBUILD             | 2 +-
 45 files changed, 49 insertions(+), 47 deletions(-)

diff --git a/community/dzen/APKBUILD b/community/dzen/APKBUILD
index 26f6028000d7..e9efc8bec2c5 100644
--- a/community/dzen/APKBUILD
+++ b/community/dzen/APKBUILD
@@ -11,7 +11,7 @@ license="MIT"
 makedepends="libx11-dev libxft-dev libxinerama-dev libxpm-dev"
 subpackages="$pkgname-gadgets"
 options="!check"  # no test suite
-source="$pkgname-$_pkgver.tar.gz::$url/archive/$_pkgver.tar.gz
+source="$pkgname-$_pkgver.tar.gz::https://github.com/robm/dzen/archive/$_pkgver.tar.gz
 	0001-Enable-Xinerama-and-XPM.patch"
 builddir="$srcdir/$pkgname-$_pkgver"
 
@@ -29,5 +29,7 @@ gadgets() {
 	make PREFIX=/usr DESTDIR="$subpkgdir" install
 }
 
-sha512sums="e750ab9c62dad311bf478d79c15ffdc1ef108fe2c3ed5df82316d879aad000bee785d304048f5daae237468f6fe018f14fc05d0114d68d873f766dbf1dfebbc9  dzen-488ab66019f475e35e067646621827c18a879ba1.tar.gz
-06cf3474926e7f2d612e36a96e10673a2d261a9a1dd9fec8c2382f1ceb9f1d203232980d73910723cd050d6d25c14ef2fae81b6413a58056a183fec1936cd73a  0001-Enable-Xinerama-and-XPM.patch"
+sha512sums="
+e750ab9c62dad311bf478d79c15ffdc1ef108fe2c3ed5df82316d879aad000bee785d304048f5daae237468f6fe018f14fc05d0114d68d873f766dbf1dfebbc9  dzen-488ab66019f475e35e067646621827c18a879ba1.tar.gz
+06cf3474926e7f2d612e36a96e10673a2d261a9a1dd9fec8c2382f1ceb9f1d203232980d73910723cd050d6d25c14ef2fae81b6413a58056a183fec1936cd73a  0001-Enable-Xinerama-and-XPM.patch
+"
diff --git a/community/emptty/APKBUILD b/community/emptty/APKBUILD
index c8aaa1717b63..8fc81937b26a 100644
--- a/community/emptty/APKBUILD
+++ b/community/emptty/APKBUILD
@@ -7,7 +7,7 @@ url="https://github.com/tvrzna/emptty"
 arch="all"
 license="MIT"
 makedepends="git go linux-pam-dev libx11-dev"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tvrzna/emptty/archive/v$pkgver.tar.gz"
 subpackages="
 	$pkgname-doc
 	$pkgname-openrc
diff --git a/community/foot/APKBUILD b/community/foot/APKBUILD
index 2caa8c7fb8ff..5a5da25ad2ff 100644
--- a/community/foot/APKBUILD
+++ b/community/foot/APKBUILD
@@ -33,7 +33,7 @@ subpackages="
 	$pkgname-themes:_themes:noarch
 	"
 source="
-	$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz
+	$pkgname-$pkgver.tar.gz::https://codeberg.org/dnkl/foot/archive/$pkgver.tar.gz
 
 	0001-quirks-sway-does-not-damage-surface-beneath-sub-surface-when-unmapped.patch::https://codeberg.org/dnkl/foot/commit/3b41379be43a21a00a776d0d136c5d1b2fe4007e.diff
 	0002-regress-sway-damage.patch::https://codeberg.org/dnkl/foot/commit/738deb236853ebf1e19843e536b9bda053b69bf7.diff
diff --git a/community/fortune/APKBUILD b/community/fortune/APKBUILD
index f14849af65b7..c95ed2c8bd8e 100644
--- a/community/fortune/APKBUILD
+++ b/community/fortune/APKBUILD
@@ -10,7 +10,7 @@ license="BSD-3-Clause"
 options="!check" # no test suite
 makedepends="libbsd-dev"
 subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ahills/fortune/archive/v$pkgver.tar.gz"
 
 build() {
 	make PREFIX=/usr
diff --git a/community/go-bindata/APKBUILD b/community/go-bindata/APKBUILD
index 619e141e313a..517b716972d4 100644
--- a/community/go-bindata/APKBUILD
+++ b/community/go-bindata/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
 license="CC0-1.0"
 makedepends="go"
 options="!check" # No test suite
-source="go-bindata-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="go-bindata-$pkgver.tar.gz::https://github.com/go-bindata/go-bindata/archive/v$pkgver.tar.gz"
 
 export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
 export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
diff --git a/community/html-xml-utils/APKBUILD b/community/html-xml-utils/APKBUILD
index e5c0e92ef70e..e78f0f993758 100644
--- a/community/html-xml-utils/APKBUILD
+++ b/community/html-xml-utils/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
 license="W3C"
 checkdepends="netcat-openbsd"
 subpackages="$pkgname-doc"
-source="$url/$pkgname-$pkgver.tar.gz"
+source="https://www.w3.org/Tools/HTML-XML-utils//$pkgname-$pkgver.tar.gz"
 
 prepare() {
 	default_prepare
diff --git a/community/libtpms/APKBUILD b/community/libtpms/APKBUILD
index 2f10a6131c5f..52baa31c0ef9 100644
--- a/community/libtpms/APKBUILD
+++ b/community/libtpms/APKBUILD
@@ -9,7 +9,7 @@ arch="aarch64 armhf x86 x86_64"
 license="BSD-3-Clause"
 makedepends="autoconf automake bash gawk libtool make openssl-dev>3"
 subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/stefanberger/libtpms/archive/v$pkgver.tar.gz"
 
 prepare() {
 	default_prepare
diff --git a/community/neofetch/APKBUILD b/community/neofetch/APKBUILD
index a212ae2c9227..7ec3d036f0b1 100644
--- a/community/neofetch/APKBUILD
+++ b/community/neofetch/APKBUILD
@@ -11,7 +11,7 @@ depends="bash"
 makedepends="make"
 options="!check"
 subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dylanaraps/neofetch/archive/$pkgver.tar.gz"
 
 package() {
 	make DESTDIR="$pkgdir" install
diff --git a/community/prometheus-json-exporter/APKBUILD b/community/prometheus-json-exporter/APKBUILD
index f5f263bf5a36..258cac567417 100644
--- a/community/prometheus-json-exporter/APKBUILD
+++ b/community/prometheus-json-exporter/APKBUILD
@@ -11,7 +11,7 @@ arch="all !riscv64" # nonexistent riscv64 dependency downloaded at build time
 makedepends="go>=1.14 bash sed"
 install="$pkgname.pre-install $pkgname.pre-upgrade"
 subpackages="$pkgname-openrc"
-source="$_pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
+source="$_pkgname-$pkgver.tar.gz::https://github.com/prometheus-community/json_exporter/archive/v$pkgver.tar.gz
 	json-exporter.initd
 	json-exporter.confd
 	0001-disable-go-race-detector.patch
diff --git a/community/pwsafe/APKBUILD b/community/pwsafe/APKBUILD
index 50ef1f1b7f66..dd4ad80077d4 100644
--- a/community/pwsafe/APKBUILD
+++ b/community/pwsafe/APKBUILD
@@ -10,7 +10,7 @@ arch="all"
 license="GPL-2.0"
 makedepends="autoconf automake ncurses-dev openssl-dev>3 libxmu-dev readline-dev"
 subpackages="$pkgname-doc"
-source="$url/archive/$_commit/$pkgname-$_commit.tar.gz"
+source="https://github.com/nsd20463/pwsafe/archive/$_commit/$pkgname-$_commit.tar.gz"
 options="suid"
 builddir="$srcdir/$pkgname-$_commit"
 
diff --git a/community/py3-dirty-equals/APKBUILD b/community/py3-dirty-equals/APKBUILD
index 423544990cdd..82f39b2d9129 100644
--- a/community/py3-dirty-equals/APKBUILD
+++ b/community/py3-dirty-equals/APKBUILD
@@ -11,7 +11,7 @@ depends="python3 py3-tz py3-typing-extensions"
 makedepends="py3-gpep517 py3-installer py3-wheel py3-hatchling"
 checkdepends="py3-pytest"
 subpackages="$pkgname-pyc"
-source="$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/samuelcolvin/dirty-equals/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
 builddir="$srcdir/dirty-equals-$pkgver"
 
 build() {
diff --git a/community/py3-svgwrite/APKBUILD b/community/py3-svgwrite/APKBUILD
index b98e188ff9c4..378f58ea11d5 100644
--- a/community/py3-svgwrite/APKBUILD
+++ b/community/py3-svgwrite/APKBUILD
@@ -16,7 +16,7 @@ checkdepends="
 	py3-pytest
 "
 subpackages="$pkgname-pyc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mozman/svgwrite/archive/v$pkgver.tar.gz"
 builddir="$srcdir/$_pkgname-$pkgver"
 
 build() {
diff --git a/community/swtpm/APKBUILD b/community/swtpm/APKBUILD
index 0c45afec14bb..8ce9c4054492 100644
--- a/community/swtpm/APKBUILD
+++ b/community/swtpm/APKBUILD
@@ -12,7 +12,7 @@ makedepends="autoconf automake bash expect gawk gnutls gnutls-dev gnutls-utils
 	python3 socat
 	"
 subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/stefanberger/swtpm/archive/v$pkgver.tar.gz"
 options="!check" # needs /dev/tpm0 among others
 
 prepare() {
diff --git a/community/sxiv/APKBUILD b/community/sxiv/APKBUILD
index 126ed6e4f45d..a0cf678b9cc4 100644
--- a/community/sxiv/APKBUILD
+++ b/community/sxiv/APKBUILD
@@ -10,7 +10,7 @@ arch="all"
 license="GPL-2.0"
 makedepends="imlib2-dev giflib-dev libexif-dev libxft-dev"
 subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/muennich/sxiv/archive/v$pkgver.tar.gz"
 
 build() {
 	make -C "$builddir"
diff --git a/community/xbanish/APKBUILD b/community/xbanish/APKBUILD
index 38edfa6be085..81e47cea2809 100644
--- a/community/xbanish/APKBUILD
+++ b/community/xbanish/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
 license="ISC"
 makedepends="libx11-dev libxt-dev libxfixes-dev libxi-dev"
 subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jcs/xbanish/archive/v$pkgver.tar.gz"
 
 build() {
 	make
diff --git a/community/xprintidle/APKBUILD b/community/xprintidle/APKBUILD
index 95aabfa4d81e..f3cb96a8e48f 100644
--- a/community/xprintidle/APKBUILD
+++ b/community/xprintidle/APKBUILD
@@ -8,7 +8,7 @@ arch="all"
 license="GPL-2.0-only"
 makedepends="meson libx11-dev libxext-dev libxscrnsaver-dev"
 subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/g0hl1n/xprintidle/archive/refs/tags/$pkgver.tar.gz"
 
 build() {
 	abuild-meson . output
diff --git a/community/xwallpaper/APKBUILD b/community/xwallpaper/APKBUILD
index c0f5893c9f37..0b503af573f7 100644
--- a/community/xwallpaper/APKBUILD
+++ b/community/xwallpaper/APKBUILD
@@ -19,7 +19,7 @@ makedepends="
 	"
 options="!check" # no test suite
 subpackages="$pkgname-doc $pkgname-zsh-completion"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/stoeckmann/xwallpaper/archive/v$pkgver.tar.gz"
 
 prepare() {
 	default_prepare
diff --git a/main/awall/APKBUILD b/main/awall/APKBUILD
index b27b75ece135..e9121d776fbe 100644
--- a/main/awall/APKBUILD
+++ b/main/awall/APKBUILD
@@ -14,7 +14,7 @@ depends="drill ipset iptables lua$_luaver lua$_luaver-alt-getopt
 	lua$_luaver-stringy lua$_luaver-lyaml xtables-addons"
 subpackages="$pkgname-masquerade $pkgname-policies"
 triggers="$pkgname.trigger=/usr/share/awall"
-source="$url/-/archive/v$pkgver/awall-v$pkgver.tar.bz2
+source="https://gitlab.alpinelinux.org/alpine/awall/-/archive/v$pkgver/awall-v$pkgver.tar.bz2
 	awall-init
 	setup-firewall
 	"
diff --git a/main/axel/APKBUILD b/main/axel/APKBUILD
index fbc459290229..328134d490fd 100644
--- a/main/axel/APKBUILD
+++ b/main/axel/APKBUILD
@@ -10,7 +10,7 @@ options="!check" # has no checks
 license="GPL-2.0-or-later WITH OpenSSL-Exception"
 makedepends="openssl-dev>3"
 subpackages="$pkgname-doc"
-source="$url/releases/download/v$pkgver/axel-$pkgver.tar.xz"
+source="https://github.com/axel-download-accelerator/axel/releases/download/v$pkgver/axel-$pkgver.tar.xz"
 
 # secfixes:
 #   2.17.8-r0:
diff --git a/main/ddate/APKBUILD b/main/ddate/APKBUILD
index a76c8b51c8a4..8413817bd0bc 100644
--- a/main/ddate/APKBUILD
+++ b/main/ddate/APKBUILD
@@ -10,7 +10,7 @@ license="Public-Domain"
 options="!check" # no testsuite
 makedepends="cmake samurai"
 subpackages="$pkgname-doc"
-source="ddate-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="ddate-$pkgver.tar.gz::https://github.com/bo0ts/ddate/archive/v$pkgver.tar.gz"
 
 build() {
 	cmake -B build -G Ninja \
diff --git a/main/dmvpn/APKBUILD b/main/dmvpn/APKBUILD
index 40c0bc375f49..717e61134290 100644
--- a/main/dmvpn/APKBUILD
+++ b/main/dmvpn/APKBUILD
@@ -16,7 +16,7 @@ depends="augeas bind-tools lua5.2 lua5.2-cqueues lua5.2-lyaml lua5.2-ossl
 	lua5.2-posix lua5.2-struct lua-dmvpn quagga strongswan tunnel"
 subpackages="dmvpn-ca dmvpn-crl-dp lua-dmvpn"
 options="!check"
-source="$url/snapshot/dmvpn-tools-$pkgver.tar.bz2
+source="https://git.alpinelinux.org/cgit/dmvpn-tools//snapshot/dmvpn-tools-$pkgver.tar.bz2
 	dmvpn-ca.insync"
 builddir="$srcdir/dmvpn-tools-$pkgver"
 
diff --git a/main/hiredis/APKBUILD b/main/hiredis/APKBUILD
index fe318661e49d..ba814f473231 100644
--- a/main/hiredis/APKBUILD
+++ b/main/hiredis/APKBUILD
@@ -10,7 +10,7 @@ license="BSD-3-Clause"
 makedepends="openssl-dev>3"
 checkdepends="redis"
 subpackages="$pkgname-ssl $pkgname-dev"
-source="$pkgname-$pkgver-99.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver-99.tar.gz::https://github.com/redis/hiredis/archive/v$pkgver.tar.gz"
 options="!check" # fail with redis 7 for now for some reason
 
 build() {
diff --git a/main/lua-asn1/APKBUILD b/main/lua-asn1/APKBUILD
index c10a2adec6c5..af67b4864926 100644
--- a/main/lua-asn1/APKBUILD
+++ b/main/lua-asn1/APKBUILD
@@ -8,7 +8,7 @@ url=https://github.com/kunkku/lua-asn1
 arch=noarch
 license=MIT
 depends=lua-stringy
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kunkku/lua-asn1/archive/v$pkgver.tar.gz"
 
 package() {
 	make install "ROOT_DIR=$pkgdir"
diff --git a/main/lua-schema/APKBUILD b/main/lua-schema/APKBUILD
index b5ab169859ad..a19e369b5d75 100644
--- a/main/lua-schema/APKBUILD
+++ b/main/lua-schema/APKBUILD
@@ -11,7 +11,7 @@ url="https://github.com/sschoener/lua-schema"
 arch="noarch"
 license="MIT"
 makedepends="lua5.2 lua5.3 lua5.4"
-source="lua-schema-$_commit.tar.gz::$url/archive/$_commit.tar.gz"
+source="lua-schema-$_commit.tar.gz::https://github.com/sschoener/lua-schema/archive/$_commit.tar.gz"
 builddir="$srcdir/$pkgname-$_commit"
 options="!check"
 
diff --git a/main/tiny-cloud/APKBUILD b/main/tiny-cloud/APKBUILD
index 08d8aa34c05d..8ac181951dd3 100644
--- a/main/tiny-cloud/APKBUILD
+++ b/main/tiny-cloud/APKBUILD
@@ -12,7 +12,7 @@ checkdepends="kyua xz lz4 zstd"
 depends="e2fsprogs-extra partx sfdisk yx openssh-server"
 install="$pkgname.pre-upgrade"
 source="
-	$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz
+	https://gitlab.alpinelinux.org/alpine/cloud/tiny-cloud/-/archive/$pkgver/$pkgname-$pkgver.tar.gz
 
 	$pkgname-alpine.post-install
 	$pkgname-aws.post-install
diff --git a/testing/afetch/APKBUILD b/testing/afetch/APKBUILD
index 1a63b85d9c11..0173dabe25d6 100644
--- a/testing/afetch/APKBUILD
+++ b/testing/afetch/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
 license="GPL-3.0-or-later"
 subpackages="$pkgname-doc"
 options="!check" # there is no test suite
-source="$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/V$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/13-CF/afetch/archive/refs/tags/V$pkgver.tar.gz"
 
 build() {
 	make
diff --git a/testing/cgo/APKBUILD b/testing/cgo/APKBUILD
index c0c87087d41d..107a941b9ea9 100644
--- a/testing/cgo/APKBUILD
+++ b/testing/cgo/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
 license="0BSD"
 subpackages="$pkgname-doc"
 options="!check" # there is no test suite
-source="$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kieselsteini/cgo/archive/refs/tags/v$pkgver.tar.gz"
 
 build() {
 	make
diff --git a/testing/devmem2/APKBUILD b/testing/devmem2/APKBUILD
index ed33fe8108f0..35164d6a0718 100644
--- a/testing/devmem2/APKBUILD
+++ b/testing/devmem2/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Program to read/write from/to any location in memory"
 url="https://github.com/VCTLabs/devmem2"
 arch="all"
 license="GPL-2.0-or-later"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/VCTLabs/devmem2/archive/$pkgver.tar.gz"
 options="!check" # No testsuite
 
 build() {
diff --git a/testing/disfetch/APKBUILD b/testing/disfetch/APKBUILD
index e18fd46c2a7d..15a8f5bb7889 100644
--- a/testing/disfetch/APKBUILD
+++ b/testing/disfetch/APKBUILD
@@ -9,7 +9,7 @@ url="https://github.com/q60/disfetch"
 arch="noarch"
 options="!check" # no tests
 license="MIT"
-source="$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/q60/disfetch/archive/refs/tags/$pkgver.tar.gz"
 
 package() {
 	make DESTDIR="$pkgdir" PREFIX=/usr install
diff --git a/testing/font-merriweather/APKBUILD b/testing/font-merriweather/APKBUILD
index 994aaa54dae7..6dcc212f8df9 100644
--- a/testing/font-merriweather/APKBUILD
+++ b/testing/font-merriweather/APKBUILD
@@ -10,7 +10,7 @@ arch="noarch"
 license="OFL-1.1"
 depends="fontconfig"
 options="!check"
-source="merriweather-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="merriweather-$pkgver.tar.gz::https://github.com/EbenSorkin/Merriweather/archive/v$pkgver.tar.gz"
 builddir="$srcdir/Merriweather-$pkgver"
 
 package() {
diff --git a/testing/innernet/APKBUILD b/testing/innernet/APKBUILD
index dafcfdc36440..048fb1afe213 100644
--- a/testing/innernet/APKBUILD
+++ b/testing/innernet/APKBUILD
@@ -9,7 +9,7 @@ url="https://github.com/tonarino/innernet"
 license="MIT"
 makedepends="cargo clang-dev sqlite-dev"
 source="
-	$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz
+	https://github.com/tonarino/innernet/archive/v$pkgver/$pkgname-$pkgver.tar.gz
 	unbundle-sqlite.patch
 	innernet.initd
 	innernet.confd
diff --git a/testing/lua-inet/APKBUILD b/testing/lua-inet/APKBUILD
index 153d1b2f0d65..b02b55e15c0d 100644
--- a/testing/lua-inet/APKBUILD
+++ b/testing/lua-inet/APKBUILD
@@ -10,7 +10,7 @@ arch="noarch"
 license="LGPL-3.0-only"
 depends="lua-lpeg"
 checkdepends="lua5.2 lua5.3 luacheck"
-source="$pkgname-$pkgver.tar.gz::$url/snapshot/$_gittag.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://git.2e8.dk/lua-inet//snapshot/$_gittag.tar.gz
 	luacheck.patch"
 builddir="$srcdir/$_gittag"
 
diff --git a/testing/mkg3a/APKBUILD b/testing/mkg3a/APKBUILD
index 23e47205347d..b41ba76cc127 100644
--- a/testing/mkg3a/APKBUILD
+++ b/testing/mkg3a/APKBUILD
@@ -10,7 +10,7 @@ license="Zlib"
 makedepends="libpng-dev cmake"
 subpackages="$pkgname-doc"
 options="!check" # there is no test suite
-source="$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/mkg3a-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/taricorp/mkg3a/-/archive/$pkgver/mkg3a-$pkgver.tar.gz"
 
 build() {
 	if [ "$CBUILD" != "$CHOST" ]; then
diff --git a/testing/pfetch/APKBUILD b/testing/pfetch/APKBUILD
index 667cf2b7b6ad..92799f786f34 100644
--- a/testing/pfetch/APKBUILD
+++ b/testing/pfetch/APKBUILD
@@ -8,7 +8,7 @@ url="https://github.com/dylanaraps/pfetch"
 arch="noarch"
 license="MIT"
 options="!check" # There is no test suite
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dylanaraps/pfetch/archive/$pkgver.tar.gz"
 
 package() {
 	install -Dm755 pfetch "$pkgdir"/usr/bin/pfetch
diff --git a/testing/pipe-viewer/APKBUILD b/testing/pipe-viewer/APKBUILD
index 304313ebd2d5..5dc132a56a93 100644
--- a/testing/pipe-viewer/APKBUILD
+++ b/testing/pipe-viewer/APKBUILD
@@ -18,7 +18,7 @@ depends="
 	"
 checkdepends="perl-test-pod"
 subpackages="$pkgname-doc $pkgname-gtk"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/trizen/pipe-viewer/archive/$pkgver.tar.gz"
 
 build() {
 	perl Build.PL --gtk3
diff --git a/testing/py3-enzyme/APKBUILD b/testing/py3-enzyme/APKBUILD
index 1d5297b94aaf..f3fcd28b1b8d 100644
--- a/testing/py3-enzyme/APKBUILD
+++ b/testing/py3-enzyme/APKBUILD
@@ -12,7 +12,7 @@ depends="python3"
 makedepends="py3-setuptools"
 checkdepends="py3-pytest py3-requests py3-yaml"
 subpackages="$pkgname-pyc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Diaoul/enzyme/archive/$pkgver.tar.gz"
 builddir="$srcdir/$_pkgname-$pkgver"
 
 build() {
diff --git a/testing/py3-pysrt/APKBUILD b/testing/py3-pysrt/APKBUILD
index 18819bfe90a8..630392beaa64 100644
--- a/testing/py3-pysrt/APKBUILD
+++ b/testing/py3-pysrt/APKBUILD
@@ -12,7 +12,7 @@ depends="python3 py3-chardet"
 makedepends="py3-setuptools"
 checkdepends="py3-nose"
 subpackages="$pkgname-pyc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/byroot/pysrt/archive/v$pkgver.tar.gz"
 builddir="$srcdir/$_pkgname-$pkgver"
 
 build() {
diff --git a/testing/subliminal/APKBUILD b/testing/subliminal/APKBUILD
index 2d21ca8c2ab1..0bf568a85aa1 100644
--- a/testing/subliminal/APKBUILD
+++ b/testing/subliminal/APKBUILD
@@ -26,7 +26,7 @@ depends="python3
 makedepends="py3-setuptools"
 checkdepends="python3-dev py3-pytest py3-pytest-runner libarchive-tools py3-vcrpy py3-sympy"
 subpackages="$pkgname-pyc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/Diaoul/subliminal/archive/$pkgver.tar.gz
 		tests.patch legendastv.patch"
 options="!check" # missing simpy
 
diff --git a/testing/tmux-resurrect/APKBUILD b/testing/tmux-resurrect/APKBUILD
index b179e1748355..80d28dc04cad 100644
--- a/testing/tmux-resurrect/APKBUILD
+++ b/testing/tmux-resurrect/APKBUILD
@@ -9,7 +9,7 @@ license="MIT"
 depends="tmux>=1.9 bash"
 options="!check" # Tests rely on symlinks to another package, broken in releases
 subpackages="$pkgname-doc"
-source="$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz
+source="https://github.com/tmux-plugins/tmux-resurrect/archive/v$pkgver/$pkgname-$pkgver.tar.gz
 	ps.patch"
 
 package() {
diff --git a/testing/topgit/APKBUILD b/testing/topgit/APKBUILD
index 7fc5292a4a9d..cdc7bdce4e3f 100644
--- a/testing/topgit/APKBUILD
+++ b/testing/topgit/APKBUILD
@@ -11,7 +11,7 @@ options="!check"
 depends="git gawk sed"
 makedepends="perl"
 subpackages="$pkgname-doc $pkgname-bash-completion"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mackyle/topgit/archive/$pkgname-$pkgver.tar.gz"
 builddir="$srcdir/$pkgname-$pkgname-$pkgver"
 
 build() {
diff --git a/testing/tremc/APKBUILD b/testing/tremc/APKBUILD
index 2dfe984a46e5..939885bdd842 100644
--- a/testing/tremc/APKBUILD
+++ b/testing/tremc/APKBUILD
@@ -10,7 +10,7 @@ license="GPL-3.0-only"
 depends="python3"
 options="!check" # no test suite
 subpackages="$pkgname-doc $pkgname-bash-completion $pkgname-zsh-completion"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tremc/tremc/archive/$pkgver.tar.gz"
 
 package() {
 	make PREFIX=/usr DESTDIR="$pkgdir" install
diff --git a/testing/wabt/APKBUILD b/testing/wabt/APKBUILD
index fe5ff1e6c6fb..53c85e66065f 100644
--- a/testing/wabt/APKBUILD
+++ b/testing/wabt/APKBUILD
@@ -17,7 +17,7 @@ makedepends="
 	"
 subpackages="$pkgname-doc"
 _wasm_c_api_commit="d9a80099d496b5cdba6f3fe8fc77586e0e505ddc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/WebAssembly/wabt/archive/$pkgver.tar.gz
 	wasm-c-api-$_wasm_c_api_commit.tar.gz::https://github.com/WebAssembly/wasm-c-api/archive/$_wasm_c_api_commit.tar.gz
 	"
 # Tests require vendored dependencies (as git submodules). Should be modified
diff --git a/testing/xcape/APKBUILD b/testing/xcape/APKBUILD
index 5ce43968ae36..b18b98e7f685 100644
--- a/testing/xcape/APKBUILD
+++ b/testing/xcape/APKBUILD
@@ -10,7 +10,7 @@ license="GPL-3.0"
 options="!check" # no test suite
 makedepends="libxtst-dev"
 subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/alols/xcape/archive/v$pkgver.tar.gz"
 
 build() {
 	make
diff --git a/testing/xkb-switch/APKBUILD b/testing/xkb-switch/APKBUILD
index 358e50cf9f79..19e104483e3f 100644
--- a/testing/xkb-switch/APKBUILD
+++ b/testing/xkb-switch/APKBUILD
@@ -10,7 +10,7 @@ license="GPL-3.0-or-later"
 options="!check"
 makedepends="cmake libx11-dev libxkbfile-dev"
 subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/grwlf/xkb-switch/archive/$pkgver.tar.gz"
 
 prepare() {
 	default_prepare
diff --git a/testing/youtube-viewer/APKBUILD b/testing/youtube-viewer/APKBUILD
index 0ca1e17429e2..09af895ee36a 100644
--- a/testing/youtube-viewer/APKBUILD
+++ b/testing/youtube-viewer/APKBUILD
@@ -18,7 +18,7 @@ depends="
 	"
 checkdepends="perl-test-pod"
 subpackages="$pkgname-doc $pkgname-gtk"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/trizen/youtube-viewer/archive/$pkgver.tar.gz"
 
 build() {
 	perl Build.PL --gtk3
-- 
GitLab