diff --git a/testing/py3-pytest-rerunfailures/APKBUILD b/testing/py3-pytest-rerunfailures/APKBUILD
index fb9a8ea9642c222288895057c80a5626c0a61d2b..117c87caa378f1b3597678e4a737acf0071ce752 100644
--- a/testing/py3-pytest-rerunfailures/APKBUILD
+++ b/testing/py3-pytest-rerunfailures/APKBUILD
@@ -1,29 +1,32 @@
 # Contributor: Philipp Glaum <p@pglaum.de>
 # Maintainer: Philipp Glaum <p@pglaum.de>
 pkgname=py3-pytest-rerunfailures
-_pkgname=pytest-rerunfailures
-pkgver=9.1.1
-pkgrel=2
+_pkgname=${pkgname#py3-}
+pkgver=10.2
+pkgrel=0
 pkgdesc="Pytest plugin to re-run tests to eliminate flaky failures"
 url="https://pypi.org/project/pytest-rerunfailures/"
 arch="noarch"
 license="MPL-2.0"
 depends="python3 py3-pytest"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-build py3-installer py3-wheel"
 checkdepends="py3-mock"
 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
 builddir="$srcdir/$_pkgname-$pkgver"
 
 build() {
-	python3 setup.py build
+	python3 -m build --no-isolation --wheel
 }
 
 check() {
-	py.test-3
+	python3 -m pytest
 }
 
 package() {
-	python3 setup.py install --prefix=/usr --root="$pkgdir"
+	python3 -m installer -d "$pkgdir" \
+		dist/${_pkgname/-/_}-$pkgver-py3-none-any.whl
 }
 
-sha512sums="875591306ab010494ccbb865ea6445ab37422fce9105260d9495215af44057210564aca4fed3b4765b5a30c1cbef120de716d15d10a6db91dcb7d9f5b4f3b102  pytest-rerunfailures-9.1.1.tar.gz"
+sha512sums="
+8830610276e2cc172ee372ae4d8376bc6329138751ea2737a4def6af32d05c112c872a7a180ff554018058c05ed0d109927dbac61f748586257e40b0243f03c8  pytest-rerunfailures-10.2.tar.gz
+"