diff --git a/main/check/APKBUILD b/main/check/APKBUILD
index 470c825ece38e5f581204a24097a1cc25044564d..0b6c5bc691bebae9471739f3e9faff7d93cc6a4c 100644
--- a/main/check/APKBUILD
+++ b/main/check/APKBUILD
@@ -7,10 +7,17 @@ pkgdesc="A unit test framework for C"
 url="https://libcheck.github.io/check/"
 arch="all"
 license="LGPL-2.0-or-later"
-makedepends="pkgconfig"
+makedepends="pkgconfig texinfo autoconf automake libtool"
 checkdepends="diffutils gawk"
 subpackages="$pkgname-doc $pkgname-dev"
-source="https://github.com/libcheck/check/releases/download/$pkgver/check-$pkgver.tar.gz"
+source="https://github.com/libcheck/check/releases/download/$pkgver/check-$pkgver.tar.gz
+	do-not-check-for-tex.patch"
+
+prepare() {
+	default_prepare
+	cd "$builddir"
+	autoreconf -vfi
+}
 
 build() {
 	cd "$builddir"
@@ -20,7 +27,8 @@ build() {
 		--prefix=/usr \
 		--sysconfdir=/etc \
 		--mandir=/usr/share/man \
-		--localstatedir=/var
+		--localstatedir=/var \
+		--enable-build-docs
 	make
 }
 
@@ -34,4 +42,5 @@ package() {
 	make DESTDIR="$pkgdir" install
 }
 
-sha512sums="9e3a3b4b2e1aae02f6481a3d944a5a9216c1f03d85a2bbd63c05d047095fe16b78e5c4094b464fe531650daba24c58d7343f7ec059ce0e127e9aff1ff86213d0  check-0.13.0.tar.gz"
+sha512sums="9e3a3b4b2e1aae02f6481a3d944a5a9216c1f03d85a2bbd63c05d047095fe16b78e5c4094b464fe531650daba24c58d7343f7ec059ce0e127e9aff1ff86213d0  check-0.13.0.tar.gz
+79b421a3154f904350352a787801b4db337bd7fed728e613ee2aad8fc9cdbcfbf2c7ec476a2753780a773a3cb3b54e9e7a4ae1d2ea4bd641e1dd6730d389b628  do-not-check-for-tex.patch"
diff --git a/main/check/do-not-check-for-tex.patch b/main/check/do-not-check-for-tex.patch
new file mode 100644
index 0000000000000000000000000000000000000000..50b7b8e9d942e9c5ead033b75e0e99f2b2696028
--- /dev/null
+++ b/main/check/do-not-check-for-tex.patch
@@ -0,0 +1,23 @@
+Starting with check 0.13.0, check incorrectly checks for the tex instead
+of the makeinfo command for building documentation. 
+
+See:
+
+	* https://github.com/libcheck/check/issues/206
+	* https://github.com/libcheck/check/pull/212
+
+Without this change documentation files (the info page and example code)
+which were previously installed are no longer installed.
+
+diff -upr check-0.13.0.orig/configure.ac check-0.13.0/configure.ac
+--- check-0.13.0.orig/configure.ac	2019-10-25 17:17:54.361921908 +0200
++++ check-0.13.0/configure.ac	2019-10-25 17:18:13.101931933 +0200
+@@ -182,7 +182,7 @@ AC_CHECK_PROGS(LCOV, lcov, false)
+ AC_CHECK_PROGS(GENHTML, genhtml, false)
+ 
+ if test "xtrue" = x"$enable_build_docs"; then
+-    AC_CHECK_PROGS(TEX, tex, false)
++    AC_CHECK_PROGS(TEX, makeinfo, false)
+     if test "$TEX" = "false"; then
+         # Make it [somewhat] clear to maintainers that tex is missing. Not an error
+         # though because 'make install' (which users need) does not build the docs