diff --git a/testing/asuran-cli/APKBUILD b/testing/asuran-cli/APKBUILD
index 4d0a8d1a14bf3c7d28437e0ca114689187b5f662..bc33c22963cfcdfcc557f4c54b49794f287bbb87 100644
--- a/testing/asuran-cli/APKBUILD
+++ b/testing/asuran-cli/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.1.6
 pkgrel=1
 pkgdesc="Asuran is a new archive format and rust implementation"
 url="https://gitlab.com/asuran-rs/asuran"
-arch="all !s390x !mips !mips64"
+arch="all !s390x !mips !mips64 !riscv64"
 license="BSD-2-Clause-Patent"
 makedepends="cargo openssl-dev"
 source="https://gitlab.com/asuran-rs/asuran/-/archive/v$pkgver/asuran-v$pkgver.tar.gz"
diff --git a/testing/b3sum/APKBUILD b/testing/b3sum/APKBUILD
index 4065d331b4326d891173d62337328c3977a00f15..3fccbfb19f598b4fcef03d0d6203c47d267bfab5 100644
--- a/testing/b3sum/APKBUILD
+++ b/testing/b3sum/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.3.8
 pkgrel=0
 pkgdesc="Command line implementation of the BLAKE3 hash function"
 url="https://blake3.io"
-arch="all !s390x !armhf !mips !mips64" # armhf: 'vaddq_u32': target specific option mismatch
+arch="all !s390x !armhf !mips !mips64 !riscv64" # armhf: 'vaddq_u32': target specific option mismatch
 license="CC0-1.0 OR Apache-2.0"
 makedepends="cargo"
 source="b3sum-$pkgver.tar.gz::https://crates.io/api/v1/crates/b3sum/$pkgver/download"
diff --git a/testing/bitwarden_rs/APKBUILD b/testing/bitwarden_rs/APKBUILD
index 3eb2ea95239993bd55e8a82c99f7a407de502248..26986250d23c4a55e0939343623d4bb34d0ad190 100644
--- a/testing/bitwarden_rs/APKBUILD
+++ b/testing/bitwarden_rs/APKBUILD
@@ -7,7 +7,7 @@ pkgrel=1
 pkgdesc="bitwarden alternative backend"
 _bw_web_ver=2.17.1
 url="https://github.com/dani-garcia/bitwarden_rs"
-arch="all !ppc64le !s390x !mips !mips64" # ring crate has platform specific asm - no ppc support, no rust on s390x & mips*
+arch="all !ppc64le !s390x !mips !mips64 !riscv64" # ring crate has platform specific asm - no ppc support, no rust on s390x & mips*
 license="GPL-3.0-only"
 makedepends="rust cargo sqlite-dev postgresql-dev"
 install="$pkgname.pre-install"
diff --git a/testing/cargo-c/APKBUILD b/testing/cargo-c/APKBUILD
index 9e8e5cd65307c10171684830f174a633d3e5fc19..ffabfbbe25082b61ec16be4b0ad901d0ff2e8345 100644
--- a/testing/cargo-c/APKBUILD
+++ b/testing/cargo-c/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.9.0
 pkgrel=0
 pkgdesc="cargo subcommand to build and install C-ABI compatibile dynamic and static libraries"
 url="https://github.com/lu-zero/cargo-c"
-arch="all !s390x !mips !mips64" # no cargo for these archies
+arch="all !s390x !mips !mips64 !riscv64" # no cargo for these archies
 license="MIT"
 makedepends="cargo openssl-dev"
 subpackages="$pkgname-doc"
diff --git a/testing/castor/APKBUILD b/testing/castor/APKBUILD
index 9c100a92613ca1c049338d1c22a3ae8ef5b99771..0bc664660d4ec48ae1085dad40e1d6f42b082952 100644
--- a/testing/castor/APKBUILD
+++ b/testing/castor/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.8.16
 pkgrel=0
 pkgdesc="A graphical browser for Gemini, Gopher and Finger."
 url="https://sr.ht/~julienxx/Castor/"
-arch="all !s390x !mips !mips64" # limited by rust/cargo
+arch="all !s390x !mips !mips64 !riscv64" # limited by rust/cargo
 license="MIT"
 makedepends="rust cargo gtk+3.0-dev openssl-dev"
 source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~julienxx/castor/archive/$pkgver.tar.gz"
diff --git a/testing/delta/APKBUILD b/testing/delta/APKBUILD
index 0e22f7c22337965590efb2aff5f9e341d028202a..63eb056f8af86882eee4c3d4b7e1cf8b47d905a8 100644
--- a/testing/delta/APKBUILD
+++ b/testing/delta/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.8.2
 pkgrel=0
 pkgdesc="A viewer for git and diff output"
 url="https://github.com/dandavison/delta"
-arch="all !s390x !mips !mips64" # Limited by cargo
+arch="all !s390x !mips !mips64 !riscv64" # Limited by cargo
 license="MIT"
 makedepends="cargo"
 source="$pkgname-$pkgver.tar.gz::https://github.com/dandavison/delta/archive/$pkgver.tar.gz"
diff --git a/testing/diskus/APKBUILD b/testing/diskus/APKBUILD
index a6effdff5447aaafce46f1221862a54140989b20..388b282c422ecb8444506cf245728f583cb35b1c 100644
--- a/testing/diskus/APKBUILD
+++ b/testing/diskus/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.6.0
 pkgrel=0
 pkgdesc="fast alternative for du"
 url="https://github.com/sharkdp/diskus"
-arch="all !s390x !mips !mips64" # limited by cargo
+arch="all !s390x !mips !mips64 !riscv64" # limited by cargo
 options="!check" #size_of_single_file test timout on armhf
 license="MIT"
 makedepends="cargo"
diff --git a/testing/greetd/APKBUILD b/testing/greetd/APKBUILD
index 2c25f41646f2f96e00bcb7f37074f9cce02726e3..2fb2e0fd66b271b663b07a47f36378537b6841c0 100644
--- a/testing/greetd/APKBUILD
+++ b/testing/greetd/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.7.0
 pkgrel=0
 pkgdesc="Minimal and flexible login manager daemon"
 url="https://git.sr.ht/~kennylevinsen/greetd"
-arch="all !mips64 !s390x" # blocked by cargo
+arch="all !mips64 !s390x !riscv64" # blocked by cargo
 license="GPL-3.0-only"
 makedepends="cargo linux-pam-dev scdoc"
 install="$pkgname.pre-install"
diff --git a/testing/grpc-health-check/APKBUILD b/testing/grpc-health-check/APKBUILD
index 58729499a8cfa5dd793c673c3665f3d99e69c543..eadd39de33af46469e796d88bbfa4b3cbe4529d6 100644
--- a/testing/grpc-health-check/APKBUILD
+++ b/testing/grpc-health-check/APKBUILD
@@ -3,7 +3,7 @@
 pkgname=grpc-health-check
 pkgver=0.1.0
 pkgrel=0
-arch="all !s390x !ppc64le !armhf !armv7 !mips64"
+arch="all !s390x !ppc64le !armhf !armv7 !mips64 !riscv64"
 pkgdesc="gRPC health checking protocol"
 url="https://github.com/paypizza/grpc-health-check"
 license="Apache-2.0"
diff --git a/testing/i3status-rust/APKBUILD b/testing/i3status-rust/APKBUILD
index acce2bed8f8a572cc41a179286d5f9d24a294c59..778b84591791a62d5714323f791e0ebd0c63254e 100644
--- a/testing/i3status-rust/APKBUILD
+++ b/testing/i3status-rust/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.20.2
 pkgrel=0
 pkgdesc="i3status replacement in Rust"
 url="https://github.com/greshake/i3status-rust"
-arch="all !s390x !mips !mips64" # limited by cargo
+arch="all !s390x !mips !mips64 !riscv64" # limited by cargo
 license="GPL-3.0-only"
 makedepends="rust cargo dbus-dev openssl-dev libpulse"
 options="net !check" # no tests
diff --git a/testing/kak-lsp/APKBUILD b/testing/kak-lsp/APKBUILD
index a9d12e47c3067b5cb3c499e3fae20603c5246e9e..2e737dd829b2567e3eac032c137a0ecc498e8858 100644
--- a/testing/kak-lsp/APKBUILD
+++ b/testing/kak-lsp/APKBUILD
@@ -5,7 +5,7 @@ pkgver=9.0.0
 pkgrel=0
 pkgdesc="Language Server Protocol client for Kakoune implemented in Rust"
 url="https://github.com/kak-lsp/kak-lsp"
-arch="all !s390x !mips !mips64 !ppc64le" # limited by cargo
+arch="all !s390x !mips !mips64 !ppc64le !riscv64" # limited by cargo
 license="Unlicense OR MIT"
 makedepends="cargo"
 source="$pkgname-$pkgver.tar.gz::https://github.com/kak-lsp/kak-lsp/archive/v$pkgver.tar.gz"
diff --git a/testing/librespot/APKBUILD b/testing/librespot/APKBUILD
index 4b68d7fc9b9bb7d5e90b7d948bbf49193a4f193a..bb37b01fc60fb315ad7008ff921e560630ddeefe 100644
--- a/testing/librespot/APKBUILD
+++ b/testing/librespot/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.2.0
 pkgrel=0
 pkgdesc="Open Source Spotify client library"
 url="https://github.com/librespot-org/librespot"
-arch="all !s390x !mips64" # limited by cargo
+arch="all !s390x !mips64 !riscv64" # limited by cargo
 license="MIT"
 options="!check" # no test suite
 makedepends="cargo>=1.48 alsa-lib-dev"
diff --git a/testing/mdbook/APKBUILD b/testing/mdbook/APKBUILD
index f9d5e44643f4292ed935153fcdcf002cc6d76f24..815f4d314ceb54f43c2cb5d59bd215815d8b3da3 100644
--- a/testing/mdbook/APKBUILD
+++ b/testing/mdbook/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.4.9
 pkgrel=0
 pkgdesc="mdBook is a utility to create modern online books from Markdown files"
 url="https://rust-lang.github.io/mdBook/"
-arch="all !s390x !mips !mips64" # limited by cargo
+arch="all !s390x !mips !mips64 !riscv64" # limited by cargo
 license="MPL-2.0"
 makedepends="rust cargo"
 source="$pkgname-$pkgver.tar.gz::https://github.com/rust-lang-nursery/mdBook/archive/v$pkgver.tar.gz"
diff --git a/testing/mdcat/APKBUILD b/testing/mdcat/APKBUILD
index 4f4ffaa9fb9af18962f104e56ac613c9478fb14b..e438bf8319a019ef64b006b93d9b8ab51d0447b6 100644
--- a/testing/mdcat/APKBUILD
+++ b/testing/mdcat/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Cat for markdown"
 url="https://github.com/lunaryorn/mdcat"
 # s390x, mips, mips64 limited by cargo
 # ppc64le fails to build 'ring v0.16.19'
-arch="all !s390x !mips !mips64 !ppc64le"
+arch="all !s390x !mips !mips64 !ppc64le !riscv64"
 license="Apache-2.0"
 makedepends="asciidoctor cargo openssl-dev"
 checkdepends="py3-ansi2html"
diff --git a/testing/miniserve/APKBUILD b/testing/miniserve/APKBUILD
index b96320fdcbf10b0110352bd0372054330d3fffbd..b7d7758c544323f645d6546933723a8c8d91b5d5 100644
--- a/testing/miniserve/APKBUILD
+++ b/testing/miniserve/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
 pkgdesc="Quickly serve files via HTTP"
 url="https://github.com/svenstaro/miniserve"
 license="MIT"
-arch="all !s390x !mips64" # limited by rust/cargo
+arch="all !s390x !mips64 !riscv64" # limited by rust/cargo
 arch="$arch !ppc64le" # FTBFS
 makedepends="cargo"
 subpackages="$pkgname-bash-completion $pkgname-fish-completion $pkgname-zsh-completion"
diff --git a/testing/nushell/APKBUILD b/testing/nushell/APKBUILD
index a76a3a078ad1f9cef51495dabda0ad9eafa7a79f..5ee37b7d02780cd588d9d807ad6d034c6d46cc88 100644
--- a/testing/nushell/APKBUILD
+++ b/testing/nushell/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
 pkgdesc="A new type of shell"
 url="https://www.nushell.sh"
 # s390x, mips, mips64: limited by cargo
-arch="all !s390x !mips !mips64"
+arch="all !s390x !mips !mips64 !riscv64"
 license="MIT"
 makedepends="cargo pkgconf openssl-dev libx11-dev libxcb-dev libgit2-dev python3"
 source="$pkgname-$pkgver.tar.gz::https://github.com/nushell/nushell/archive/$pkgver.tar.gz"
diff --git a/testing/onefetch/APKBUILD b/testing/onefetch/APKBUILD
index 1291e196d4a5aea026cd6da5aa8bcaa65758741e..79ba537562ac7d480cd01f21f4d77a29d322717b 100644
--- a/testing/onefetch/APKBUILD
+++ b/testing/onefetch/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.9.1
 pkgrel=0
 pkgdesc="Git repository summary on your terminal"
 url="https://github.com/o2sh/onefetch"
-arch="all !s390x !mips !mips64"
+arch="all !s390x !mips !mips64 !riscv64"
 license="MIT"
 makedepends="cargo libgit2-dev zlib-dev"
 source="$pkgname-$pkgver.tar.gz::https://crates.io/api/v1/crates/onefetch/$pkgver/download"
diff --git a/testing/pastel/APKBUILD b/testing/pastel/APKBUILD
index cf8373b9bf3d7b6338ee7123e7fe18164f0a059a..007da740489660223035aea6f70380a9be710687 100644
--- a/testing/pastel/APKBUILD
+++ b/testing/pastel/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.8.0
 pkgrel=0
 pkgdesc="A command-line tool to generate, analyze, convert and manipulate colors"
 url="https://github.com/sharkdp/pastel"
-arch="all !s390x !mips !mips64" # rust/cargo
+arch="all !s390x !mips !mips64 !riscv64" # rust/cargo
 license="Apache-2.0"
 makedepends="rust cargo"
 source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/pastel/archive/v$pkgver.tar.gz"
diff --git a/testing/piping-server/APKBUILD b/testing/piping-server/APKBUILD
index eb591318246e0fee788681f41da1deec5f106b54..38134d5eebd47b4e26eb8aeeb49eb79e6c7907a4 100644
--- a/testing/piping-server/APKBUILD
+++ b/testing/piping-server/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
 pkgdesc="Infinitely transfer data between devices over HTTP"
 url="https://github.com/nwtgck/piping-server-rust"
 license="MIT"
-arch="all !s390x !mips64" # limited by cargo
+arch="all !s390x !mips64 !riscv64" # limited by cargo
 arch="$arch !ppc64le" # FTBFS
 makedepends="cargo"
 subpackages="$pkgname-openrc"
diff --git a/testing/procs/APKBUILD b/testing/procs/APKBUILD
index 4f98868f7674189b3eb0942d224d036a9739e1e9..248685b9f04d74ae09b0462824ae5cb9b1133c55 100644
--- a/testing/procs/APKBUILD
+++ b/testing/procs/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.11.8
 pkgrel=0
 pkgdesc="Modern replacement for ps written in Rust"
 url="https://github.com/dalance/procs"
-arch="all !mips64 !s390x" # limited by rust/cargo
+arch="all !mips64 !s390x !riscv64" # limited by rust/cargo
 license="MIT"
 options="net"
 makedepends="cargo"
diff --git a/testing/prometheus-wireguard-exporter/APKBUILD b/testing/prometheus-wireguard-exporter/APKBUILD
index 3a12f93b2f7ff12b6988d4d71ab9fe348e54da44..38e472e0ebe4ae435afef29a2458c4fe3aa65587 100644
--- a/testing/prometheus-wireguard-exporter/APKBUILD
+++ b/testing/prometheus-wireguard-exporter/APKBUILD
@@ -4,7 +4,7 @@ pkgver=3.2.1
 pkgrel=2
 pkgdesc="A Prometheus exporter for WireGuard, written in Rust"
 url="https://github.com/MindFlavor/prometheus_wireguard_exporter"
-arch="all !s390x !ppc64le !mips !mips64" #Crypto is broken (https://github.com/briansmith/ring/issues/389)
+arch="all !s390x !ppc64le !mips !mips64 !riscv64" #Crypto is broken (https://github.com/briansmith/ring/issues/389)
 license="MIT"
 makedepends="cargo"
 subpackages="$pkgname-openrc"
diff --git a/testing/rav1e/APKBUILD b/testing/rav1e/APKBUILD
index 7cfcfadc821d64b80147f7ff9c74dd04ee0f86fa..f59003a225f144d24d945a834f9e7e4341112202 100644
--- a/testing/rav1e/APKBUILD
+++ b/testing/rav1e/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.4.1
 pkgrel=0
 pkgdesc="The fastest and safest AV1 encoder"
 url="https://github.com/xiph/rav1e"
-arch="all !s390x !mips !mips64" # no cargo for s390x
+arch="all !s390x !mips !mips64 !riscv64" # no cargo for s390x
 arch="$arch !x86 !armv7 !armhf" # tests fail on these archies
 license="BSD-2-Clause custom"
 makedepends="cargo cargo-c nasm openssl-dev"
diff --git a/testing/rpg-cli/APKBUILD b/testing/rpg-cli/APKBUILD
index 00e2fe9e8ae1a96806cc6e67157ce8c6497b6420..3e493a4c5a345dcd6eb8b8d5d230a8520bf1b7b7 100644
--- a/testing/rpg-cli/APKBUILD
+++ b/testing/rpg-cli/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
 pkgdesc="Your filesystem as a dungeon!"
 url="https://github.com/facundoolano/rpg-cli"
 license="MIT"
-arch="all !s390x !mips64" # blocked by rust/cargo
+arch="all !s390x !mips64 !riscv64" # blocked by rust/cargo
 makedepends="cargo"
 source="https://github.com/facundoolano/rpg-cli/archive/$pkgver/rpg-cli-$pkgver.tar.gz"
 
diff --git a/testing/sccache/APKBUILD b/testing/sccache/APKBUILD
index ebde10dfaa85c8be420a24e73cb87830344547a1..78648a6d71f1984d8bed3741fe6aedffcaeecadb 100644
--- a/testing/sccache/APKBUILD
+++ b/testing/sccache/APKBUILD
@@ -7,7 +7,7 @@ url="https://github.com/mozilla/sccache/"
 # s390x & mips64: limited by cargo
 # ppc64le: not supported by ring crate
 # armhf: sigbus
-arch="all !s390x !mips64 !ppc64le !armhf"
+arch="all !s390x !mips64 !ppc64le !armhf !riscv64"
 license="Apache-2.0"
 makedepends="cargo openssl-dev"
 subpackages="$pkgname-doc"
diff --git a/testing/skim/APKBUILD b/testing/skim/APKBUILD
index 628d5ebff9a2554970188c777a41a2bb90547cdb..50ce1e9ebb219c7793d85939acecedde0ffc3c44 100644
--- a/testing/skim/APKBUILD
+++ b/testing/skim/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.9.4
 pkgrel=0
 pkgdesc="Fuzzy finder in rust"
 url="https://github.com/lotabout/skim"
-arch="all !s390x !mips !mips64" # limited by rust/cargo
+arch="all !s390x !mips !mips64 !riscv64" # limited by rust/cargo
 license="MIT"
 makedepends="cargo"
 options="net"
diff --git a/testing/synapse-bt/APKBUILD b/testing/synapse-bt/APKBUILD
index 1036a6a8cfa8ea413c6cd8f598f6b905b7614451..20eb2bb5f64a8aefe92567516d1e601063ed0cb0 100644
--- a/testing/synapse-bt/APKBUILD
+++ b/testing/synapse-bt/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.0
 pkgrel=2
 pkgdesc="Flexible and fast BitTorrent daemon"
 url="https://github.com/Luminarys/synapse"
-arch="all !aarch64 !s390x !mips !mips64" # Cargo (aarch64 due to MAP_32BIT)
+arch="all !aarch64 !s390x !mips !mips64 !riscv64" # Cargo (aarch64 due to MAP_32BIT)
 license="ISC"
 pkgusers="synapse-bt"
 pkggroups="synapse-bt"
diff --git a/testing/thunderbird/APKBUILD b/testing/thunderbird/APKBUILD
index 2a77afe9f8eb0a971b3d6787fe7628f669895c87..6fa4bbeb5297aaf674d55a8c23f5186508d9b656 100644
--- a/testing/thunderbird/APKBUILD
+++ b/testing/thunderbird/APKBUILD
@@ -10,7 +10,7 @@ url="https://www.thunderbird.net/"
 # s390x: limited by pipewire
 # armhf: build failure on armhf due to wasm
 # ppc64le: Rust SIGSEGVs when compiling gkrust
-arch="all !s390x !armhf !mips !mips64 !ppc64le"
+arch="all !s390x !armhf !mips !mips64 !ppc64le !riscv64"
 license="GPL-3.0-or-later AND LGPL-2.1-or-later AND MPL-2.0"
 options="!check"
 depends="
diff --git a/testing/twiggy/APKBUILD b/testing/twiggy/APKBUILD
index 191ecc1cd5949036b05aa8d2a63397e400f92d3b..2399ed5d80d45e5324d2d8ceb18e877ad6406ab2 100644
--- a/testing/twiggy/APKBUILD
+++ b/testing/twiggy/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.6.0
 pkgrel=1
 pkgdesc="Twiggy a code size profiler for Wasm"
 url="https://github.com/rustwasm/twiggy"
-arch="all !s390x !mips !mips64" # Limited by cargo
+arch="all !s390x !mips !mips64 !riscv64" # Limited by cargo
 license="Apache-2.0"
 makedepends="cargo"
 source="$pkgname-$pkgver.tar.gz::https://github.com/rustwasm/twiggy/archive/$pkgver.tar.gz"
diff --git a/testing/viu/APKBUILD b/testing/viu/APKBUILD
index 8bee6392263f8295e198e519a28e0cfe890c720e..2c77316f466e4128dbc66a562c40bba0d92f9d0d 100644
--- a/testing/viu/APKBUILD
+++ b/testing/viu/APKBUILD
@@ -3,7 +3,7 @@ pkgname=viu
 pkgver=1.3.0
 pkgrel=0
 pkgdesc="terminal image viewer"
-arch="all !s390x !mips64" # limited by cargo
+arch="all !s390x !mips64 !riscv64" # limited by cargo
 url="https://github.com/atanunq/viu"
 license="MIT"
 makedepends="cargo"
diff --git a/testing/vocage/APKBUILD b/testing/vocage/APKBUILD
index 4e4302d141f4719859975dd273b5522ad1e5729b..8338e69c45036e37cb35e437c05b52b07e85869d 100644
--- a/testing/vocage/APKBUILD
+++ b/testing/vocage/APKBUILD
@@ -4,7 +4,7 @@ pkgver=1.1.0
 pkgrel=0
 pkgdesc="Minimalistic terminal-based vocabulary-learning tool"
 url="https://github.com/proycon/vocage"
-arch="all !s390x !mips !mips64"
+arch="all !s390x !mips !mips64 !riscv64"
 license="GPL-3.0-or-later"
 makedepends="rust cargo"
 source="$pkgname-$pkgver.tar.gz::https://github.com/proycon/vocage/archive/refs/tags/v$pkgver.tar.gz"
diff --git a/testing/websocat/APKBUILD b/testing/websocat/APKBUILD
index a5e1cae306b1e8c9d793c4d61dc4b72e73ed261e..0104004a4a78d516068f1a3bc1058a1afa02495c 100644
--- a/testing/websocat/APKBUILD
+++ b/testing/websocat/APKBUILD
@@ -4,7 +4,7 @@ pkgver=1.7.0
 pkgrel=0
 pkgdesc="Netcat, curl and socat for WebSockets"
 url="https://github.com/vi/websocat"
-arch="all !s390x !mips !mips64" # Limited by cargo/rust
+arch="all !s390x !mips !mips64 !riscv64" # Limited by cargo/rust
 license="MIT"
 makedepends="cargo"
 options="net"
diff --git a/testing/zkgroup/APKBUILD b/testing/zkgroup/APKBUILD
index 8ad9050dc9f8e95e7c618afb687c8359acc67116..75a04f8c37e897aa7d0de614bc6f3374b7f47546 100644
--- a/testing/zkgroup/APKBUILD
+++ b/testing/zkgroup/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.7.2
 pkgrel=0
 pkgdesc="Library for the Signal Private Group System"
 url="https://github.com/signalapp/zkgroup"
-arch="all !s390x !mips !mips64 !ppc64le" # limited by cargo
+arch="all !s390x !mips !mips64 !ppc64le !riscv64" # limited by cargo
 license="GPL-3.0-only"
 makedepends="cargo"
 source="$pkgname-$pkgver.tar.gz::https://github.com/signalapp/zkgroup/archive/v$pkgver.tar.gz"