diff --git a/testing/php7-mongodb/APKBUILD b/testing/php7-mongodb/APKBUILD
index 1fdbe8703de53f0683da9f301bf0620c32cbd27e..4421d221c9635f11a5a7e01d1ec24b99bf7b78e9 100644
--- a/testing/php7-mongodb/APKBUILD
+++ b/testing/php7-mongodb/APKBUILD
@@ -19,17 +19,16 @@ options="!check"  # tests requires additional dependencies (vagrant)
 _builddir="$srcdir"/$_pkgreal-$_pkgver
 build() {
 	cd "$_builddir"
-	phpize7 || return 1
+	phpize7
 	./configure --prefix=/usr \
-		--with-php-config=/usr/bin/php-config7 \
-	|| return 1
-	make || return 1
+		--with-php-config=/usr/bin/php-config7
+	make
 }
 
 package() {
 	cd "$_builddir"
-	make INSTALL_ROOT="$pkgdir/" install || return 1
-	install -d "$pkgdir"/etc/php7/conf.d || return 1
+	make INSTALL_ROOT="$pkgdir/" install
+	install -d "$pkgdir"/etc/php7/conf.d
 	echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
 }