From 2de4ebb59a16fb96a9f7dff01b732593ffd121d3 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Fri, 9 Sep 2022 15:16:39 +0000
Subject: [PATCH] main/fuse3: upgrade to 3.12.0

---
 main/fuse3/APKBUILD | 14 +++++++++-----
 1 file changed, 9 insertions(+), 5 deletions(-)

diff --git a/main/fuse3/APKBUILD b/main/fuse3/APKBUILD
index 6aaaee6e29bb..15f30662209e 100644
--- a/main/fuse3/APKBUILD
+++ b/main/fuse3/APKBUILD
@@ -1,8 +1,8 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=fuse3
 _pkgname=fuse
-pkgver=3.11.0
-pkgrel=1
+pkgver=3.12.0
+pkgrel=0
 pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
 url="https://github.com/libfuse/libfuse"
 arch="all"
@@ -40,7 +40,10 @@ builddir="$srcdir"/$_pkgname-$pkgver
 #     - CVE-2018-10906
 
 build() {
-	abuild-meson --default-library=both . output
+	abuild-meson \
+		-Dinitscriptdir="" \
+		--default-library=both \
+		. output
 	meson compile ${JOBS:+-j ${JOBS}} -C output
 }
 
@@ -50,7 +53,8 @@ check() {
 
 package() {
 	DESTDIR="$pkgdir" meson install --no-rebuild -C output
-	rm -r "$pkgdir"/dev "$pkgdir"/etc/init.d
+
+	rm -r "$pkgdir"/dev
 
 	install -Dm755 "$srcdir"/fuse.initd "$pkgdir"/etc/init.d/fuse
 	# create config
@@ -80,7 +84,7 @@ _openrc() {
 }
 
 sha512sums="
-033324de7ea4c7e91fb21c453211c01e53771ec5805c2126e13ef2d4334119a51f5c783b6249e888e28888c753aa04b48ed33cefb6d486d8d526546565f6ae50  fuse-3.11.0.tar.xz
+b66232785fbe83ec32a9779542d085dc2c19f1fe0655e5f1e22e1a7add69795df40eb58da256a963537e64a9bf798ed8dfbc678f977fdd22567c5befa5b6ca04  fuse-3.12.0.tar.xz
 1a9e1d1e8a7b0778ffde328e4322c73b5d57ec98d52767c846d755cce861ab27989823a75b6c5f994432ddb77fa351dfa4a8f948c9467c5f7d5f471e4608358b  fix-realpath.patch
 7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1  fuse.initd
 "
-- 
GitLab