From 2da167275f9f34009de050988df4a259b27c8e55 Mon Sep 17 00:00:00 2001
From: Alex Dowad <alexinbeijing@gmail.com>
Date: Mon, 9 May 2022 14:49:29 +0200
Subject: [PATCH] community/luacheck: upgrade to 0.26.1

It seems that the original developer of luacheck has died and others
have had to fork the project to a different repository to continue
developing and maintaining it. Move to the new de-facto standard
repository.

Co-Authored-By: Jakub Jirutka <jakub@jirutka.cz>
---
 community/luacheck/APKBUILD | 24 +++++++++++++++++-------
 1 file changed, 17 insertions(+), 7 deletions(-)

diff --git a/community/luacheck/APKBUILD b/community/luacheck/APKBUILD
index a32ed53da512..f23947e9350e 100644
--- a/community/luacheck/APKBUILD
+++ b/community/luacheck/APKBUILD
@@ -1,16 +1,24 @@
 # Contributor: Jakub Jirutka <jakub@jirutka.cz>
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=luacheck
-pkgver=0.22.1
-pkgrel=1
+pkgver=0.26.1
+pkgrel=0
 pkgdesc="A tool for linting and static analysis of Lua code"
-url="https://github.com/mpeterv/luacheck"
+url="https://github.com/lunarmodules/luacheck"
 arch="noarch"
 license="MIT"
 _luaversion="5.1"
-depends="lua$_luaversion lua$_luaversion-filesystem"
-checkdepends="lua$_luaversion-busted"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mpeterv/luacheck/archive/$pkgver.tar.gz"
+depends="
+	lua$_luaversion
+	lua$_luaversion-argparse
+	lua$_luaversion-filesystem
+	"
+checkdepends="
+	lua$_luaversion-busted
+	lua$_luaversion-luautf8
+	lua$_luaversion-socket
+	"
+source="https://github.com/lunarmodules/luacheck/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
 
 check() {
 	busted-$_luaversion .
@@ -25,4 +33,6 @@ package() {
 	install -D -m 755 bin/$pkgname.lua "$pkgdir"/usr/bin/$pkgname
 }
 
-sha512sums="b4855331e848994242191138772ce55b07ebef98b616fdeda9c1549b71f539cd7e118dd06915edcf909f08334735924aebe356d4a7dd42a5d02bd5f5dd4f021d  luacheck-0.22.1.tar.gz"
+sha512sums="
+fdd9fea8e0028dfefac3b0b4699cebfc2d1bfc0b56e3e426886cb5763957ff1f83cbc2178d0eddbe9691145832284b1ddd89b176dada900de05fece09f233dfb  luacheck-0.26.1.tar.gz
+"
-- 
GitLab