From 2bb31b57f367ce754eeada62251916e59ba5ee14 Mon Sep 17 00:00:00 2001
From: Alexander Edland <s@ocv.me>
Date: Sun, 5 Aug 2018 04:35:42 +0200
Subject: [PATCH] testing/bchunk: new aport

---
 testing/bchunk/APKBUILD | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
 create mode 100644 testing/bchunk/APKBUILD

diff --git a/testing/bchunk/APKBUILD b/testing/bchunk/APKBUILD
new file mode 100644
index 000000000000..25eeaf74e2b3
--- /dev/null
+++ b/testing/bchunk/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Alexander Edland <alpine@ocv.me>
+# Maintainer: Alexander Edland <alpine@ocv.me>
+pkgname=bchunk
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="Convert bin+cue CD images to .iso and .cdr"
+url="https://github.com/hessu/bchunk"
+arch="all"
+license="GPL-2.0-or-later"
+options="!check"  # no test suite
+subpackages="$pkgname-doc"
+source="bchunk-$pkgver.tar.gz::https://github.com/hessu/bchunk/archive/release/$pkgver.tar.gz"
+builddir="$srcdir/bchunk-release-$pkgver"
+
+build() {
+	cd "$builddir"
+	make
+}
+
+package() {
+	cd "$builddir"
+	mkdir -p \
+		"$pkgdir/usr/bin" \
+		"$pkgdir/usr/share/man/man1"
+	
+	sed -ri '/^(BIN|MAN)_DIR /d' Makefile
+	make -j1 \
+		BIN_DIR="$pkgdir/usr/bin" \
+		MAN_DIR="$pkgdir/usr/share/man" \
+		install
+}
+
+sha512sums="d99f5a98944d6dab269865489843a39748b0fa1cd7dc5ec4e2a8d0ecc6223f196eed6c1d8d325822b4d548d9bb03eee151fdab7b867aaa79930f6e751175d459  bchunk-1.2.2.tar.gz"
-- 
GitLab