diff --git a/testing/fusesoc/APKBUILD b/testing/fusesoc/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..d534e24a33f9d6bafe25a947bb207ecb092f0f1d
--- /dev/null
+++ b/testing/fusesoc/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: Marian Buschsieweke <marian.buschsieweke@posteo.net>
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@posteo.net>
+pkgname=fusesoc
+pkgver=2.3
+pkgrel=0
+pkgdesc="Package manager and build abstraction tool for FPGA/ASIC development"
+url="https://github.com/olofk/fusesoc"
+license="BSD-2-Clause"
+arch="all"
+depends="
+	py3-edalize
+	py3-fastjsonschema
+	py3-okonomiyaki
+	py3-parsing
+	py3-simplesat
+	py3-yaml
+	python3
+	"
+makedepends="
+	py3-setuptools
+	py3-gpep517
+	py3-wheel
+	py3-installer
+	"
+checkdepends="
+	py3-pexpect
+	py3-pytest
+	"
+subpackages="
+	$pkgname-pyc
+	"
+source="
+	$pkgname-$pkgver.tar.gz::https://github.com/olofk/fusesoc/archive/refs/tags/$pkgver.tar.gz
+	"
+
+build() {
+	gpep517 build-wheel \
+		--wheel-dir dist \
+		--output-fd 3 3>&1 >&2
+}
+
+check() {
+	python3 -m venv --clear --without-pip --system-site-packages "$srcdir"/testenv
+	"$srcdir"/testenv/bin/python3 -m installer dist/*.whl
+
+	PATH="$srcdir/testenv/bin:$PATH" "$srcdir"/testenv/bin/python3 -m pytest -v
+}
+
+package() {
+	python3 -m installer -d "$pkgdir" \
+		"$builddir"/dist/*.whl
+}
+
+sha512sums="
+958dd104857a5aa638d919b1389b339726471c5119f8dcf371fe2dd51b8c8fc9b76323c5fa2245b9d04913ddae41180760cfa500635aa519189efb3a97928ec1  fusesoc-2.3.tar.gz
+"