diff --git a/community/waybar/0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch b/community/waybar/0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch
deleted file mode 100644
index 5803a18c2fcacdd7e6d60e3829b443811af99a45..0000000000000000000000000000000000000000
--- a/community/waybar/0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 3b507d63a07ab198d6499b5a49663bcc9346dcf0 Mon Sep 17 00:00:00 2001
-From: Clayton Craft <clayton@craftyguy.net>
-Date: Wed, 24 Apr 2024 23:51:32 -0700
-Subject: [PATCH] upower: fix segfault by initializing lastWarningLevel
-
-fixes bd8b215416cdca6ed0c929c18cede7dfb907edf0
----
- include/modules/upower/upower.hpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/include/modules/upower/upower.hpp b/include/modules/upower/upower.hpp
-index 8cea8c42..a5eb7209 100644
---- a/include/modules/upower/upower.hpp
-+++ b/include/modules/upower/upower.hpp
-@@ -71,7 +71,7 @@ class UPower : public AModule {
-   GDBusConnection *login1_connection;
-   std::unique_ptr<UPowerTooltip> upower_tooltip;
-   std::string lastStatus;
--  const char *lastWarningLevel;
-+  const char *lastWarningLevel = nullptr;
-   bool showAltText;
-   bool showIcon = true;
-   bool upowerRunning;
--- 
-2.44.0
-
diff --git a/community/waybar/APKBUILD b/community/waybar/APKBUILD
index 582f053f2f1d7b7ec5afa005c4c75351ee444729..8668fef8e6a3f4f050b8d3caddcccb79e0db55cb 100644
--- a/community/waybar/APKBUILD
+++ b/community/waybar/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Luca Weiss <luca@z3ntu.xyz>
 # Maintainer: Clayton Craft <clayton@craftyguy.net>
 pkgname=waybar
-pkgver=0.10.2
-pkgrel=3
+pkgver=0.10.3
+pkgrel=0
 pkgdesc="Highly customizable Wayland bar for Sway and Wlroots based compositors"
 url="https://github.com/Alexays/Waybar/"
 # s390x: no wireplumber (but who uses it there anyway)
@@ -32,7 +32,6 @@ makedepends="
 subpackages="$pkgname-doc"
 source="https://github.com/Alexays/Waybar/archive/$pkgver/Waybar-$pkgver.tar.gz
 	config-fix-clock.patch
-	0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch
 	"
 options="!check" # No test suite
 builddir="$srcdir/Waybar-$pkgver"
@@ -63,7 +62,6 @@ package() {
 }
 
 sha512sums="
-2ddcdc6cc7a41d4d9e06d7002aa501201a75350a114c86a931352c1dee1b0f435b06b5b534a92c3aa4771093932d43d0f1150a659561af39b9c3d98dcbed7724  Waybar-0.10.2.tar.gz
+2e90007056b79bccad06902db2e8b6f25103bb7c86736cb0b7dc260795bc4a1b5db7a7b8a4bebe9169f0590585fd6b170193cf8aa5437d69bab0f78d66922084  Waybar-0.10.3.tar.gz
 cd6fea7e9981e13ecb911da66b4f22e949542d4085d696e01d8d4eac0986e0ab15d5c1430040b76be730437a586dbe1f5c49ac8435269e6310fb2c213b6c74a2  config-fix-clock.patch
-ecac14b9c6d0e27e89f0a4a4eed0f0ddefa136dfbc9d80187efea770064583d0f014ac6acb12e95aac4dc98f9acd93c0ade0039356a1b1e9ba420924633abcea  0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch
 "