diff --git a/community/py3-gevent/APKBUILD b/community/py3-gevent/APKBUILD
index 79c6e77317d3275907663b45095edc83a962c5f4..63e07d64b2238cf4071d33a4f9b8e0cb3bba1069 100644
--- a/community/py3-gevent/APKBUILD
+++ b/community/py3-gevent/APKBUILD
@@ -37,6 +37,7 @@ provides="py-gevent=$pkgver-r$pkgrel" # Backwards compatibility
 build() {
 	export GEVENTSETUP_EMBED=0
 	export GEVENTSETUP_EMBED_LIBEV=0
+	export CFLAGS="$CFLAGS -Wno-incompatible-pointer-types"
 
 	gpep517 build-wheel \
 		--wheel-dir .dist \